aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-03-30 20:12:53 +0800
committerAkinori MUSHA <knu@FreeBSD.org>2002-03-30 20:12:53 +0800
commit380317bde9db6861d1d800cc1e9f44f21857bcee (patch)
tree7779cd09554e172da6706253f05a3e6e179c1986
parent48775a7604e95255ed935a46a7ffe919a74aa502 (diff)
downloadfreebsd-ports-gnome-380317bde9db6861d1d800cc1e9f44f21857bcee.tar.gz
freebsd-ports-gnome-380317bde9db6861d1d800cc1e9f44f21857bcee.tar.zst
freebsd-ports-gnome-380317bde9db6861d1d800cc1e9f44f21857bcee.zip
cd dir && command -> cd dir; command
-rw-r--r--databases/ruby-cdb/Makefile2
-rw-r--r--databases/ruby-gdbm/Makefile2
-rw-r--r--databases/ruby-search-namazu/Makefile4
-rw-r--r--graphics/ruby-ming/Makefile2
-rw-r--r--graphics/ruby-tgif/Makefile4
-rw-r--r--lang/ruby-mode.el/Makefile2
-rw-r--r--lang/ruby-python/Makefile2
-rw-r--r--lang/ruby-ri/Makefile2
-rw-r--r--lang/ruby-tcltklib/Makefile2
-rw-r--r--textproc/ruby-rd-mode.el/Makefile2
-rw-r--r--www/ruby-webunit/Makefile4
-rw-r--r--x11-toolkits/ruby-tk/Makefile2
12 files changed, 15 insertions, 15 deletions
diff --git a/databases/ruby-cdb/Makefile b/databases/ruby-cdb/Makefile
index e8b98cd699e5..44ddfed7d8a4 100644
--- a/databases/ruby-cdb/Makefile
+++ b/databases/ruby-cdb/Makefile
@@ -28,7 +28,7 @@ INSTALL_TARGET= site-install
post-extract:
${RM} -f ${WRKSRC}/cdb
- ${LN} -s `cd ${CDB_PORTDIR} && ${MAKE} -V WRKSRC` ${WRKSRC}/cdb
+ ${LN} -s `cd ${CDB_PORTDIR}; ${MAKE} -V WRKSRC` ${WRKSRC}/cdb
post-install:
.if !defined(NOPORTDOCS)
diff --git a/databases/ruby-gdbm/Makefile b/databases/ruby-gdbm/Makefile
index 59ca275b1f62..d1cc6264c34e 100644
--- a/databases/ruby-gdbm/Makefile
+++ b/databases/ruby-gdbm/Makefile
@@ -24,7 +24,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
do-extract:
${MKDIR} ${WRKDIR}
- ${LN} -sf `cd ${PORTSDIR}/${RUBY_PORT} && ${MAKE} -V WRKDIR`/${PORTNAME} ${WRKDIR}/
+ ${LN} -sf `cd ${PORTSDIR}/${RUBY_PORT}; ${MAKE} -V WRKDIR`/${PORTNAME} ${WRKDIR}/
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/databases/ruby-search-namazu/Makefile b/databases/ruby-search-namazu/Makefile
index 850775862bd3..d4798f870ddb 100644
--- a/databases/ruby-search-namazu/Makefile
+++ b/databases/ruby-search-namazu/Makefile
@@ -26,8 +26,8 @@ INSTALL_TARGET= site-install
post-build:
.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${RUBY_RD} search-namazu.en.rd > search-namazu.en.html
- cd ${WRKSRC} && ${RUBY_RD} search-namazu.ja.rd > search-namazu.ja.html
+ cd ${WRKSRC}; ${RUBY_RD} search-namazu.en.rd > search-namazu.en.html
+ cd ${WRKSRC}; ${RUBY_RD} search-namazu.ja.rd > search-namazu.ja.html
.endif
post-install:
diff --git a/graphics/ruby-ming/Makefile b/graphics/ruby-ming/Makefile
index cf6abc4075ae..e2331c059437 100644
--- a/graphics/ruby-ming/Makefile
+++ b/graphics/ruby-ming/Makefile
@@ -34,7 +34,7 @@ EXAMPLES= ../examples/rb/*.rb
do-extract:
${MKDIR} ${WRKDIR}
- ${LN} -s `cd ${PORTSDIR}/graphics/ming && ${MAKE} -V WRKDIR`/* ${WRKDIR}/
+ ${LN} -s `cd ${PORTSDIR}/graphics/ming; ${MAKE} -V WRKDIR`/* ${WRKDIR}/
post-extract:
${LN} -sf ../ming.i ${WRKSRC}/
diff --git a/graphics/ruby-tgif/Makefile b/graphics/ruby-tgif/Makefile
index 526840f5242d..47fbc7e44cf1 100644
--- a/graphics/ruby-tgif/Makefile
+++ b/graphics/ruby-tgif/Makefile
@@ -27,14 +27,14 @@ TGIF_PORT= graphics/tgif-nls
WRKSRC= ${WRKDIR}/ruby-${PORTNAME}-${PORTVERSION}
CONFIGURE_ARGS= --with-x-dir="${X11BASE}" \
- --with-ldflags=" `cd ${WRKSRC}/tgif && ${MAKE} -V LDOPTIONS -V LOCAL_LIBRARIES -V LDLIBS -V EXTRA_LOAD_FLAGS | paste -s -`"
+ --with-ldflags=" `cd ${WRKSRC}/tgif; ${MAKE} -V LDOPTIONS -V LOCAL_LIBRARIES -V LDLIBS -V EXTRA_LOAD_FLAGS | paste -s -`"
INSTALL_TARGET= site-install
DOCS_EN= README
DOCS_JA= ChangeLog.ja README.ja
post-extract:
- ${LN} -sf `cd ${PORTSDIR}/${TGIF_PORT} && ${MAKE} -V WRKSRC` ${WRKSRC}/tgif
+ ${LN} -sf `cd ${PORTSDIR}/${TGIF_PORT}; ${MAKE} -V WRKSRC` ${WRKSRC}/tgif
post-patch:
${RUBY} -i -pe 'gsub %r|\.\./|, "tgif/"' ${WRKSRC}/extconf.rb ${WRKSRC}/*.c
diff --git a/lang/ruby-mode.el/Makefile b/lang/ruby-mode.el/Makefile
index 9953ea66707c..adc596e0e414 100644
--- a/lang/ruby-mode.el/Makefile
+++ b/lang/ruby-mode.el/Makefile
@@ -27,7 +27,7 @@ XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
do-extract:
${MKDIR} ${WRKDIR}
- ${LN} -sf `cd ${PORTSDIR}/${RUBY_PORT} && ${MAKE} -V WRKSRC`/misc ${WRKSRC}
+ ${LN} -sf `cd ${PORTSDIR}/${RUBY_PORT}; ${MAKE} -V WRKSRC`/misc ${WRKSRC}
do-install:
${INSTALL_DATA} ${WRKSRC}/* ${RUBY_ELISPDIR}/
diff --git a/lang/ruby-python/Makefile b/lang/ruby-python/Makefile
index b8dc237f9809..01c4cb76db71 100644
--- a/lang/ruby-python/Makefile
+++ b/lang/ruby-python/Makefile
@@ -24,7 +24,7 @@ USE_RUBY= yes
USE_RUBY_EXTCONF= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-CONFIGURE_ARGS= --with-python-lib=`cd ${PYTHON_PORTSDIR} && ${MAKE} -V WRKSRC`
+CONFIGURE_ARGS= --with-python-lib=`cd ${PYTHON_PORTSDIR}; ${MAKE} -V WRKSRC`
INSTALL_TARGET= site-install
post-install:
diff --git a/lang/ruby-ri/Makefile b/lang/ruby-ri/Makefile
index 3dc8bb33aab9..763406b26cde 100644
--- a/lang/ruby-ri/Makefile
+++ b/lang/ruby-ri/Makefile
@@ -34,7 +34,7 @@ post-patch:
${WRKSRC}/contrib/dblack/emacs/ri.el
do-install:
- cd ${WRKSRC} && ${RUBY} install.rb
+ cd ${WRKSRC}; ${RUBY} install.rb
${INSTALL_DATA} ${WRKSRC}/contrib/dblack/emacs/Emacs.rb ${RUBY_SITELIBDIR}/${PORTNAME}/op/
${MKDIR} ${XEMACSLISPDIR}
.for f in ${ELISP_FILES}
diff --git a/lang/ruby-tcltklib/Makefile b/lang/ruby-tcltklib/Makefile
index 3e1703baee83..95a3e55ab8db 100644
--- a/lang/ruby-tcltklib/Makefile
+++ b/lang/ruby-tcltklib/Makefile
@@ -59,7 +59,7 @@ PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
do-extract:
${MKDIR} ${WRKDIR}
- ${LN} -sf `cd ${PORTSDIR}/${RUBY_PORT} && ${MAKE} -V WRKDIR`/${PORTNAME} ${WRKDIR}/
+ ${LN} -sf `cd ${PORTSDIR}/${RUBY_PORT}; ${MAKE} -V WRKDIR`/${PORTNAME} ${WRKDIR}/
post-install:
.if !defined(NOPORTDOCS)
diff --git a/textproc/ruby-rd-mode.el/Makefile b/textproc/ruby-rd-mode.el/Makefile
index c2d916da5199..5b1a8d06ef0f 100644
--- a/textproc/ruby-rd-mode.el/Makefile
+++ b/textproc/ruby-rd-mode.el/Makefile
@@ -28,7 +28,7 @@ XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
do-extract:
${MKDIR} ${WRKDIR}
- ${LN} -sf `cd ${.CURDIR}/../ruby-rdtool && ${MAKE} -V WRKSRC`/utils ${WRKSRC}
+ ${LN} -sf `cd ${.CURDIR}/../ruby-rdtool; ${MAKE} -V WRKSRC`/utils ${WRKSRC}
do-install:
${MKDIR} ${XEMACSLISPDIR}/
diff --git a/www/ruby-webunit/Makefile b/www/ruby-webunit/Makefile
index e00c0941e4b2..5f71f5b96da8 100644
--- a/www/ruby-webunit/Makefile
+++ b/www/ruby-webunit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= webunit
-PORTVERSION= 20011019
+PORTVERSION= 20011022
CATEGORIES= www textproc ruby
MASTER_SITES= http://xp.jbt.co.jp/download/webunit/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -31,7 +31,7 @@ DOCS_EN= index-en.html
DOCS_JA= index-ja.html TIPS-ja.html TODO-ja.sdf
do-install:
- cd ${WRKSRC} && ${RUBY} install.rb
+ cd ${WRKSRC}; ${RUBY} install.rb
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
.for f in ${EXAMPLES_EN}
diff --git a/x11-toolkits/ruby-tk/Makefile b/x11-toolkits/ruby-tk/Makefile
index 6585399c7ed2..5daa14679db5 100644
--- a/x11-toolkits/ruby-tk/Makefile
+++ b/x11-toolkits/ruby-tk/Makefile
@@ -38,7 +38,7 @@ PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
do-extract:
${MKDIR} ${WRKDIR}
- ${LN} -sf `cd ${PORTSDIR}/${RUBY_PORT} && ${MAKE} -V WRKDIR`/${PORTNAME} ${WRKDIR}/
+ ${LN} -sf `cd ${PORTSDIR}/${RUBY_PORT}; ${MAKE} -V WRKDIR`/${PORTNAME} ${WRKDIR}/
post-install:
.if !defined(NOPORTDOCS)