aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2010-09-16 00:36:09 +0800
committernivit <nivit@FreeBSD.org>2010-09-16 00:36:09 +0800
commit391245071146a3d76e2bce1ec5d5f5922be60471 (patch)
tree10c9f4b1d7a8c8e90915bbf3ab6ddbdb5624c3dd
parent75ddd50823b29913a96b9a6c4b6a92f7f6431695 (diff)
downloadfreebsd-ports-gnome-391245071146a3d76e2bce1ec5d5f5922be60471.tar.gz
freebsd-ports-gnome-391245071146a3d76e2bce1ec5d5f5922be60471.tar.zst
freebsd-ports-gnome-391245071146a3d76e2bce1ec5d5f5922be60471.zip
Distribute is intended to replace Setuptools as the standard method
for working with Python module distributions. The project has two goals: - Providing a backward compatible version to replace Setuptools and make all distributions that depend on Setuptools work as before, but with less bugs and behavioral issues. - Re-factoring the code, and releasing it in several distributions. This work is being done in the 0.7.x series but not yet released.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-distribute/Makefile29
-rw-r--r--devel/py-distribute/distinfo3
-rw-r--r--devel/py-distribute/files/patch-setuptools-command-easy_install.py11
-rw-r--r--devel/py-distribute/pkg-descr11
-rw-r--r--devel/py-distribute/pkg-plist6
6 files changed, 61 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4601e942d127..bcc85a8dfd85 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2685,6 +2685,7 @@
SUBDIR += py-dexml
SUBDIR += py-dialog
SUBDIR += py-distorm
+ SUBDIR += py-distribute
SUBDIR += py-distutils-extra
SUBDIR += py-durus
SUBDIR += py-dynrules
diff --git a/devel/py-distribute/Makefile b/devel/py-distribute/Makefile
new file mode 100644
index 000000000000..4e243d0724fa
--- /dev/null
+++ b/devel/py-distribute/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-distribute
+# Date created: 2010-05-06
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= distribute
+PORTVERSION= 0.6.14
+#PORTREVISION= 0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= A Python packages installer, and Setuptools replacement
+
+PLIST_SUB= PYVER=${PYTHON_VER} VERSION=${PORTVERSION} SETUPTOOLS_VER=0.6c11
+
+PYDISTUTILS_NOEGGINFO= yes
+# waiting for better times...
+PYEASYINSTALL_CMD= ${LOCALBASE}/bin/easy_install-${PYTHON_VER}
+CONFLICTS= ${PKGNAMEPREFIX}setuptools-[0-9]*
+# i.e. a support in bsd.python.mk
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-distribute/distinfo b/devel/py-distribute/distinfo
new file mode 100644
index 000000000000..bb10fe8a5567
--- /dev/null
+++ b/devel/py-distribute/distinfo
@@ -0,0 +1,3 @@
+MD5 (distribute-0.6.14.tar.gz) = ac607e05682116c06383b27a15e2db90
+SHA256 (distribute-0.6.14.tar.gz) = 16d5da8211d74eb11f2744c5945a3c7fcae9abbfebb56ea493f177a45d2e5bec
+SIZE (distribute-0.6.14.tar.gz) = 281527
diff --git a/devel/py-distribute/files/patch-setuptools-command-easy_install.py b/devel/py-distribute/files/patch-setuptools-command-easy_install.py
new file mode 100644
index 000000000000..a16daa2e02b8
--- /dev/null
+++ b/devel/py-distribute/files/patch-setuptools-command-easy_install.py
@@ -0,0 +1,11 @@
+--- setuptools/command/easy_install.py 2010-07-15 01:59:21.000000000 +0200
++++ setuptools/command/easy_install.py.port 2010-09-15 17:49:35.000000000 +0200
+@@ -688,7 +688,7 @@
+ return True
+ if not dist.has_metadata('zip-safe'):
+ return True
+- return True
++ return False
+
+ def maybe_move(self, spec, dist_filename, setup_base):
+ dst = os.path.join(self.build_directory, spec.key)
diff --git a/devel/py-distribute/pkg-descr b/devel/py-distribute/pkg-descr
new file mode 100644
index 000000000000..0cb0cb549277
--- /dev/null
+++ b/devel/py-distribute/pkg-descr
@@ -0,0 +1,11 @@
+Distribute is intended to replace Setuptools as the standard method
+for working with Python module distributions.
+
+ The project has two goals:
+
+ - Providing a backward compatible version to replace Setuptools
+ and make all distributions that depend on Setuptools work as
+ before, but with less bugs and behavioral issues.
+
+ - Re-factoring the code, and releasing it in several distributions.
+ This work is being done in the 0.7.x series but not yet released.
diff --git a/devel/py-distribute/pkg-plist b/devel/py-distribute/pkg-plist
new file mode 100644
index 000000000000..651977c770a2
--- /dev/null
+++ b/devel/py-distribute/pkg-plist
@@ -0,0 +1,6 @@
+bin/easy_install
+bin/easy_install-%%PYVER%%
+%%PYTHON_SITELIBDIR%%/distribute-%%VERSION%%-py%%PYVER%%.egg
+%%PYTHON_SITELIBDIR%%/easy-install.pth
+%%PYTHON_SITELIBDIR%%/setuptools-%%SETUPTOOLS_VER%%-py%%PYVER%%.egg-info
+%%PYTHON_SITELIBDIR%%/setuptools.pth