aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-06-16 07:49:22 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-06-16 07:49:22 +0800
commit3921fbb4cd7c67fa1f7e7a52e90bcd1fc072aab7 (patch)
tree1c0c6ddafc6a6075f8a5efcc8a55134f97d3902c
parent0197f68da04cbaf6a73d3f21b1da37eb34fde599 (diff)
downloadfreebsd-ports-gnome-3921fbb4cd7c67fa1f7e7a52e90bcd1fc072aab7.tar.gz
freebsd-ports-gnome-3921fbb4cd7c67fa1f7e7a52e90bcd1fc072aab7.tar.zst
freebsd-ports-gnome-3921fbb4cd7c67fa1f7e7a52e90bcd1fc072aab7.zip
- Add a patch I've forgotten to `cvs add` -> make the port respect PREFIX, LOCALBASE and CFLAGS
Reported by: QATty
-rw-r--r--games/vor/Makefile1
-rw-r--r--games/vor/files/patch-Makefile25
2 files changed, 26 insertions, 0 deletions
diff --git a/games/vor/Makefile b/games/vor/Makefile
index 9724f8e29f8d..338d6d7ab81c 100644
--- a/games/vor/Makefile
+++ b/games/vor/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vor
PORTVERSION= 0.5.4
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://qualdan.com/vor/ \
http://mirror.amdmi3.ru/
diff --git a/games/vor/files/patch-Makefile b/games/vor/files/patch-Makefile
new file mode 100644
index 000000000000..cf9a579bce57
--- /dev/null
+++ b/games/vor/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig 2009-05-29 07:45:20.000000000 +0400
++++ Makefile 2009-05-29 17:39:12.000000000 +0400
+@@ -15,19 +15,18 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+-prefix = /usr/local
++prefix = ${PREFIX}
+ exec_prefix = $(prefix)
+
+ datarootdir = $(prefix)/share
+ pkgdatadir = $(datarootdir)/vor
+ bindir = $(exec_prefix)/bin
+
+-CFLAGS := -Wall -O3
+ LDFLAGS :=
+
+ paths := -DDATA_PREFIX=\"$(pkgdatadir)\"
+-sdl-cflags := $(shell sdl-config --cflags)
+-sdl-ldflags := $(shell sdl-config --libs)
++sdl-cflags := $(shell $(SDL_CONFIG) --cflags)
++sdl-ldflags := $(shell $(SDL_CONFIG) --libs)
+
+ ldflags := $(sdl-ldflags) -lSDL_image -lSDL_mixer $(LDFLAGS)
+ cflags := $(sdl-cflags) $(paths) $(CFLAGS)