aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2014-05-21 02:55:12 +0800
committermakc <makc@FreeBSD.org>2014-05-21 02:55:12 +0800
commit39d55d6384f083c14d428e917453c2dcff7d4ea9 (patch)
treeb2d1581915d3955686b917b9aa542df997157641
parent1ee5c16c7f5adc2ab5cd6f0878b1666256f1092d (diff)
downloadfreebsd-ports-gnome-39d55d6384f083c14d428e917453c2dcff7d4ea9.tar.gz
freebsd-ports-gnome-39d55d6384f083c14d428e917453c2dcff7d4ea9.tar.zst
freebsd-ports-gnome-39d55d6384f083c14d428e917453c2dcff7d4ea9.zip
audio/mp3unicode:
- Update to 1.2.1 - Remove patch for DOCS option, which no longer needed in STAGEDIR era \o/
-rw-r--r--audio/mp3unicode/Makefile12
-rw-r--r--audio/mp3unicode/distinfo4
-rw-r--r--audio/mp3unicode/files/patch-Makefile.in12
-rw-r--r--audio/mp3unicode/files/patch-mp3unicode.cpp13
4 files changed, 10 insertions, 31 deletions
diff --git a/audio/mp3unicode/Makefile b/audio/mp3unicode/Makefile
index 3f52fdd80954..436c3da4fd3c 100644
--- a/audio/mp3unicode/Makefile
+++ b/audio/mp3unicode/Makefile
@@ -1,10 +1,9 @@
# $FreeBSD$
PORTNAME= mp3unicode
-PORTVERSION= 1.2
-PORTREVISION= 3
+PORTVERSION= 1.2.1
CATEGORIES= audio
-MASTER_SITES= SF
+MASTER_SITES= http://github.com/downloads/alonbl/mp3unicode/
MAINTAINER= makc@FreeBSD.org
COMMENT= ID3 tags charset converter
@@ -22,11 +21,4 @@ PORTDOCS= COPYING README
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-pre-configure:
-.if !${PORT_OPTIONS:MDOCS}
- ${REINPLACE_CMD} -e '/^install-data-am/s|install-dist_docDATA||' ${WRKSRC}/Makefile.in
-.endif
-
.include <bsd.port.mk>
diff --git a/audio/mp3unicode/distinfo b/audio/mp3unicode/distinfo
index 5fc8bbfbff28..28d0385114b2 100644
--- a/audio/mp3unicode/distinfo
+++ b/audio/mp3unicode/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mp3unicode-1.2.tar.bz2) = 7788dde056204d003f32f07aa99ed46b1599ecfc0e9e12c8b559fa1072ffb74b
-SIZE (mp3unicode-1.2.tar.bz2) = 95372
+SHA256 (mp3unicode-1.2.1.tar.bz2) = 375b432ce784407e74fceb055d115bf83b1bd04a83b95256171e1a36e00cfe07
+SIZE (mp3unicode-1.2.1.tar.bz2) = 101593
diff --git a/audio/mp3unicode/files/patch-Makefile.in b/audio/mp3unicode/files/patch-Makefile.in
deleted file mode 100644
index 74eb19bec302..000000000000
--- a/audio/mp3unicode/files/patch-Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./Makefile.in.orig 2007-09-28 23:07:40.000000000 +0400
-+++ ./Makefile.in 2008-05-26 21:32:34.000000000 +0400
-@@ -757,8 +757,7 @@
-
- info-am:
-
--install-data-am: install-dist_docDATA install-man \
-- install-nodist_htmlDATA
-+install-data-am: install-dist_docDATA install-man
-
- install-dvi: install-dvi-recursive
-
diff --git a/audio/mp3unicode/files/patch-mp3unicode.cpp b/audio/mp3unicode/files/patch-mp3unicode.cpp
index 9cb405af1513..164200b65130 100644
--- a/audio/mp3unicode/files/patch-mp3unicode.cpp
+++ b/audio/mp3unicode/files/patch-mp3unicode.cpp
@@ -1,12 +1,11 @@
---- ./mp3unicode.cpp.orig 2007-09-25 14:57:33.000000000 +0400
-+++ ./mp3unicode.cpp 2007-09-29 15:16:49.000000000 +0400
-@@ -200,9 +200,6 @@
+--- ./mp3unicode.cpp.orig 2012-05-07 12:03:19.000000000 +0000
++++ ./mp3unicode.cpp 2014-05-13 20:16:40.053475428 +0000
+@@ -229,7 +229,7 @@
if (
iconv (
cd,
--#if !defined(_LIBICONV_VERSION) || _LIBICONV_VERSION < 0x010B
-- (char **)
--#endif
- &from,
+- (char **)&from,
++ &from,
&from_size,
&to,
+ &to_size