aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-02-05 06:56:02 +0800
committermarino <marino@FreeBSD.org>2016-02-05 06:56:02 +0800
commit3a16c563d19aea81c91d2e824193015819aa9ec3 (patch)
treee8803c296be136dc7cb3d4ef1e5294de404de391
parent2f153138bc6fee3dc586a9f95891d97e6d4a9062 (diff)
downloadfreebsd-ports-gnome-3a16c563d19aea81c91d2e824193015819aa9ec3.tar.gz
freebsd-ports-gnome-3a16c563d19aea81c91d2e824193015819aa9ec3.tar.zst
freebsd-ports-gnome-3a16c563d19aea81c91d2e824193015819aa9ec3.zip
games/unnethack: document ncurses rqmt (USES+=ncurses), respect LDFLAGS
while here, set one CONFIGURE_ARG per line for readability and to respect 80 columns approved by: infrastructure blanket
-rw-r--r--games/unnethack/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/games/unnethack/Makefile b/games/unnethack/Makefile
index da0d13ce5049..da3e92e87ecf 100644
--- a/games/unnethack/Makefile
+++ b/games/unnethack/Makefile
@@ -10,14 +10,18 @@ MAINTAINER= knu@FreeBSD.org
COMMENT= New variant of NetHack
GNU_CONFIGURE= yes
-USES= gmake
+USES= gmake ncurses
MAKE_JOBS_UNSAFE= yes
VARDIR_REL= var/games/${PORTNAME}
VARDIR= ${PREFIX}/${VARDIR_REL}
-CONFIGURE_ARGS= --datadir="${DATADIR:H}" --localstatedir="${VARDIR:H}" --docdir="${DOCSDIR:H}" \
- --with-owner=no --with-group=no \
- --enable-data-librarian
+CONFIGURE_ARGS= --datadir="${DATADIR:H}" \
+ --localstatedir="${VARDIR:H}" \
+ --docdir="${DOCSDIR:H}" \
+ --with-owner=no \
+ --with-group=no \
+ --enable-data-librarian \
+ LFLAGS="${LDFLAGS}"
MAKE_ARGS= MANPREFIX="${STAGEDIR}${MANPREFIX}"
INSTALL_TARGET= install manpages
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall