aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2014-04-10 08:34:17 +0800
committernivit <nivit@FreeBSD.org>2014-04-10 08:34:17 +0800
commit3a3453df9a33f341fade7f5c1116d167eb5936a5 (patch)
tree8c6465e5ac05d4c362f1ef8cbd5a71c7fd3da6ae
parentb6d417344ba09941303d1c4b4952c5aa9c17b39a (diff)
downloadfreebsd-ports-gnome-3a3453df9a33f341fade7f5c1116d167eb5936a5.tar.gz
freebsd-ports-gnome-3a3453df9a33f341fade7f5c1116d167eb5936a5.tar.zst
freebsd-ports-gnome-3a3453df9a33f341fade7f5c1116d167eb5936a5.zip
- Update to 1.5.4
- Use GitHub as download site, so we can build docs - Build docs as HTML format with Sphinx - Add a regression-test target (not active at the moment, because some tests fail) - Update pkg-descr Release Notes: http://www.pip-installer.org/en/latest/news.html
-rw-r--r--devel/py-pip/Makefile34
-rw-r--r--devel/py-pip/distinfo4
-rw-r--r--devel/py-pip/pkg-descr2
-rw-r--r--devel/py-pip/pkg-plist78
4 files changed, 99 insertions, 19 deletions
diff --git a/devel/py-pip/Makefile b/devel/py-pip/Makefile
index 106806d093ce..03666735b19c 100644
--- a/devel/py-pip/Makefile
+++ b/devel/py-pip/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= pip
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.4
CATEGORIES= devel python
-MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
@@ -12,24 +11,47 @@ COMMENT= Tool for installing and managing Python packages
LICENSE= MIT
+GH_ACCOUNT= pypa
+GH_COMMIT= e3f9e25
+
OPTIONS_DEFINE= DOCS
-USES= shebangfix
-USE_PYTHON= yes
+USES= shebangfix
+USE_GITHUB= yes
+USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
+# This port installs the following file in shared dirs
+# PLIST_FILES= bin/pip
+
SHEBANG_FILES= pip/__init__.py
-python_OLD_CMD= /usr/bin/env python
+python_OLD_CMD= ${SETENV} python
python_CMD= ${PYTHON_CMD}
+.if 0
+TEST_DEPENDS= tox:${PORTSDIR}/devel/py-tox
+TOX_CMD= ${LOCALBASE}/bin/tox
+.endif
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS+= sphinx-build:${PORTSDIR}/textproc/py-sphinx
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+MAKE_ENV+= HOME=${WRKDIR}
+PYDISTUTILS_BUILD_TARGET+= build_sphinx -n --all-files --fresh-env
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/build/sphinx/html && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} "! -name .buildinfo -and ! -name objects.inv")
+.endif
+
+.if 0
+regression-test: build
+ @cd ${WRKSRC} && \
+ ${TOX_CMD} -e py${PYTHON_SUFFIX},docs
.endif
.include <bsd.port.mk>
diff --git a/devel/py-pip/distinfo b/devel/py-pip/distinfo
index bb00bf2fe37c..872af3641bbf 100644
--- a/devel/py-pip/distinfo
+++ b/devel/py-pip/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pip-1.5.2.tar.gz) = 2a8a3e08e652d3a40edbb39264bf01f8ff3c32520a79113357cca1f30533f738
-SIZE (pip-1.5.2.tar.gz) = 1079904
+SHA256 (pip-1.5.4.tar.gz) = 349c6a982ce4f2dc54afcb2f278de0e90bd9b3154f05f2716acfd27803b1a766
+SIZE (pip-1.5.4.tar.gz) = 7856822
diff --git a/devel/py-pip/pkg-descr b/devel/py-pip/pkg-descr
index 32164c693df0..2539248b5ea5 100644
--- a/devel/py-pip/pkg-descr
+++ b/devel/py-pip/pkg-descr
@@ -1,3 +1,5 @@
+The PyPA recommended tool for installing and managing Python packages.
+
pip is a replacement for easy_install. It uses mostly the same techniques
for finding packages, so packages that were made easy_installable should
be pip-installable as well.
diff --git a/devel/py-pip/pkg-plist b/devel/py-pip/pkg-plist
index 0c894c3715a8..6b3e535e4804 100644
--- a/devel/py-pip/pkg-plist
+++ b/devel/py-pip/pkg-plist
@@ -1,11 +1,67 @@
-%%PORTDOCS%%%%DOCSDIR%%/configuration.rst
-%%PORTDOCS%%%%DOCSDIR%%/cookbook.rst
-%%PORTDOCS%%%%DOCSDIR%%/development.rst
-%%PORTDOCS%%%%DOCSDIR%%/index.rst
-%%PORTDOCS%%%%DOCSDIR%%/installing.rst
-%%PORTDOCS%%%%DOCSDIR%%/logic.rst
-%%PORTDOCS%%%%DOCSDIR%%/news.rst
-%%PORTDOCS%%%%DOCSDIR%%/other-tools.rst
-%%PORTDOCS%%%%DOCSDIR%%/quickstart.rst
-%%PORTDOCS%%%%DOCSDIR%%/usage.rst
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%DOCSDIR%%/_sources/configuration.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/cookbook.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/development.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/distribute_setuptools.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/index.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/installing.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/logic.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/news.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/quickstart.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/index.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_freeze.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_install.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_list.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_search.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_show.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_uninstall.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/reference/pip_wheel.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/usage.txt
+%%PORTDOCS%%%%DOCSDIR%%/_sources/user_guide.txt
+%%PORTDOCS%%%%DOCSDIR%%/_static/ajax-loader.gif
+%%PORTDOCS%%%%DOCSDIR%%/_static/basic.css
+%%PORTDOCS%%%%DOCSDIR%%/_static/comment-bright.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/comment-close.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/comment.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/default.css
+%%PORTDOCS%%%%DOCSDIR%%/_static/doctools.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/down-pressed.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/down.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/file.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/jquery.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/minus.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/plus.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/pygments.css
+%%PORTDOCS%%%%DOCSDIR%%/_static/searchtools.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/sidebar.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/underscore.js
+%%PORTDOCS%%%%DOCSDIR%%/_static/up-pressed.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/up.png
+%%PORTDOCS%%%%DOCSDIR%%/_static/websupport.js
+%%PORTDOCS%%%%DOCSDIR%%/configuration.html
+%%PORTDOCS%%%%DOCSDIR%%/cookbook.html
+%%PORTDOCS%%%%DOCSDIR%%/development.html
+%%PORTDOCS%%%%DOCSDIR%%/distribute_setuptools.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/installing.html
+%%PORTDOCS%%%%DOCSDIR%%/logic.html
+%%PORTDOCS%%%%DOCSDIR%%/news.html
+%%PORTDOCS%%%%DOCSDIR%%/quickstart.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/index.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/pip.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/pip_freeze.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/pip_install.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/pip_list.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/pip_search.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/pip_show.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/pip_uninstall.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/pip_wheel.html
+%%PORTDOCS%%%%DOCSDIR%%/search.html
+%%PORTDOCS%%%%DOCSDIR%%/searchindex.js
+%%PORTDOCS%%%%DOCSDIR%%/usage.html
+%%PORTDOCS%%%%DOCSDIR%%/user_guide.html
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/reference
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/_static
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/_sources/reference
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%/_sources
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%