aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-18 02:21:04 +0800
committerantoine <antoine@FreeBSD.org>2014-02-18 02:21:04 +0800
commit3a858bfdff55640417eb6927fb5eb4fcbf2c82ba (patch)
tree073e04bfd7696ba0a8ae93a40f76470d02ce0706
parent6a80b526b1bb8d888bfd2fb3e5e65bd707af9df6 (diff)
downloadfreebsd-ports-gnome-3a858bfdff55640417eb6927fb5eb4fcbf2c82ba.tar.gz
freebsd-ports-gnome-3a858bfdff55640417eb6927fb5eb4fcbf2c82ba.tar.zst
freebsd-ports-gnome-3a858bfdff55640417eb6927fb5eb4fcbf2c82ba.zip
Stage support
-rw-r--r--java/trove4j/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/java/trove4j/Makefile b/java/trove4j/Makefile
index 6ed49098ed40..f4821acd6d21 100644
--- a/java/trove4j/Makefile
+++ b/java/trove4j/Makefile
@@ -15,22 +15,14 @@ USE_JAVA= yes
JAVA_VERSION= 1.6+
NO_BUILD= yes
-.if !defined(NOPORTDOCS)
PORTDOCS= javadocs AUTHORS ChangeLog LICENSE.txt README-license.txt README.txt
-.endif
JARFILE= trove.jar
PLIST_FILES+= %%JAVAJARDIR%%/${JARFILE}
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
- @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${JARFILE}..."
- @${INSTALL_DATA} ${WRKSRC}/lib/${JARFILE} ${JAVAJARDIR}/
- @${ECHO_MSG} " [ DONE ]"
-.if !defined(NOPORTDOCS)
- @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
- @cd ${WRKSRC} && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/{} \;
- @cd ${WRKSRC} && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
- @${ECHO_MSG} " [ DONE ]"
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/lib/${JARFILE} ${STAGEDIR}${JAVAJARDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>