aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-11-12 03:36:20 +0800
committernetchild <netchild@FreeBSD.org>2005-11-12 03:36:20 +0800
commit3b5a19c5946519ac65ac3da21ca204fb110696c5 (patch)
tree79ad9c42bfc22ee2adb174cea88a678264829004
parent61fd7d020a50caa634df146860890a9e1e0d3335 (diff)
downloadfreebsd-ports-gnome-3b5a19c5946519ac65ac3da21ca204fb110696c5.tar.gz
freebsd-ports-gnome-3b5a19c5946519ac65ac3da21ca204fb110696c5.tar.zst
freebsd-ports-gnome-3b5a19c5946519ac65ac3da21ca204fb110696c5.zip
- fix OpenSSL version check
- (hopefully) fix build on FreeBSD 4.x [1] - fix plist in the ClamAV case [2] - add SHA256 [2] Submitted by: "Herbert J. Skuhra" <h.skuhra@gmail.com> [2] Noticed by: YAPHR [1]
-rw-r--r--mail/claws-mail/Makefile3
-rw-r--r--mail/claws-mail/distinfo2
-rw-r--r--mail/claws-mail/files/patch-configure.ac2
-rw-r--r--mail/claws-mail/pkg-plist1
-rw-r--r--mail/sylpheed-claws/Makefile3
-rw-r--r--mail/sylpheed-claws/distinfo2
-rw-r--r--mail/sylpheed-claws/files/patch-configure.ac2
-rw-r--r--mail/sylpheed-claws/pkg-plist1
8 files changed, 12 insertions, 4 deletions
diff --git a/mail/claws-mail/Makefile b/mail/claws-mail/Makefile
index 923cf669624a..e58ee4cd3b60 100644
--- a/mail/claws-mail/Makefile
+++ b/mail/claws-mail/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sylpheed-claws
PORTVERSION= 1.9.100
+PORTREVISION= 1
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -167,7 +168,7 @@ post-patch:
s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/tools/README.sylprint ${WRKSRC}/tools/sylprint.pl
- @${REINPLACE_CMD} -e "s|po intl src|po src| ; s:@SYLPHEED_GNOME:#@SYLPHEED_GNOME:g" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|po intl src|po src| ; s:@SYLPHEED_GNOME:#@SYLPHEED_GNOME:g ; s:-Wno-unused-function::" ${WRKSRC}/Makefile.in
@for f in `${FIND} ${WRKSRC}/tools -type f -print`; do \
${REINPLACE_CMD} -e "s|/usr/bin/perl|${PERL}|" $$f; done
# @${LN} -s ${WRKSRC}/po/sylpheed.pot ${WRKSRC}/po/${PORTNAME}.pot
diff --git a/mail/claws-mail/distinfo b/mail/claws-mail/distinfo
index 603e78ac68a2..4f55fdc1b2a8 100644
--- a/mail/claws-mail/distinfo
+++ b/mail/claws-mail/distinfo
@@ -1,4 +1,6 @@
MD5 (sylpheed-claws-1.9.100.tar.bz2) = 863c314557f90f17c2f6d6a0ab57e6c2
+SHA256 (sylpheed-claws-1.9.100.tar.bz2) = f4bf3826925caa9d1d877345671c9fbb1c4990cea500eead505806e245bca78d
SIZE (sylpheed-claws-1.9.100.tar.bz2) = 3480063
MD5 (sylpheed-iconset-20040929.tar.gz) = d72cf03bf3d13cf9e2785eaca3807707
+SHA256 (sylpheed-iconset-20040929.tar.gz) = 11e791cf7187b5f3ac5a5ab5f0144d9ea8701bbc6182b30b35c30c2cc50e5210
SIZE (sylpheed-iconset-20040929.tar.gz) = 1298891
diff --git a/mail/claws-mail/files/patch-configure.ac b/mail/claws-mail/files/patch-configure.ac
index d9f0665cf1ac..8bc413ea4cd3 100644
--- a/mail/claws-mail/files/patch-configure.ac
+++ b/mail/claws-mail/files/patch-configure.ac
@@ -7,7 +7,7 @@
- PKG_CHECK_MODULES(OPENSSL, openssl >= 0.9.7, :, ac_cv_enable_openssl=no)
+ case $host_os in
+ *freebsd*)
-+ if [ $(openssl version | cut -d ' ' -f 2) \< 0.9.7 ]; then
++ if test $(openssl version | cut -d ' ' -f 2) \< 0.9.7 ; then
+ ac_cv_enable_openssl=no
+ else
+ OPENSSL_LIBS=${OPENSSL_LIBS-"-lcrypto -lssl"}
diff --git a/mail/claws-mail/pkg-plist b/mail/claws-mail/pkg-plist
index 3a23719ac762..0008020e28e0 100644
--- a/mail/claws-mail/pkg-plist
+++ b/mail/claws-mail/pkg-plist
@@ -210,6 +210,7 @@ libdata/pkgconfig/sylpheed-claws.pc
@dirrm include/sylpheed-claws
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin.so
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin_gtk.so
+%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin_gtk.deps
%%GPGME%%lib/sylpheed-claws/plugins/pgpcore.so
%%GPGME%%lib/sylpheed-claws/plugins/pgpmime.deps
%%GPGME%%lib/sylpheed-claws/plugins/pgpmime.so
diff --git a/mail/sylpheed-claws/Makefile b/mail/sylpheed-claws/Makefile
index 923cf669624a..e58ee4cd3b60 100644
--- a/mail/sylpheed-claws/Makefile
+++ b/mail/sylpheed-claws/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sylpheed-claws
PORTVERSION= 1.9.100
+PORTREVISION= 1
CATEGORIES= mail news ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sylpheed-claws
@@ -167,7 +168,7 @@ post-patch:
s|gpgme-config|gpgme03-config|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/tools/README.sylprint ${WRKSRC}/tools/sylprint.pl
- @${REINPLACE_CMD} -e "s|po intl src|po src| ; s:@SYLPHEED_GNOME:#@SYLPHEED_GNOME:g" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|po intl src|po src| ; s:@SYLPHEED_GNOME:#@SYLPHEED_GNOME:g ; s:-Wno-unused-function::" ${WRKSRC}/Makefile.in
@for f in `${FIND} ${WRKSRC}/tools -type f -print`; do \
${REINPLACE_CMD} -e "s|/usr/bin/perl|${PERL}|" $$f; done
# @${LN} -s ${WRKSRC}/po/sylpheed.pot ${WRKSRC}/po/${PORTNAME}.pot
diff --git a/mail/sylpheed-claws/distinfo b/mail/sylpheed-claws/distinfo
index 603e78ac68a2..4f55fdc1b2a8 100644
--- a/mail/sylpheed-claws/distinfo
+++ b/mail/sylpheed-claws/distinfo
@@ -1,4 +1,6 @@
MD5 (sylpheed-claws-1.9.100.tar.bz2) = 863c314557f90f17c2f6d6a0ab57e6c2
+SHA256 (sylpheed-claws-1.9.100.tar.bz2) = f4bf3826925caa9d1d877345671c9fbb1c4990cea500eead505806e245bca78d
SIZE (sylpheed-claws-1.9.100.tar.bz2) = 3480063
MD5 (sylpheed-iconset-20040929.tar.gz) = d72cf03bf3d13cf9e2785eaca3807707
+SHA256 (sylpheed-iconset-20040929.tar.gz) = 11e791cf7187b5f3ac5a5ab5f0144d9ea8701bbc6182b30b35c30c2cc50e5210
SIZE (sylpheed-iconset-20040929.tar.gz) = 1298891
diff --git a/mail/sylpheed-claws/files/patch-configure.ac b/mail/sylpheed-claws/files/patch-configure.ac
index d9f0665cf1ac..8bc413ea4cd3 100644
--- a/mail/sylpheed-claws/files/patch-configure.ac
+++ b/mail/sylpheed-claws/files/patch-configure.ac
@@ -7,7 +7,7 @@
- PKG_CHECK_MODULES(OPENSSL, openssl >= 0.9.7, :, ac_cv_enable_openssl=no)
+ case $host_os in
+ *freebsd*)
-+ if [ $(openssl version | cut -d ' ' -f 2) \< 0.9.7 ]; then
++ if test $(openssl version | cut -d ' ' -f 2) \< 0.9.7 ; then
+ ac_cv_enable_openssl=no
+ else
+ OPENSSL_LIBS=${OPENSSL_LIBS-"-lcrypto -lssl"}
diff --git a/mail/sylpheed-claws/pkg-plist b/mail/sylpheed-claws/pkg-plist
index 3a23719ac762..0008020e28e0 100644
--- a/mail/sylpheed-claws/pkg-plist
+++ b/mail/sylpheed-claws/pkg-plist
@@ -210,6 +210,7 @@ libdata/pkgconfig/sylpheed-claws.pc
@dirrm include/sylpheed-claws
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin.so
%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin_gtk.so
+%%CLAM_PLUG%%lib/sylpheed-claws/plugins/clamav_plugin_gtk.deps
%%GPGME%%lib/sylpheed-claws/plugins/pgpcore.so
%%GPGME%%lib/sylpheed-claws/plugins/pgpmime.deps
%%GPGME%%lib/sylpheed-claws/plugins/pgpmime.so