aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-02-05 00:18:24 +0800
committermakc <makc@FreeBSD.org>2013-02-05 00:18:24 +0800
commit3c79736fec585b939ab36636f9ee52997f3944cf (patch)
tree73221b138108219ae9b51d40bdce2b1cdd6539db
parent8ce38e0a6de0990edbc3e4e75d13c3ef8a5c7a47 (diff)
downloadfreebsd-ports-gnome-3c79736fec585b939ab36636f9ee52997f3944cf.tar.gz
freebsd-ports-gnome-3c79736fec585b939ab36636f9ee52997f3944cf.tar.zst
freebsd-ports-gnome-3c79736fec585b939ab36636f9ee52997f3944cf.zip
Merge from area51 repository:
- Trip Makefile header - Convert to new options framework / rename option
-rw-r--r--multimedia/phonon-gstreamer/Makefile14
-rw-r--r--multimedia/phonon/Makefile29
-rw-r--r--multimedia/phonon/pkg-message4
-rw-r--r--multimedia/phonon/pkg-plist3
4 files changed, 15 insertions, 35 deletions
diff --git a/multimedia/phonon-gstreamer/Makefile b/multimedia/phonon-gstreamer/Makefile
index 01611745b852..903d97bdd71a 100644
--- a/multimedia/phonon-gstreamer/Makefile
+++ b/multimedia/phonon-gstreamer/Makefile
@@ -1,7 +1,4 @@
-# New ports collection Makefile for: phonon
-# Date created: 2008-01-30
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
PORTNAME= phonon
@@ -40,14 +37,15 @@ PLIST_SUB+= QT_PREFIX=${QT_PREFIX}
IGNORE= conflicts with Qt 4 Phonon. Please, deinstall qt4-phonon-gst and unset WITH_QT_PHONON to continue
.endif
-OPTIONS_DEFINE= PLUGINS
-PLUGINS_DESC= Install GStreamer plugins
+OPTIONS_DEFINE= GST_PLUGINS
+
+GST_PLUGINS_DESC= Install GStreamer plugins
OPTIONS_DEFAULT=
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MPLUGINS}
+.if ${PORT_OPTIONS:MGST_PLUGINS}
RUN_DEPENDS+= gstreamer-plugins-all>=0:${PORTSDIR}/multimedia/gstreamer-plugins-all
.else
SUB_FILES= pkg-message
@@ -59,7 +57,7 @@ pre-su-install:
post-install:
${LN} -sf ${PREFIX}/lib/kde4/plugins/phonon_backend/phonon_gstreamer.so \
${QT_PLUGINDIR}/phonon_backend/libphonon_gstreamer.so
-.if empty(PORT_OPTIONS:MPLUGINS)
+.if ! ${PORT_OPTIONS:MGST_PLUGINS}
@${CAT} ${PKGMESSAGE}
.endif
diff --git a/multimedia/phonon/Makefile b/multimedia/phonon/Makefile
index 255c7f678f25..846001701b3b 100644
--- a/multimedia/phonon/Makefile
+++ b/multimedia/phonon/Makefile
@@ -1,7 +1,4 @@
-# New ports collection Makefile for: phonon
-# Date created: 2008-01-30
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
PORTNAME= phonon
@@ -15,7 +12,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE multimedia framework
-LIB_DEPENDS= qzeitgeist.1:${PORTSDIR}/sysutils/qzeitgeist
+LIB_DEPENDS= qzeitgeist:${PORTSDIR}/sysutils/qzeitgeist
CONFLICTS= qt4-phonon-4*
@@ -27,29 +24,17 @@ USE_QT4= dbus gui \
USE_XZ= yes
USE_CMAKE= yes
CMAKE_ARGS= -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=TRUE \
- -DPHONON_NO_PLATFORMPLUGIN:BOOL=TRUE
+ -DPHONON_NO_PLATFORMPLUGIN:BOOL=TRUE \
+ -DPHONON_BUILD_DESIGNER_PLUGIN:BOOL=OFF
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
-OPTIONS= PULSEAUDIO "Support playback via PulseAudio" off
-# DESIGNER "Install Qt Designer plugin" off \
+OPTIONS_DEFINE= PULSEAUDIO
.include <bsd.port.options.mk>
-# qt4-designer depends on phonon. Disable this option to avoid a
-# circular dependency.
-.undef WITH_DESIGNER
-.ifdef(WITH_DESIGNER)
-USE_QT4+= designer
-CMAKE_ARGS+= -DPHONON_BUILD_DESIGNER_PLUGIN:BOOL=ON
-PLIST_SUB+= DESIGNER=""
-.else
-CMAKE_ARGS+= -DPHONON_BUILD_DESIGNER_PLUGIN:BOOL=OFF
-PLIST_SUB+= DESIGNER="@comment "
-.endif
-
-.ifdef(WITH_PULSEAUDIO)
-LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
+.if ${PORT_OPTIONS:MPULSEAUDIO}
+LIB_DEPENDS+= pulse:${PORTSDIR}/audio/pulseaudio
USE_GNOME+= glib20
CMAKE_ARGS+= -DWITH_PulseAudio:BOOL=ON
.else
diff --git a/multimedia/phonon/pkg-message b/multimedia/phonon/pkg-message
index 93eb3571a49c..a3aca2afd70c 100644
--- a/multimedia/phonon/pkg-message
+++ b/multimedia/phonon/pkg-message
@@ -1,7 +1,7 @@
======================================================================
Please, consider installing backends for Phonon:
-multimedia/phonon-gstreamer GStreamer backend
-multimedia/phonon-vlc VLC backend
+- multimedia/phonon-gstreamer GStreamer backend
+- multimedia/phonon-vlc VLC backend
======================================================================
diff --git a/multimedia/phonon/pkg-plist b/multimedia/phonon/pkg-plist
index b7d76db0ebf6..4dcd54a696c6 100644
--- a/multimedia/phonon/pkg-plist
+++ b/multimedia/phonon/pkg-plist
@@ -197,10 +197,7 @@ share/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
%%QT_LIBDIR_REL%%/libphonon.so.4
%%QT_LIBDIR_REL%%/libphononexperimental.so
%%QT_LIBDIR_REL%%/libphononexperimental.so.4
-%%DESIGNER%%%%QT_PLUGINDIR_REL%%/designer/libphononwidgets.so
share/qt4/mkspecs/modules/qt_phonon.pri
@dirrmtry share/qt4/mkspecs/modules
-%%DESIGNER%%@dirrmtry %%QT_PLUGINDIR_REL%%/designer
-%%DESIGNER%%@dirrmtry %%QT_PLUGINDIR_REL%%
@dirrmtry %%QT_LIBDIR_REL%%
@dirrmtry %%QT_INCDIR_REL%%