aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2019-06-25 05:02:46 +0800
committerolgeni <olgeni@FreeBSD.org>2019-06-25 05:02:46 +0800
commit3cad0746859f3f2307ca2e217f50833dd4554367 (patch)
treed9775f2d677c39efb27fe2a5748766486db832c8
parentf342616480bac1dc14d09a110123f6bb9c4f13ea (diff)
downloadfreebsd-ports-gnome-3cad0746859f3f2307ca2e217f50833dd4554367.tar.gz
freebsd-ports-gnome-3cad0746859f3f2307ca2e217f50833dd4554367.tar.zst
freebsd-ports-gnome-3cad0746859f3f2307ca2e217f50833dd4554367.zip
lang/erlang-runtime22: install dtrace files (*.d) if DTRACE is enabled.
-rw-r--r--lang/erlang-runtime22/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/lang/erlang-runtime22/Makefile b/lang/erlang-runtime22/Makefile
index 4c3e7680b547..7ddeb2a69468 100644
--- a/lang/erlang-runtime22/Makefile
+++ b/lang/erlang-runtime22/Makefile
@@ -4,6 +4,7 @@
PORTNAME= erlang
DISTVERSIONPREFIX= OTP-
DISTVERSION= 22.0.4
+PORTREVISION= 1
CATEGORIES= lang parallel java
PKGNAMESUFFIX= -runtime22
DIST_SUBDIR= erlang
@@ -138,9 +139,16 @@ post-install-WX-off:
${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/observer-*
${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/wx-*
+post-install-DTRACE-on:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/dtrace
+ ${INSTALL_DATA} ${WRKSRC}/erts/emulator/beam/*.d \
+ ${WRKSRC}/lib/runtime_tools/c_src/*.d \
+ ${WRKSRC}/lib/runtime_tools/examples/*.d \
+ ${STAGEDIR}${DATADIR}/dtrace
+
post-stage:
${FIND} ${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/* -type d -empty -delete
- @cd ${STAGEDIR}${PREFIX}; ${FIND} lib/${ERLANG_LIB}/* -type f -o -type l \
+ @cd ${STAGEDIR}${PREFIX}; ${FIND} lib/${ERLANG_LIB}/* ${DATADIR_REL}/* -type f -o -type l \
| ${SORT} >> ${TMPPLIST}
.include <bsd.port.post.mk>