aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-07-25 23:04:42 +0800
committermarino <marino@FreeBSD.org>2013-07-25 23:04:42 +0800
commit3cfaefb0d9c3f307ab7089f7c617bb305746f529 (patch)
tree4dd2cb0662ada9eda266e23b75cf488e7c87e3a4
parent4dc4acd1d1c34981dfb71cfd397eef6067e0685f (diff)
downloadfreebsd-ports-gnome-3cfaefb0d9c3f307ab7089f7c617bb305746f529.tar.gz
freebsd-ports-gnome-3cfaefb0d9c3f307ab7089f7c617bb305746f529.tar.zst
freebsd-ports-gnome-3cfaefb0d9c3f307ab7089f7c617bb305746f529.zip
audio/timemachine: directly link libmath and cleanup
Fixes indirect linking errors on modern binutils (fix from dports) Also: remove redundant MAKE_JOBS_SAFE while we are here. Remove library version specification Approved by: bapt (mentor)
-rw-r--r--audio/timemachine/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/audio/timemachine/Makefile b/audio/timemachine/Makefile
index 3b6eb742d85f..8e1cacf0d592 100644
--- a/audio/timemachine/Makefile
+++ b/audio/timemachine/Makefile
@@ -12,9 +12,9 @@ COMMENT= JACK audio capture tool
LICENSE= GPLv2
-LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack \
+LIB_DEPENDS= jack:${PORTSDIR}/audio/jack \
lo:${PORTSDIR}/audio/liblo \
- sndfile.1:${PORTSDIR}/audio/libsndfile
+ sndfile:${PORTSDIR}/audio/libsndfile
OPTIONS_DEFINE= LASH
@@ -22,12 +22,12 @@ USES= pathfix
USE_GNOME= gtk20
USE_GMAKE= yes
GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
+LDFLAGS+= -lm
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLASH}
-LIB_DEPENDS+= lash.2:${PORTSDIR}/audio/lash
+LIB_DEPENDS+= lash:${PORTSDIR}/audio/lash
.else
CONFIGURE_ARGS+=--disable-lash
.endif