aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-06-15 22:08:44 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2018-06-15 22:08:44 +0800
commit3da041d8edec8833abce0c944dc4241c45f09061 (patch)
tree1729f29376d439307d626b071dd7c53ea33b6a94
parent57aa4f4468e476619d46bd7a28169dad9cb1778f (diff)
downloadfreebsd-ports-gnome-3da041d8edec8833abce0c944dc4241c45f09061.tar.gz
freebsd-ports-gnome-3da041d8edec8833abce0c944dc4241c45f09061.tar.zst
freebsd-ports-gnome-3da041d8edec8833abce0c944dc4241c45f09061.zip
graphics/sane-backends: Remove bogus interactive pkg-deinstall script
Half of the script is never run and the other half tries to stop saned and asks an interactive question outside of pkg's control if saned happens to be still running which will stall pkg-delete(8) indefinitely.
-rw-r--r--graphics/sane-backends/Makefile2
-rw-r--r--graphics/sane-backends/pkg-deinstall63
2 files changed, 1 insertions, 64 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index b282360e5778..1a26455feb88 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sane-backends
PORTVERSION= 1.0.27
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= https://alioth.debian.org/frs/download.php/file/4146/ \
http://fossies.org/linux/misc/
diff --git a/graphics/sane-backends/pkg-deinstall b/graphics/sane-backends/pkg-deinstall
deleted file mode 100644
index 1f1f4ecc8ef1..000000000000
--- a/graphics/sane-backends/pkg-deinstall
+++ /dev/null
@@ -1,63 +0,0 @@
-#!/bin/sh
-
-user=saned
-group=saned
-
-ask() {
- local question default answer
-
- question=$1
- default=$2
- if [ -z "${PACKAGE_BUILDING}" ]; then
- read -p "${question} [${default}]? " answer
- fi
- if [ x${answer} = x ]; then
- answer=${default}
- fi
- echo ${answer}
-}
-
-yesno() {
- local dflt question answer
-
- question=$1
- dflt=$2
- while :; do
- answer=$(ask "${question}" "${dflt}")
- case "${answer}" in
- [Yy]*) return 0;;
- [Nn]*) return 1;;
- esac
- echo "Please answer yes or no."
- done
-}
-
-delete_account() {
- local u g home
-
- u=$1
- g=$2
- if yesno "Do you want me to remove group \"${g}\"" y; then
- pw groupdel -n ${g}
- echo "Done."
- fi
- if yesno "Do you want me to remove user \"${u}\"" y; then
- eval home=~${u}
- pw userdel -n ${u}
- echo "Done."
- fi
-}
-
-if [ x"$2" = xDEINSTALL ]; then
- if [ ! -n "$BATCH" ]; then
- if /bin/ps -axc | /usr/bin/grep -q saned; then
- if yesno "There are some SANE processes running. Shall I kill them" y; then
- ${PKG_PREFIX}/etc/rc.d/saned stop
- sleep 2
- else
- echo "OK ... I hope you know what you are doing."
- fi
- fi
-
- fi
-fi