aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>2008-07-22 03:11:36 +0800
committerjmz <jmz@FreeBSD.org>2008-07-22 03:11:36 +0800
commit40b1e085f1578811484ea1be63340e6b37ea9e1d (patch)
treec5f14df25cf1ca0c91cb128176977f7d8c9d7b3a
parentfa158f66136d4fefc99c24cc86dc971754932989 (diff)
downloadfreebsd-ports-gnome-40b1e085f1578811484ea1be63340e6b37ea9e1d.tar.gz
freebsd-ports-gnome-40b1e085f1578811484ea1be63340e6b37ea9e1d.tar.zst
freebsd-ports-gnome-40b1e085f1578811484ea1be63340e6b37ea9e1d.zip
Add another 64-bit fix.
Submitted by: naddy Obtained from: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=394366
-rw-r--r--x11/xloadimage/Makefile2
-rw-r--r--x11/xloadimage/files/patch-lp6423
2 files changed, 24 insertions, 1 deletions
diff --git a/x11/xloadimage/Makefile b/x11/xloadimage/Makefile
index 607a83b66f48..7ca68a9d5416 100644
--- a/x11/xloadimage/Makefile
+++ b/x11/xloadimage/Makefile
@@ -7,7 +7,7 @@
VERSION= 4.1
REVISION= 16
-PORTREVISION= 3
+PORTREVISION= 4
PORTNAME= xloadimage
PORTVERSION= ${VERSION}.${REVISION}
diff --git a/x11/xloadimage/files/patch-lp64 b/x11/xloadimage/files/patch-lp64
index 0344dc9a98ab..1391c5fab823 100644
--- a/x11/xloadimage/files/patch-lp64
+++ b/x11/xloadimage/files/patch-lp64
@@ -74,3 +74,26 @@
(*((byte *)(PTR) + 3) << 24))))))
+--- root.c.orig 2006-10-20 16:05:45.000000000 -0400
++++ root.c 2006-10-20 16:18:09.000000000 -0400
+@@ -68,16 +68,16 @@
+ Pixmap *pm;
+ Atom actual_type; /* NOTUSED */
+ int format;
+- int nitems;
+- int bytes_after;
++ unsigned long nitems;
++ unsigned long bytes_after;
+
+ /* intern the property name */
+ Atom atom = XInternAtom(dpy, RETAIN_PROP_NAME, 0);
+
+ /* look for existing resource allocation */
+ if ((XGetWindowProperty(dpy, w, atom, 0, 1, 1/*delete*/,
+- AnyPropertyType, &actual_type, &format, (unsigned long *)&nitems,
+- (unsigned long *)&bytes_after, (unsigned char **)&pm) == Success) &&
++ AnyPropertyType, &actual_type, &format, &nitems,
++ &bytes_after, (unsigned char **)&pm) == Success) &&
+ nitems == 1) {
+ if ((actual_type == XA_PIXMAP) && (format == 32) &&
+ (nitems == 1) && (bytes_after == 0)) {