aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-05-12 09:39:37 +0800
committerPete Fritchman <petef@FreeBSD.org>2003-05-12 09:39:37 +0800
commit40b5b64326bd109abdc45b2ef806cfc2658c4533 (patch)
tree113a67d6029fecc00197af071a79f72d5529c38c
parentd0a2eae9385dcd9b41dca440a4b617c9a45e08ba (diff)
downloadfreebsd-ports-gnome-40b5b64326bd109abdc45b2ef806cfc2658c4533.tar.gz
freebsd-ports-gnome-40b5b64326bd109abdc45b2ef806cfc2658c4533.tar.zst
freebsd-ports-gnome-40b5b64326bd109abdc45b2ef806cfc2658c4533.zip
Add picp 0.4, driver for the Microchip Picstart Plus development
programmer. PR: 44786 Submitted by: Bruce M Simpson <bms@spc.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/picp/Makefile28
-rw-r--r--devel/picp/distinfo1
-rw-r--r--devel/picp/pkg-descr9
-rw-r--r--devel/picp/pkg-plist1
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f9b6f38bee86..5535bdb49ba0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -700,6 +700,7 @@
SUBDIR += pharmacy
SUBDIR += php-dbg
SUBDIR += picasm
+ SUBDIR += picp
SUBDIR += picprog
SUBDIR += pinstall
SUBDIR += pkgconfig
diff --git a/devel/picp/Makefile b/devel/picp/Makefile
new file mode 100644
index 000000000000..0a33494b022a
--- /dev/null
+++ b/devel/picp/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: picp
+# Date created: 25 October 2002
+# Whom: Bruce M Simpson <bms@spc.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= picp
+PORTVERSION= 0.4
+CATEGORIES= devel
+MASTER_SITES= http://bofh.stabilis.ru/
+DISTNAME= ${PORTNAME}_fbsd
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= bms@spc.org
+COMMENT= Driver for the Microchip Picstart Plus development programmer
+
+USE_REINPLACE= yes
+NO_WRKSUBDIR= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,CC=,CC?=,' -e 's,-O2,,' \
+ -e 's,CFLAGS=,CFLAGS+=,' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/picp ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/picp/distinfo b/devel/picp/distinfo
new file mode 100644
index 000000000000..27a8827e4315
--- /dev/null
+++ b/devel/picp/distinfo
@@ -0,0 +1 @@
+MD5 (picp_fbsd.tgz) = 419c4c98cbd2fd4fd74146ee6c798299
diff --git a/devel/picp/pkg-descr b/devel/picp/pkg-descr
new file mode 100644
index 000000000000..6ee54b2a9437
--- /dev/null
+++ b/devel/picp/pkg-descr
@@ -0,0 +1,9 @@
+This is a FreeBSD port of picp, a command line driver for the Microchip
+Picstart Plus development programmer. It is compatible with a variety of
+PICs including the 16F84.
+
+WWW: http://www.cosmodog.com/pic/
+WWW: http://bofh.stabilis.ru/soft.html
+
+Bruce
+bms@spc.org
diff --git a/devel/picp/pkg-plist b/devel/picp/pkg-plist
new file mode 100644
index 000000000000..41174690231e
--- /dev/null
+++ b/devel/picp/pkg-plist
@@ -0,0 +1 @@
+bin/picp