aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2007-12-30 09:36:02 +0800
committerLars Engels <lme@FreeBSD.org>2007-12-30 09:36:02 +0800
commit41664caef9e270580d55900c256353a9f48a6b65 (patch)
treeffff1b7eac16cac7267a92b25ccd0321034c00c5
parentb48f683ee3f43049b6d82767bcbd17ec4a661a1e (diff)
downloadfreebsd-ports-gnome-41664caef9e270580d55900c256353a9f48a6b65.tar.gz
freebsd-ports-gnome-41664caef9e270580d55900c256353a9f48a6b65.tar.zst
freebsd-ports-gnome-41664caef9e270580d55900c256353a9f48a6b65.zip
aTunes is a full-featured audio player and manager, developed in Java.
Currently plays mp3, ogg, wma, wav, flac, mp4 and radio streaming, allowing users to easily edit tags, organize music and rip Audio CDs. WWW: http://www.atunes.org/ Approved by: miwi (mentor)
-rw-r--r--audio/Makefile1
-rw-r--r--audio/atunes/Makefile73
-rw-r--r--audio/atunes/distinfo3
-rw-r--r--audio/atunes/files/atunes.in5
-rw-r--r--audio/atunes/pkg-descr6
-rw-r--r--audio/atunes/pkg-plist66
6 files changed, 154 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 4cc8b0b58a86..103c385db296 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -38,6 +38,7 @@
SUBDIR += asmix
SUBDIR += asmixer
SUBDIR += asunder
+ SUBDIR += atunes
SUBDIR += aube
SUBDIR += audacious-crossfade
SUBDIR += audacious-dumb
diff --git a/audio/atunes/Makefile b/audio/atunes/Makefile
new file mode 100644
index 000000000000..b96498f0f94c
--- /dev/null
+++ b/audio/atunes/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: atunes
+# Date Created: 29 Dec 2007
+# Whom: Lars Engels <lme@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= atunes
+PORTVERSION= 1.8.1
+CATEGORIES= audio java
+MASTER_SITES= SF
+DISTNAME= aTunes_${PORTVERSION}
+
+MAINTAINER= lme@FreeBSD.org
+COMMENT= A full-featured audio player and manager developed in Java
+
+NO_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+SUB_FILES= atunes
+
+WRKSRC= ${WRKDIR}/aTunes
+
+OPTIONS= CDDA2WAV "Ripper: Enable cdrtools support" on \
+ LAME "Encoder: Enable lame MP3 encoder" on \
+ VORBIS "Encoder: Enable vorbis OGG encoder" on \
+ FLAC "Encoder: Enable FLAC encoder" off
+
+.include <bsd.port.pre.mk>
+
+RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
+
+.if defined(WITH_CDDA2WAV)
+USE_CDRTOOLS= yes
+.endif
+
+.if !defined(WITHOUT_LAME)
+RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
+.endif
+
+.if defined(WITH_VORBIS)
+RUN_DEPENDS+= ogg123:${PORTSDIR}/audio/vorbis-tools
+.endif
+
+.if defined(WITH_FLAC)
+RUN_DEPENDS+= flac:${PORTSDIR}/audio/flac
+.endif
+
+DESKTOP_ENTRIES="aTunes" \
+ "Audio player and manager" \
+ "${DATADIR}/aTunes.ico" \
+ "aTunes" \
+ "Application;Audio;Player;" \
+ false
+
+INSTALL_FILES= aTunes.ico aTunes.jar build.properties changelog.txt \
+ extendedLog.properties license.txt log4j.properties \
+ lyricsEngines.properties shortcutSpec.xml
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @${MKDIR} ${DATADIR}/translations
+ @${MKDIR} ${DATADIR}/lib
+ ${INSTALL_SCRIPT} ${WRKDIR}/atunes ${PREFIX}/bin
+.for file in ${INSTALL_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DATADIR}/${file}
+.endfor
+ cd ${WRKSRC} && ${FIND} translations -type f -exec ${INSTALL_DATA} {} \
+ ${DATADIR}/{} \;
+ cd ${WRKSRC} && ${FIND} lib -type f -name "*.jar" -exec ${INSTALL_DATA} {} \
+ ${DATADIR}/{} \;
+
+.include <bsd.port.post.mk>
diff --git a/audio/atunes/distinfo b/audio/atunes/distinfo
new file mode 100644
index 000000000000..33b3cd9d57ae
--- /dev/null
+++ b/audio/atunes/distinfo
@@ -0,0 +1,3 @@
+MD5 (aTunes_1.8.1.tar.gz) = 725161bb8d9ae3ff7a58cad8fed8dc76
+SHA256 (aTunes_1.8.1.tar.gz) = 79cf08631b2aa4d84f071cbc5625828307600a8f1cc3232edf164ef4f066bd79
+SIZE (aTunes_1.8.1.tar.gz) = 15855569
diff --git a/audio/atunes/files/atunes.in b/audio/atunes/files/atunes.in
new file mode 100644
index 000000000000..85527f3dfa4a
--- /dev/null
+++ b/audio/atunes/files/atunes.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd %%DATADIR%%
+
+JAVA_VERSION="%%JAVA_VERSION%%" exec %%LOCALBASE%%/bin/java -Xms18m -Xmx48m -cp aTunes.jar:lib/commons-io-1.3.2.jar:lib/jcommon-1.0.0.jar:lib/jfreechart-1.0.1.jar:lib/jaudiotagger.jar:lib/log4j-1.2.13.jar:lib/commons-logging-1.1.jar:lib/jdic.jar:lib/jdic_stub_linux.jar:lib/antBuildNumber.jar:lib/substance.jar:lib/oro.jar:lib/swingx.jar:lib/jhlabs.jar:lib/htmlparser.jar:lib/substance-swingx.jar net.sourceforge.atunes.Main "$@"
diff --git a/audio/atunes/pkg-descr b/audio/atunes/pkg-descr
new file mode 100644
index 000000000000..cf1f731b339a
--- /dev/null
+++ b/audio/atunes/pkg-descr
@@ -0,0 +1,6 @@
+aTunes is a full-featured audio player and manager, developed in Java.
+
+Currently plays mp3, ogg, wma, wav, flac, mp4 and radio streaming,
+allowing users to easily edit tags, organize music and rip Audio CDs.
+
+WWW: http://www.atunes.org/
diff --git a/audio/atunes/pkg-plist b/audio/atunes/pkg-plist
new file mode 100644
index 000000000000..959b00750674
--- /dev/null
+++ b/audio/atunes/pkg-plist
@@ -0,0 +1,66 @@
+bin/atunes
+%%DATADIR%%/aTunes.ico
+%%DATADIR%%/aTunes.jar
+%%DATADIR%%/build.properties
+%%DATADIR%%/changelog.txt
+%%DATADIR%%/extendedLog.properties
+%%DATADIR%%/lib/antBuildNumber.jar
+%%DATADIR%%/lib/antCommenter.jar
+%%DATADIR%%/lib/commons-io-1.3.2.jar
+%%DATADIR%%/lib/commons-logging-1.1.jar
+%%DATADIR%%/lib/htmlparser.jar
+%%DATADIR%%/lib/jaudiotagger.jar
+%%DATADIR%%/lib/jcommon-1.0.0.jar
+%%DATADIR%%/lib/jdic.jar
+%%DATADIR%%/lib/jdic_stub_linux.jar
+%%DATADIR%%/lib/jdic_stub_win.jar
+%%DATADIR%%/lib/jfreechart-1.0.1.jar
+%%DATADIR%%/lib/jhlabs.jar
+%%DATADIR%%/lib/log4j-1.2.13.jar
+%%DATADIR%%/lib/oro.jar
+%%DATADIR%%/lib/substance-swingx.jar
+%%DATADIR%%/lib/substance.jar
+%%DATADIR%%/lib/swingx.jar
+%%DATADIR%%/license.txt
+%%DATADIR%%/log4j.properties
+%%DATADIR%%/lyricsEngines.properties
+%%DATADIR%%/shortcutSpec.xml
+%%DATADIR%%/translations/MainBundle.properties
+%%DATADIR%%/translations/MainBundle_ar.properties
+%%DATADIR%%/translations/MainBundle_cs.properties
+%%DATADIR%%/translations/MainBundle_de.properties
+%%DATADIR%%/translations/MainBundle_el.properties
+%%DATADIR%%/translations/MainBundle_en.properties
+%%DATADIR%%/translations/MainBundle_es.properties
+%%DATADIR%%/translations/MainBundle_fr.properties
+%%DATADIR%%/translations/MainBundle_hu.properties
+%%DATADIR%%/translations/MainBundle_it.properties
+%%DATADIR%%/translations/MainBundle_ja.properties
+%%DATADIR%%/translations/MainBundle_no.properties
+%%DATADIR%%/translations/MainBundle_pt.properties
+%%DATADIR%%/translations/MainBundle_pt_BR.properties
+%%DATADIR%%/translations/MainBundle_sk.properties
+%%DATADIR%%/translations/MainBundle_tr.properties
+%%DATADIR%%/translations/MainBundle_zh.properties
+%%DATADIR%%/translations/MainBundle_zh_TW.properties
+%%DATADIR%%/translations/flag_ar.png
+%%DATADIR%%/translations/flag_cs.png
+%%DATADIR%%/translations/flag_de.png
+%%DATADIR%%/translations/flag_el.png
+%%DATADIR%%/translations/flag_en.png
+%%DATADIR%%/translations/flag_es.png
+%%DATADIR%%/translations/flag_fr.png
+%%DATADIR%%/translations/flag_hu.png
+%%DATADIR%%/translations/flag_it.png
+%%DATADIR%%/translations/flag_ja.png
+%%DATADIR%%/translations/flag_no.png
+%%DATADIR%%/translations/flag_pt.png
+%%DATADIR%%/translations/flag_pt_BR.png
+%%DATADIR%%/translations/flag_sk.png
+%%DATADIR%%/translations/flag_tr.png
+%%DATADIR%%/translations/flag_zh.png
+%%DATADIR%%/translations/flag_zh_TW.png
+@dirrm %%DATADIR%%/translations
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%
+@dirrmtry share/applications