aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2010-06-15 02:13:15 +0800
committerMax Khon <fjoe@FreeBSD.org>2010-06-15 02:13:15 +0800
commit41852a73b22b38cc833d1a49b51a6dcf8fc4c8d3 (patch)
treec9aa970f4898767f0bdfa2b6034fb9b5088a2ba0
parent6c133257a220102347016b7f115ea3aa6d2b7434 (diff)
downloadfreebsd-ports-gnome-41852a73b22b38cc833d1a49b51a6dcf8fc4c8d3.tar.gz
freebsd-ports-gnome-41852a73b22b38cc833d1a49b51a6dcf8fc4c8d3.tar.zst
freebsd-ports-gnome-41852a73b22b38cc833d1a49b51a6dcf8fc4c8d3.zip
Add OS version check.
-rw-r--r--misc/dahdi-kmod/Makefile4
-rw-r--r--misc/dahdi/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/misc/dahdi-kmod/Makefile b/misc/dahdi-kmod/Makefile
index f4541128e651..ed61a62cf3fa 100644
--- a/misc/dahdi-kmod/Makefile
+++ b/misc/dahdi-kmod/Makefile
@@ -43,6 +43,10 @@ OPTIONS= EXPERIMENTAL "Enable experimental drivers" off
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 703000 || (${OSVERSION} >= 800000 && ${OSVERSION} < 800108)
+IGNORE= requires firmware(9) support for kernel modules with hyphens
+.endif
+
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
PLIST_SUB+= X86=""
.else
diff --git a/misc/dahdi/Makefile b/misc/dahdi/Makefile
index f4541128e651..ed61a62cf3fa 100644
--- a/misc/dahdi/Makefile
+++ b/misc/dahdi/Makefile
@@ -43,6 +43,10 @@ OPTIONS= EXPERIMENTAL "Enable experimental drivers" off
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 703000 || (${OSVERSION} >= 800000 && ${OSVERSION} < 800108)
+IGNORE= requires firmware(9) support for kernel modules with hyphens
+.endif
+
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
PLIST_SUB+= X86=""
.else