aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-02-14 16:45:16 +0800
committerkoobs <koobs@FreeBSD.org>2015-02-14 16:45:16 +0800
commit41a932e5df3ab3c474626ae8e7a7d9a80c668498 (patch)
tree36e721fd693b19c2ff9ad28ac8414482d2a65282
parentf0609f75ea87485eb36dc1ecb946be7958dbf854 (diff)
downloadfreebsd-ports-gnome-41a932e5df3ab3c474626ae8e7a7d9a80c668498.tar.gz
freebsd-ports-gnome-41a932e5df3ab3c474626ae8e7a7d9a80c668498.tar.zst
freebsd-ports-gnome-41a932e5df3ab3c474626ae8e7a7d9a80c668498.zip
[NEW] www/py-autobahn: WebSocket library, WAMP real-time framework
Autobahn|Python is a networking library that is part of the Autobahn project and provides implementations of: * The WebSocket Protocol * The Web Application Messaging Protocol (WAMP) for Twisted and asyncio, on Python 2 & 3 and for writing servers and clients. WebSocket allows bidirectional real-time messaging on the Web and WAMP adds asynchronous Remote Procedure Calls and Publish & Subscribe on top of WebSocket. WWW: http://autobahn.ws/python
-rw-r--r--www/Makefile1
-rw-r--r--www/py-autobahn/Makefile56
-rw-r--r--www/py-autobahn/distinfo2
-rw-r--r--www/py-autobahn/pkg-descr14
4 files changed, 73 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e39d11cc285e..430d95ff4e06 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1460,6 +1460,7 @@
SUBDIR += py-albatross
SUBDIR += py-amf
SUBDIR += py-apachelog
+ SUBDIR += py-autbahn
SUBDIR += py-beaker
SUBDIR += py-beautifulsoup
SUBDIR += py-beautifulsoup32
diff --git a/www/py-autobahn/Makefile b/www/py-autobahn/Makefile
new file mode 100644
index 000000000000..9da5782cbf9e
--- /dev/null
+++ b/www/py-autobahn/Makefile
@@ -0,0 +1,56 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= autobahn
+PORTVERSION= 0.9.6
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= WebSocket client & server library, WAMP real-time framework
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.6.1:${PORTSDIR}/devel/py-six
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
+
+USES= dos2unix python
+USE_PYTHON= autoplist distutils
+
+OPTIONS_DEFINE= ACCELERATE SERIALIZATION
+OPTIONS_MULTI= BACKENDS
+OPTIONS_MULTI_BACKENDS= ASYNCIO TWISTED
+OPTIONS_DEFAULT= ASYNCIO ACCELERATE SERIALIZATION TWISTED
+
+BACKENDS_DESC= Networking Backends
+
+ACCELERATE_DESC= WebSocket and JSON Acceleration
+ASYNCIO_DESC= asyncio (PEP-3156 aka "Tulip") Backend
+SERIALIZATION_DESC= WAMPv2 Binary Serialization
+TWISTED_DESC= Twisted Backend (Python 2.x ONLY)
+
+ACCELERATE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wsaccel>=0.6.2:${PORTSDIR}/www/py-wsaccel \
+ ${PYTHON_PKGNAMEPREFIX}ujson>=1.33:${PORTSDIR}/devel/py-ujson
+SERIALIZATION_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack>=0.4.0:${PORTSDIR}/devel/py-msgpack
+TWISTED_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.interface>=3.6:${PORTSDIR}/devel/py-zope.interface
+TWISTED_USES= twisted:run
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MTWISTED} && ${PYTHON_REL} >= 300
+BROKEN= Twisted currently only supports Python 2.x. Disable the TWISTED option and use ASYNCIO instead
+.endif
+
+.if ${PORT_OPTIONS:MASYNCIO} && ${PYTHON_REL} <= 340
+.if ${PYTHON_REL} >= 330
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}asyncio>=0.2.1:${PORTSDIR}/devel/py-asyncio
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}trollius>=0.1.2:${PORTSDIR}/devel/py-trollius \
+ ${PYTHON_PKGNAMEPREFIX}futures>=2.1.5:${PORTSDIR}/devel/py-futures
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/py-autobahn/distinfo b/www/py-autobahn/distinfo
new file mode 100644
index 000000000000..7ef7aa92602f
--- /dev/null
+++ b/www/py-autobahn/distinfo
@@ -0,0 +1,2 @@
+SHA256 (autobahn-0.9.6.tar.gz) = 7b17ea657ef275a361dba1977cdbfc822c664ef3fc8500c4b0d82cbf42854f9f
+SIZE (autobahn-0.9.6.tar.gz) = 137891
diff --git a/www/py-autobahn/pkg-descr b/www/py-autobahn/pkg-descr
new file mode 100644
index 000000000000..24e8054f424e
--- /dev/null
+++ b/www/py-autobahn/pkg-descr
@@ -0,0 +1,14 @@
+Autobahn|Python is a networking library that is part of the Autobahn
+project and provides implementations of:
+
+ * The WebSocket Protocol
+ * The Web Application Messaging Protocol (WAMP)
+
+for Twisted and asyncio, on Python 2 & 3 and for writing servers and
+clients.
+
+WebSocket allows bidirectional real-time messaging on the Web and WAMP
+adds asynchronous Remote Procedure Calls and Publish & Subscribe on top
+of WebSocket.
+
+WWW: http://autobahn.ws/python