aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-01-28 17:49:21 +0800
committergahr <gahr@FreeBSD.org>2014-01-28 17:49:21 +0800
commit41ec143b688c7ff78318b7ab9e7900a33d36ac9d (patch)
tree57fd47a63afe052643c6e6b644089e78ff279f5b
parent142d5a8cbdf8d8eaaf81527edfd780f761b4159b (diff)
downloadfreebsd-ports-gnome-41ec143b688c7ff78318b7ab9e7900a33d36ac9d.tar.gz
freebsd-ports-gnome-41ec143b688c7ff78318b7ab9e7900a33d36ac9d.tar.zst
freebsd-ports-gnome-41ec143b688c7ff78318b7ab9e7900a33d36ac9d.zip
- Chase compiler warning
- Fix segfault on "tmux info" due to broken strnvis(3), see http://sourceforge.net/mailarchive/message.php?msg_id=31707330 Reported by: Robert Simmons <rsimmons0@gmail.com>
-rw-r--r--sysutils/tmux/Makefile2
-rw-r--r--sysutils/tmux/files/patch-configure31
2 files changed, 33 insertions, 0 deletions
diff --git a/sysutils/tmux/Makefile b/sysutils/tmux/Makefile
index 5f133312a608..1b8b5ac62951 100644
--- a/sysutils/tmux/Makefile
+++ b/sysutils/tmux/Makefile
@@ -31,6 +31,8 @@ LIBEVENT2_DESC= Use libevent version 2
LIBEVENT_STATIC_DESC= Build with static libevent
BACKSPACE_DESC= Build with tty/keys patch
+CFLAGS+= -Wno-pointer-sign
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLIBEVENT2}
diff --git a/sysutils/tmux/files/patch-configure b/sysutils/tmux/files/patch-configure
new file mode 100644
index 000000000000..f441d6e2676e
--- /dev/null
+++ b/sysutils/tmux/files/patch-configure
@@ -0,0 +1,31 @@
+--- configure.bak 2013-03-26 21:08:51.000000000 +0100
++++ configure 2014-01-28 10:49:58.000000000 +0100
+@@ -5635,6 +5635,28 @@
+ fi
+
+ if test "x$found_strnvis" = xyes; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking if strnvis is broken" >&5
++$as_echo_n "checking if strnvis is broken... " >&6; }
++ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
++/* end confdefs.h. */
++#include <vis.h>
++
++_ACEOF
++if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
++ $EGREP "strnvis\(char \*, const char \*, size_t, int\)" >/dev/null 2>&1; then :
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++else
++ found_strnvis=no
++fi
++rm -f conftest*
++
++ if test "x$found_strnvis" = xno; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
++$as_echo "yes" >&6; }
++ fi
++fi
++if test "x$found_strnvis" = xyes; then
+ $as_echo "#define HAVE_VIS 1" >>confdefs.h
+
+ fi