aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-06-01 13:25:13 +0800
committermiwi <miwi@FreeBSD.org>2014-06-01 13:25:13 +0800
commit42cba105ae9aa448dee094182e8d4bccd4db8838 (patch)
tree153d42630b2fd433fe9cabd3f334fa4bb1b927c0
parentbeca532558b9502a187a84363589bcab52c2cd13 (diff)
downloadfreebsd-ports-gnome-42cba105ae9aa448dee094182e8d4bccd4db8838.tar.gz
freebsd-ports-gnome-42cba105ae9aa448dee094182e8d4bccd4db8838.tar.zst
freebsd-ports-gnome-42cba105ae9aa448dee094182e8d4bccd4db8838.zip
- Stage support
-rw-r--r--sysutils/zisofs-tools/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/sysutils/zisofs-tools/Makefile b/sysutils/zisofs-tools/Makefile
index 72e8f00e7bf5..ab09db76ab85 100644
--- a/sysutils/zisofs-tools/Makefile
+++ b/sysutils/zisofs-tools/Makefile
@@ -14,20 +14,18 @@ COMMENT= User utilities for zisofs
PORTDOCS= CHANGES COPYING INSTALL MRULES README
USE_AUTOTOOLS= autoconf
-USES= gmake tar:bzip2
+USES= gmake tar:bzip2 desthack
GNU_CONFIGURE= yes
MAKE_ARGS+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
-MAN1= mkzftree.1
-
-PLIST_FILES= bin/mkzftree
+PLIST_FILES= bin/mkzftree \
+ man/man1/mkzftree.1.gz
OPTIONS_DEFINE= LFS DOCS
OPTIONS_DEFAULT= LFS
LFS_DESC= Enable Large Files Support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ! ${PORT_OPTIONS:MLFS}
@@ -35,9 +33,7 @@ CONFIGURE_ARGS+= --disable-largefile
.endif
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>