aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2012-09-08 14:58:01 +0800
committerDoug Barton <dougb@FreeBSD.org>2012-09-08 14:58:01 +0800
commit433f1ce663e834a3c52d31babc24e911f93997a9 (patch)
tree6236262c3192e4e99f803125268dd660f21acc6e
parentf12a5af99738c5338803804fb0022386f48687b9 (diff)
downloadfreebsd-ports-gnome-433f1ce663e834a3c52d31babc24e911f93997a9.tar.gz
freebsd-ports-gnome-433f1ce663e834a3c52d31babc24e911f93997a9.tar.zst
freebsd-ports-gnome-433f1ce663e834a3c52d31babc24e911f93997a9.zip
Hook security/libotr3 up, and move ports that depend on the old version
to this new dependency.
-rw-r--r--irc/bitlbee/Makefile3
-rw-r--r--irc/irssi-otr/Makefile4
-rw-r--r--net-im/climm/Makefile4
-rw-r--r--net-im/mcabber/Makefile4
-rw-r--r--net/kdenetwork4/Makefile3
-rw-r--r--security/Makefile1
-rw-r--r--security/kopete-otr/Makefile4
-rw-r--r--security/libotr3/Makefile12
-rw-r--r--security/py-otr/Makefile8
9 files changed, 20 insertions, 23 deletions
diff --git a/irc/bitlbee/Makefile b/irc/bitlbee/Makefile
index 26aa32d6c938..2e9f4c49bdf3 100644
--- a/irc/bitlbee/Makefile
+++ b/irc/bitlbee/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bitlbee
PORTVERSION= 3.0.5
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://get.bitlbee.org/src/ \
${MASTER_SITE_LOCAL}
@@ -72,7 +73,7 @@ LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls \
.if defined(WITH_OTR)
CONFIGURE_ARGS+=--otr=1
-LIB_DEPENDS+= otr.4:${PORTSDIR}/security/libotr
+LIB_DEPENDS+= otr.4:${PORTSDIR}/security/libotr3
.else
CONFIGURE_ARGS+=--otr=0
.endif
diff --git a/irc/irssi-otr/Makefile b/irc/irssi-otr/Makefile
index 12ca0a8bca47..114338ce13bb 100644
--- a/irc/irssi-otr/Makefile
+++ b/irc/irssi-otr/Makefile
@@ -7,7 +7,7 @@
PORTNAME= irssi-otr
PORTVERSION= 0.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= irc
MASTER_SITES= ftp://download.tuxfamily.org/${MASTER_SITE_SUBDIR}/
MASTER_SITE_SUBDIR= irssiotr
@@ -17,7 +17,7 @@ COMMENT= A plugin for irssi for Off-the-Record (OTR) messaging
BUILD_DEPENDS= ${LOCALBASE}/include/irssi/src/common.h:${PORTSDIR}/irc/irssi \
${LOCALBASE}/bin/libgcrypt-config:${PORTSDIR}/security/libgcrypt
-LIB_DEPENDS= otr.4:${PORTSDIR}/security/libotr \
+LIB_DEPENDS= otr.4:${PORTSDIR}/security/libotr3 \
gcrypt.18:${PORTSDIR}/security/libgcrypt
RUN_DEPENDS= irssi:${PORTSDIR}/irc/irssi
diff --git a/net-im/climm/Makefile b/net-im/climm/Makefile
index 360db13826f0..7f8b403dc828 100644
--- a/net-im/climm/Makefile
+++ b/net-im/climm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= climm
PORTVERSION= 0.7.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-im
MASTER_SITES= http://www.climm.org/source/ \
http://http.bg.climm.org/source/
@@ -37,7 +37,7 @@ XMPP_DESC= Enable XMPP Jabber support
.if ${PORT_OPTIONS:MOTR}
CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --enable-otr
-LIB_DEPENDS+= otr:${PORTSDIR}/security/libotr
+LIB_DEPENDS+= otr.4:${PORTSDIR}/security/libotr3
.else
CONFIGURE_ARGS+= --disable-otr
.endif
diff --git a/net-im/mcabber/Makefile b/net-im/mcabber/Makefile
index 0eadba58c47f..87534e2fe627 100644
--- a/net-im/mcabber/Makefile
+++ b/net-im/mcabber/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mcabber
PORTVERSION= 0.10.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-im
MASTER_SITES= http://www.lilotux.net/~mikael/mcabber/files/ CENKES
@@ -61,7 +61,7 @@ CONFIGURE_ARGS+=--disable-enchant
.endif
.if defined(WITH_OTR)
-LIB_DEPENDS+= otr.4:${PORTSDIR}/security/libotr \
+LIB_DEPENDS+= otr.4:${PORTSDIR}/security/libotr3 \
gcrypt.18:${PORTSDIR}/security/libgcrypt
CONFIGURE_ARGS+=--enable-otr
PLIST_SUB+= OTR=""
diff --git a/net/kdenetwork4/Makefile b/net/kdenetwork4/Makefile
index 4cb063dd7653..2df951dd59ce 100644
--- a/net/kdenetwork4/Makefile
+++ b/net/kdenetwork4/Makefile
@@ -6,6 +6,7 @@
PORTNAME= kdenetwork
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= net kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
@@ -17,7 +18,7 @@ COMMENT= KDE Network applications
LIB_DEPENDS= slp.1:${PORTSDIR}/net/openslp \
idn.17:${PORTSDIR}/dns/libidn \
qca.2:${PORTSDIR}/devel/qca \
- otr.4:${PORTSDIR}/security/libotr \
+ otr.4:${PORTSDIR}/security/libotr3 \
vncserver.0:${PORTSDIR}/net/libvncserver \
msn.0:${PORTSDIR}/net-im/libmsn \
gadu.3:${PORTSDIR}/polish/libgadu \
diff --git a/security/Makefile b/security/Makefile
index 098c25f53b13..f8fe041737a9 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -268,6 +268,7 @@
SUBDIR += libmcrypt
SUBDIR += libntlm
SUBDIR += libotr
+ SUBDIR += libotr3
SUBDIR += libp11
SUBDIR += libprelude
SUBDIR += libpreludedb
diff --git a/security/kopete-otr/Makefile b/security/kopete-otr/Makefile
index b68e0fe773de..c299be0644ef 100644
--- a/security/kopete-otr/Makefile
+++ b/security/kopete-otr/Makefile
@@ -7,7 +7,7 @@
PORTNAME= otr
PORTVERSION= 0.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= security net-im kde
MASTER_SITES= http://kopete-otr.follefuder.org/
PKGNAMEPREFIX= kopete-
@@ -19,7 +19,7 @@ COMMENT= Allows deniable private conversations using Kopete
BUILD_DEPENDS= kopete:${PORTSDIR}/net-im/kopete
RUN_DEPENDS= kopete:${PORTSDIR}/net-im/kopete
-LIB_DEPENDS= otr:${PORTSDIR}/security/libotr
+LIB_DEPENDS= otr.4:${PORTSDIR}/security/libotr3
USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
diff --git a/security/libotr3/Makefile b/security/libotr3/Makefile
index 9e97e19406fb..f2d5e06a29fc 100644
--- a/security/libotr3/Makefile
+++ b/security/libotr3/Makefile
@@ -1,17 +1,10 @@
-# ex:ts=8
-# New ports collection makefile for: libotr
-# Date created: 2005-03-20
-# Whom: Conor McDermottroe <ports@mcdermottroe.com>
-#
# $FreeBSD$
-#
PORTNAME= libotr
PORTVERSION= 3.2.1
# Please do not bump PORTREVISION for this port unless you have
# confirmed via testing that it is necessary
-PORTREVISION= 0
-CATEGORIES= security
+CATEGORIES= security net-im net
MASTER_SITES= http://www.cypherpunks.ca/otr/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -25,6 +18,9 @@ LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error \
MAKE_JOBS_SAFE= yes
+NO_LATEST_LINK= yes
+CONFLICTS= libotr-4.*
+
USE_AUTOTOOLS= autoconf libtool
USE_LDCONFIG= yes
diff --git a/security/py-otr/Makefile b/security/py-otr/Makefile
index 4f88fea0a6cc..3c30d367b5f2 100644
--- a/security/py-otr/Makefile
+++ b/security/py-otr/Makefile
@@ -1,11 +1,8 @@
-# New ports collection makefile for: py-otr
-# Date created: 2010-26-03
-# Whom: Frank Steinborn <steinex@nognu.de>
-#
# $FreeBSD$
PORTNAME= otr
PORTVERSION= 0.2.1.1
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= http://python-otr.pentabarf.de/releases/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +12,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A set of python bindings for libotr
BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/swig13
-LIB_DEPENDS= otr:${PORTSDIR}/security/libotr
+# This should be updated to the newer version of libotr
+LIB_DEPENDS= otr.4:${PORTSDIR}/security/libotr3
USE_PYTHON= yes
USE_PYDISTUTILS=yes