aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-10-28 07:22:56 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-10-28 07:22:56 +0800
commit4446fb959f799fcec537282e8c7bbe12594a4178 (patch)
tree17d938014d7c7d84efdd41a05455f2dded9ae451
parentb45391b5fb2577eb3a82990e615757092e597dbd (diff)
downloadfreebsd-ports-gnome-4446fb959f799fcec537282e8c7bbe12594a4178.tar.gz
freebsd-ports-gnome-4446fb959f799fcec537282e8c7bbe12594a4178.tar.zst
freebsd-ports-gnome-4446fb959f799fcec537282e8c7bbe12594a4178.zip
Allow concurrent installation (USE_PYTHON=concurrent)
- Sort PLIST - Update pkg-descr - Update WWW - Bump PORTREVISION for package change - Take maintainership
-rw-r--r--devel/py-invoke/Makefile15
-rw-r--r--devel/py-invoke/pkg-descr9
2 files changed, 13 insertions, 11 deletions
diff --git a/devel/py-invoke/Makefile b/devel/py-invoke/Makefile
index 4c362194d4ab..52cd4925a688 100644
--- a/devel/py-invoke/Makefile
+++ b/devel/py-invoke/Makefile
@@ -3,24 +3,25 @@
PORTNAME= invoke
PORTVERSION= 0.23.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python task execution tool & library
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}semantic_version>0:devel/py-semantic_version@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}twine>0:devel/py-twine@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}coverage>0:devel/py-coverage@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}semantic_version>=0:devel/py-semantic_version@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}twine>=0:devel/py-twine@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent distutils
-NO_ARCH= YES
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/devel/py-invoke/pkg-descr b/devel/py-invoke/pkg-descr
index 0305d1594e82..068f1305cbc9 100644
--- a/devel/py-invoke/pkg-descr
+++ b/devel/py-invoke/pkg-descr
@@ -1,5 +1,6 @@
-Invoke is a Python (2.6+ and 3.3+) task execution tool & library,
-drawing inspiration from various sources to arrive at a powerful & clean
-feature set.
+Invoke is a Python (2.7 and 3.4+) library for managing shell-oriented
+subprocesses and organizing executable Python code into CLI-invokable tasks. It
+draws inspiration from various sources (make/rake, Fabric 1.x, etc) to arrive at
+a powerful & clean feature set.
-WWW: https://github.com/pyinvoke/invoke/
+WWW: https://github.com/pyinvoke/invoke