aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-05-19 22:50:15 +0800
committerpav <pav@FreeBSD.org>2005-05-19 22:50:15 +0800
commit446b2f42677fffde395a83aa4258e04c9f86ef73 (patch)
tree4d755a8e74fb83d6ef4a12dafc402b9e500410a8
parent7bfcf161e6f8c2087283f7c1260d179f2a9864f0 (diff)
downloadfreebsd-ports-gnome-446b2f42677fffde395a83aa4258e04c9f86ef73.tar.gz
freebsd-ports-gnome-446b2f42677fffde395a83aa4258e04c9f86ef73.tar.zst
freebsd-ports-gnome-446b2f42677fffde395a83aa4258e04c9f86ef73.zip
najitool generates and/or makes altered copies of files in the patterns you
specify or shows to the screen. najitool is being developed in the ANSI C standard so it should work and compile on any system that supports ANSI C, which should be every system. PR: ports/81204 Submitted by: <cokyazici@yahoo.co.uk>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libnaji/Makefile25
-rw-r--r--devel/libnaji/distinfo2
-rw-r--r--devel/libnaji/pkg-descr9
-rw-r--r--devel/libnaji/pkg-plist2
-rw-r--r--misc/Makefile1
-rw-r--r--misc/najitool/Makefile31
-rw-r--r--misc/najitool/distinfo2
-rw-r--r--misc/najitool/pkg-descr9
-rw-r--r--misc/najitool/pkg-plist1
10 files changed, 83 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 531cf37ef2d3..e0649044f8c0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -466,6 +466,7 @@
SUBDIR += libmimedir
SUBDIR += libmtrie
SUBDIR += libmusclecard
+ SUBDIR += libnaji
SUBDIR += liboil
SUBDIR += libol
SUBDIR += libole2
diff --git a/devel/libnaji/Makefile b/devel/libnaji/Makefile
new file mode 100644
index 000000000000..b2804b71803c
--- /dev/null
+++ b/devel/libnaji/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: libnaji
+# Date created: 18 May 2005
+# Whom: NECDET COKYAZICI <cokyazici@yahoo.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnaji
+PORTVERSION= 0.3.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= najitool
+
+MAINTAINER= cokyazici@yahoo.co.uk
+COMMENT= A library that generates, converts, and filters files
+
+MAKEFILE= makefile
+
+DISTVERSIONSUFFIX= .src
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libnaji.h ${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/libnaji.a ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/devel/libnaji/distinfo b/devel/libnaji/distinfo
new file mode 100644
index 000000000000..5af1ab8eab22
--- /dev/null
+++ b/devel/libnaji/distinfo
@@ -0,0 +1,2 @@
+MD5 (libnaji-0.3.0.src.tar.gz) = 3c8af38bb18c43e02fa715ae284a2a9e
+SIZE (libnaji-0.3.0.src.tar.gz) = 24742
diff --git a/devel/libnaji/pkg-descr b/devel/libnaji/pkg-descr
new file mode 100644
index 000000000000..50f4cd222d2c
--- /dev/null
+++ b/devel/libnaji/pkg-descr
@@ -0,0 +1,9 @@
+libnaji is a library of functions which implement the features of najitool,
+a flexible file generator, converter, and filter. libnaji is being developed
+in the ANSI C standard so it should work and compile on any system that
+supports ANSI C, which should be every system.
+
+WWW: http://najitool.sf.net/
+
+- NECDET COKYAZICI
+cokyazici@yahoo.co.uk
diff --git a/devel/libnaji/pkg-plist b/devel/libnaji/pkg-plist
new file mode 100644
index 000000000000..9876c6b8f64d
--- /dev/null
+++ b/devel/libnaji/pkg-plist
@@ -0,0 +1,2 @@
+include/libnaji.h
+lib/libnaji.a
diff --git a/misc/Makefile b/misc/Makefile
index 907871b80aa6..b96e9bb8005e 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -302,6 +302,7 @@
SUBDIR += mtx
SUBDIR += muuz
SUBDIR += nagios-base-logos
+ SUBDIR += najitool
SUBDIR += nserver
SUBDIR += nsf
SUBDIR += numchar
diff --git a/misc/najitool/Makefile b/misc/najitool/Makefile
new file mode 100644
index 000000000000..b4f26faa0112
--- /dev/null
+++ b/misc/najitool/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: najitool
+# Date created: 18 May 2005
+# Whom: NECDET COKYAZICI <cokyazici@yahoo.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= najitool
+PORTVERSION= 0.5.0
+CATEGORIES= misc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= najitool
+
+MAINTAINER= cokyazici@yahoo.co.uk
+COMMENT= A tool that generates, converts, and filters files
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnaji.a:${PORTSDIR}/devel/libnaji
+
+USE_REINPLACE= yes
+
+MAKEFILE= makefile
+
+DISTVERSIONSUFFIX= .src
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|cflags =|cflags = -I${LOCALBASE}/include|; s|libnaji.a|${LOCALBASE}/lib/libnaji.a|' ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/najitool ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/najitool/distinfo b/misc/najitool/distinfo
new file mode 100644
index 000000000000..faeb64821bbf
--- /dev/null
+++ b/misc/najitool/distinfo
@@ -0,0 +1,2 @@
+MD5 (najitool-0.5.0.src.tar.gz) = a12389cfee3104f142ed02f41fb60626
+SIZE (najitool-0.5.0.src.tar.gz) = 10092
diff --git a/misc/najitool/pkg-descr b/misc/najitool/pkg-descr
new file mode 100644
index 000000000000..58964f6ed3b5
--- /dev/null
+++ b/misc/najitool/pkg-descr
@@ -0,0 +1,9 @@
+najitool generates and/or makes altered copies of files in the patterns
+you specify or shows to the screen. najitool is being developed in the
+ANSI C standard so it should work and compile on any system that supports
+ANSI C, which should be every system.
+
+ WWW: http://najitool.sf.net/
+
+ - NECDET COKYAZICI
+ cokyazici@yahoo.co.uk
diff --git a/misc/najitool/pkg-plist b/misc/najitool/pkg-plist
new file mode 100644
index 000000000000..3f4df484b3fa
--- /dev/null
+++ b/misc/najitool/pkg-plist
@@ -0,0 +1 @@
+bin/najitool