aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2013-03-26 14:06:30 +0800
committerglewis <glewis@FreeBSD.org>2013-03-26 14:06:30 +0800
commit451422f05ce54afb9763a7d14f3494a7ca3fa8cb (patch)
treed4edf6d099e07863d3dad792296a7d729916f357
parent3d7120607f51d712fec5cd03ac428bfeec122f1f (diff)
downloadfreebsd-ports-gnome-451422f05ce54afb9763a7d14f3494a7ca3fa8cb.tar.gz
freebsd-ports-gnome-451422f05ce54afb9763a7d14f3494a7ca3fa8cb.tar.zst
freebsd-ports-gnome-451422f05ce54afb9763a7d14f3494a7ca3fa8cb.zip
. Make gnuplot compile with clang and hence remove the GCC requirement.
Submitted by: tijl@
-rw-r--r--math/gnuplot/Makefile3
-rw-r--r--math/gnuplot/files/patch-configure11
2 files changed, 12 insertions, 2 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 106b22db879b..873ca6e17b5a 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gnuplot
PORTVERSION= 4.6.2
+PORTREVISION= 1
CATEGORIES= math graphics
MASTER_SITES= SF
@@ -30,8 +31,6 @@ X11_DESC= Enable X11 support
OPTIONS_DEFAULT=CAIRO GD PDF PLOT TETEX WX X11
-USE_GCC= any
-
MAN1= gnuplot.1 lasergnu.1
.include <bsd.port.options.mk>
diff --git a/math/gnuplot/files/patch-configure b/math/gnuplot/files/patch-configure
new file mode 100644
index 000000000000..8d0a38c707c9
--- /dev/null
+++ b/math/gnuplot/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig
++++ configure
+@@ -5919,7 +5919,7 @@
+ fi
+
+
+-if test "${build}" != "${host}"
++if test "$cross_compiling" != no
+ then
+ CC=${CC-${host_alias-gcc}}
+ CFLAGS=${CFLAGS-"-g -O2"}