aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-21 22:58:36 +0800
committerclsung <clsung@FreeBSD.org>2006-07-21 22:58:36 +0800
commit4549de89df38cfd98b533a7748348e507a3d9709 (patch)
treeffa5480497542af77b5618aaa1097ff309d21e4c
parent8a95ee09ad3db870fcc1cb8c9c8bfa5da024fdce (diff)
downloadfreebsd-ports-gnome-4549de89df38cfd98b533a7748348e507a3d9709.tar.gz
freebsd-ports-gnome-4549de89df38cfd98b533a7748348e507a3d9709.tar.zst
freebsd-ports-gnome-4549de89df38cfd98b533a7748348e507a3d9709.zip
Add p5-File-HStore 0.08, store files on a filesystem using a very simple
hash-based storage. PR: ports/100622 Submitted by: Gea-Suan Lin <gslin at gslin.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-HStore/Makefile25
-rw-r--r--devel/p5-File-HStore/distinfo3
-rw-r--r--devel/p5-File-HStore/pkg-descr16
-rw-r--r--devel/p5-File-HStore/pkg-plist9
5 files changed, 54 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6bdfc00c72aa..8514ac6a4d68 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1019,6 +1019,7 @@
SUBDIR += p5-File-Flock
SUBDIR += p5-File-FnMatch
SUBDIR += p5-File-Grep
+ SUBDIR += p5-File-HStore
SUBDIR += p5-File-HomeDir
SUBDIR += p5-File-Lock
SUBDIR += p5-File-MMagic
diff --git a/devel/p5-File-HStore/Makefile b/devel/p5-File-HStore/Makefile
new file mode 100644
index 000000000000..cd7b248cc3b2
--- /dev/null
+++ b/devel/p5-File-HStore/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-File-HStore
+# Date created: 2006-07-21
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-HStore
+PORTVERSION= 0.08
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/A/AD/ADULAU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Store files on a filesystem using a very simple hash-based storage
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA2.pm:${PORTSDIR}/security/p5-Digest-SHA2
+
+PERL_CONFIGURE= yes
+
+MAN3= File::HStore.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-HStore/distinfo b/devel/p5-File-HStore/distinfo
new file mode 100644
index 000000000000..79466a760a8b
--- /dev/null
+++ b/devel/p5-File-HStore/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-HStore-0.08.tar.gz) = 47007dcd9522a9cb9780af0b9a1b0d20
+SHA256 (File-HStore-0.08.tar.gz) = b25737a60cece5978bc018aaa51123405923c0e6ce0f4cd0648ad7aa58367cc0
+SIZE (File-HStore-0.08.tar.gz) = 4756
diff --git a/devel/p5-File-HStore/pkg-descr b/devel/p5-File-HStore/pkg-descr
new file mode 100644
index 000000000000..5ac8f81b6f3b
--- /dev/null
+++ b/devel/p5-File-HStore/pkg-descr
@@ -0,0 +1,16 @@
+File-HStore is a very minimalist perl library to store files on a
+filesystem using a very simple hash-based storage.
+
+File-HStore is nothing more than a simple wrapper interface to a
+storage containing a specific directory structure where files are hold
+based on their hashes. The name of the directories is based on the
+first two bytes of the hexadecimal form of the digest. The file is
+stored and named with its full hexadecimal form in the corresponding
+prefixed directory.
+
+The current version is supporting the SHA-1 and SHA-2 (256 bits)
+algorithm. The FAT (Free Archive Toolkit) format is also supported and
+it is composed of the date of submission plus the SHA-2 real digest
+part.
+
+WWW: http://search.cpan.org/dist/File-HStore/
diff --git a/devel/p5-File-HStore/pkg-plist b/devel/p5-File-HStore/pkg-plist
new file mode 100644
index 000000000000..393d49baab7b
--- /dev/null
+++ b/devel/p5-File-HStore/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/HStore/.packlist
+%%SITE_PERL%%/File/HStore.pm
+%%SITE_PERL%%/auto/File/HStore/autosplit.ix
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/HStore
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/auto/File/HStore
+@dirrmtry %%SITE_PERL%%/auto/File
+@dirrmtry %%SITE_PERL%%/File