aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-11-18 01:31:04 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-11-18 01:31:04 +0800
commit459c0587e3d87e706b597a5050e4a35663883cdd (patch)
tree665a556b7c102fd78ec2521dcb7a2b6d9dc8ba3e
parentc5372b0cf2ec963e0f3cbdc9a0329c821d3b91e1 (diff)
downloadfreebsd-ports-gnome-459c0587e3d87e706b597a5050e4a35663883cdd.tar.gz
freebsd-ports-gnome-459c0587e3d87e706b597a5050e4a35663883cdd.tar.zst
freebsd-ports-gnome-459c0587e3d87e706b597a5050e4a35663883cdd.zip
Fix build for net/gssdp 1.1.0.1 and net/gupnp 1.1.0 update
- Update LIB_DEPENDS
-rw-r--r--net/gupnp-igd/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/net/gupnp-igd/Makefile b/net/gupnp-igd/Makefile
index 2db1301812d6..47e67281bd4f 100644
--- a/net/gupnp-igd/Makefile
+++ b/net/gupnp-igd/Makefile
@@ -15,25 +15,28 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gobject-introspection>=0.10:devel/gobject-introspection \
gupnp>=0.18:net/gupnp
-LIB_DEPENDS= libgupnp-1.0.so:net/gupnp
+LIB_DEPENDS= libgssdp-1.2.so:net/gssdp \
+ libgupnp-1.2.so:net/gupnp
RUN_DEPENDS= gupnp>=0.18:net/gupnp
OPTIONS_DEFINE= PYTHON
OPTIONS_DEFAULT=PYTHON
OPTIONS_SUB= yes
+USES= gmake gnome libtool pathfix pkgconfig tar:xz
+USE_GNOME= glib20 introspection:build
+
CONFIGURE_ARGS= --enable-introspection=yes
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USE_GNOME= glib20 introspection:build
USE_LDCONFIG= yes
-USES= gmake gnome libtool pathfix pkgconfig tar:xz
PYTHON_CONFIGURE_ENABLE=python
PYTHON_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gobject>=2.12.0:devel/py-gobject@${PY_FLAVOR}
PYTHON_USES= python:2.7
post-patch:
+ @${REINPLACE_CMD} -e 's|gssdp-1.0|gssdp-1.2|; s|gupnp-1.0|gupnp-1.2|' ${WRKSRC}/configure ${WRKSRC}/gupnp-igd-1.0.pc.in ${WRKSRC}/libgupnp-igd/Makefile.in ${WRKSRC}/libgupnp-igd/GUPnPIgd-1.0.gir
@${REINPLACE_CMD} -e '/ --define-variable=/d' ${WRKSRC}/configure
.include <bsd.port.mk>