aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-07-08 00:07:36 +0800
committermiwi <miwi@FreeBSD.org>2008-07-08 00:07:36 +0800
commit4652ddebb3e9cfacc6e7134aa7f47e8c88127584 (patch)
treed74acdc895c89158c03c16de4555b0bc5e6e7217
parenteeab7ca17c797777f69180636a140690fdc902c9 (diff)
downloadfreebsd-ports-gnome-4652ddebb3e9cfacc6e7134aa7f47e8c88127584.tar.gz
freebsd-ports-gnome-4652ddebb3e9cfacc6e7134aa7f47e8c88127584.tar.zst
freebsd-ports-gnome-4652ddebb3e9cfacc6e7134aa7f47e8c88127584.zip
POE::Test::Loops contains one function, generate(), which will
generate all the loop tests for one or more POE::Loop subclasses. WWW: http://search.cpan.org/dist/POE-Test-Loops/ PR: ports/125319 Submitted by: Zach Thompson <hideo at lastamericanempire.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-POE-Test-Loops/Makefile25
-rw-r--r--devel/p5-POE-Test-Loops/distinfo3
-rw-r--r--devel/p5-POE-Test-Loops/pkg-descr4
-rw-r--r--devel/p5-POE-Test-Loops/pkg-plist34
5 files changed, 67 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0e643c64f38b..e7f037ba8a6e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1511,6 +1511,7 @@
SUBDIR += p5-POE-Exceptions
SUBDIR += p5-POE-Session-MultiDispatch
SUBDIR += p5-POE-Stage
+ SUBDIR += p5-POE-Test-Loops
SUBDIR += p5-POE-XS-Queue-Array
SUBDIR += p5-POSIX-strptime
SUBDIR += p5-PPerl
diff --git a/devel/p5-POE-Test-Loops/Makefile b/devel/p5-POE-Test-Loops/Makefile
new file mode 100644
index 000000000000..839a912abef2
--- /dev/null
+++ b/devel/p5-POE-Test-Loops/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-POE-Test-Loops
+# Date created: 05 July 2008
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Test-Loops
+PORTVERSION= 1.002
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= Reusable tests for POE Loop authors
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Test::Loops.3
+MAN1= poe-gen-tests.1
+
+.include <bsd.port.mk>
diff --git a/devel/p5-POE-Test-Loops/distinfo b/devel/p5-POE-Test-Loops/distinfo
new file mode 100644
index 000000000000..6f9db91f0b1e
--- /dev/null
+++ b/devel/p5-POE-Test-Loops/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Test-Loops-1.002.tar.gz) = 70491755b080b64b5e28a64c2c5fe800
+SHA256 (POE-Test-Loops-1.002.tar.gz) = fa02547c83585aba2a76c99333f4e3745da4f734a082b05adbababa0eed88306
+SIZE (POE-Test-Loops-1.002.tar.gz) = 49303
diff --git a/devel/p5-POE-Test-Loops/pkg-descr b/devel/p5-POE-Test-Loops/pkg-descr
new file mode 100644
index 000000000000..d8cca6546fb9
--- /dev/null
+++ b/devel/p5-POE-Test-Loops/pkg-descr
@@ -0,0 +1,4 @@
+POE::Test::Loops contains one function, generate(), which will
+generate all the loop tests for one or more POE::Loop subclasses.
+
+WWW: http://search.cpan.org/dist/POE-Test-Loops/
diff --git a/devel/p5-POE-Test-Loops/pkg-plist b/devel/p5-POE-Test-Loops/pkg-plist
new file mode 100644
index 000000000000..cfa1dee7dc04
--- /dev/null
+++ b/devel/p5-POE-Test-Loops/pkg-plist
@@ -0,0 +1,34 @@
+bin/poe-gen-tests
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Test/Loops/.packlist
+%%SITE_PERL%%/POE/Test/DondeEstan.pm
+%%SITE_PERL%%/POE/Test/Loops.pm
+%%SITE_PERL%%/POE/Test/Loops/all_errors.pm
+%%SITE_PERL%%/POE/Test/Loops/comp_tcp.pm
+%%SITE_PERL%%/POE/Test/Loops/comp_tcp_concurrent.pm
+%%SITE_PERL%%/POE/Test/Loops/connect_errors.pm
+%%SITE_PERL%%/POE/Test/Loops/k_alarms.pm
+%%SITE_PERL%%/POE/Test/Loops/k_aliases.pm
+%%SITE_PERL%%/POE/Test/Loops/k_detach.pm
+%%SITE_PERL%%/POE/Test/Loops/k_selects.pm
+%%SITE_PERL%%/POE/Test/Loops/k_signals.pm
+%%SITE_PERL%%/POE/Test/Loops/k_signals_rerun.pm
+%%SITE_PERL%%/POE/Test/Loops/k_sig_child.pm
+%%SITE_PERL%%/POE/Test/Loops/sbk_signal_init.pm
+%%SITE_PERL%%/POE/Test/Loops/ses_nfa.pm
+%%SITE_PERL%%/POE/Test/Loops/ses_session.pm
+%%SITE_PERL%%/POE/Test/Loops/wheel_readline.pm
+%%SITE_PERL%%/POE/Test/Loops/wheel_sf_udp.pm
+%%SITE_PERL%%/POE/Test/Loops/wheel_sf_tcp.pm
+%%SITE_PERL%%/POE/Test/Loops/wheel_curses.pm
+%%SITE_PERL%%/POE/Test/Loops/wheel_run.pm
+%%SITE_PERL%%/POE/Test/Loops/wheel_accept.pm
+%%SITE_PERL%%/POE/Test/Loops/wheel_sf_ipv6.pm
+%%SITE_PERL%%/POE/Test/Loops/wheel_readwrite.pm
+%%SITE_PERL%%/POE/Test/Loops/wheel_tail.pm
+%%SITE_PERL%%/POE/Test/Loops/wheel_sf_unix.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Test/Loops
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Test
+@dirrmtry %%SITE_PERL%%/POE/Test/Loops
+@dirrmtry %%SITE_PERL%%/POE/Test
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE