aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2012-10-10 23:09:25 +0800
committerBryan Drewery <bdrewery@FreeBSD.org>2012-10-10 23:09:25 +0800
commit4685a6afde8c28f63d2f3ab16233768fd745fc2a (patch)
treefb2ba73a248e6a897aa806ae93ced8db34ee9d84
parent7d4c6e7311e56746e42ad0e0460482bdd6f62f79 (diff)
downloadfreebsd-ports-gnome-4685a6afde8c28f63d2f3ab16233768fd745fc2a.tar.gz
freebsd-ports-gnome-4685a6afde8c28f63d2f3ab16233768fd745fc2a.tar.zst
freebsd-ports-gnome-4685a6afde8c28f63d2f3ab16233768fd745fc2a.zip
Open Chinese Convert (OpenCC) is an open source Simplified-Traditional
Chinese conversion project, providing high quality thesaurus and libopencc, as well as a conversion utility and a dictionary generator. bsdconv is a BSD licensed charset/encoding converter library with more function than libiconv. (Currently, only a few codecs are supported) This port is a opencc conversion module for bsdconv. WWW: https://github.com/buganini/bsdconv-opencc PR: ports/172266 Submitted by: Kuan-Chung Chiu <buganini@gmail.com>
-rw-r--r--chinese/Makefile1
-rw-r--r--chinese/bsdconv-opencc/Makefile26
-rw-r--r--chinese/bsdconv-opencc/distinfo2
-rw-r--r--chinese/bsdconv-opencc/pkg-descr10
-rw-r--r--chinese/bsdconv-opencc/pkg-plist32
5 files changed, 71 insertions, 0 deletions
diff --git a/chinese/Makefile b/chinese/Makefile
index 266ecb52a958..5a176c52fbd2 100644
--- a/chinese/Makefile
+++ b/chinese/Makefile
@@ -19,6 +19,7 @@
SUBDIR += big5con
SUBDIR += big5width
SUBDIR += bitchx
+ SUBDIR += bsdconv-opencc
SUBDIR += bug5
SUBDIR += c2t
SUBDIR += calligra-l10n-zh_CN
diff --git a/chinese/bsdconv-opencc/Makefile b/chinese/bsdconv-opencc/Makefile
new file mode 100644
index 000000000000..f0648079eb5d
--- /dev/null
+++ b/chinese/bsdconv-opencc/Makefile
@@ -0,0 +1,26 @@
+# Created by: buganini@gmail.com
+# $FreeBSD$
+
+PORTNAME= opencc
+PORTVERSION= 1.0
+CATEGORIES= chinese converters
+PKGNAMEPREFIX= bsdconv-
+DISTNAME= ${GH_ACCOUNT}-${GH_PROJECT}-${PORTVERSION}-0-g${GH_COMMIT}
+
+MAINTAINER= buganini@gmail.com
+COMMENT= OpenCC conversion module for bsdconv
+
+LICENSE= BSD
+
+BUILD_DEPENDS= bsdconv_mktable:${PORTSDIR}/converters/bsdconv
+LIB_DEPENDS= bsdconv:${PORTSDIR}/converters/bsdconv \
+ opencc:${PORTSDIR}/chinese/opencc
+
+USE_GITHUB= yes
+GH_ACCOUNT= buganini
+GH_PROJECT= bsdconv-${PORTNAME}
+GH_COMMIT= be3e559
+
+MAKE_ARGS= PREFIX=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/chinese/bsdconv-opencc/distinfo b/chinese/bsdconv-opencc/distinfo
new file mode 100644
index 000000000000..92a89c6a313d
--- /dev/null
+++ b/chinese/bsdconv-opencc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (buganini-bsdconv-opencc-1.0-0-gbe3e559.tar.gz) = 4f21bcc78a5165d7919cc65bcb42c740224acb6de9d14f16915af0f56ba85a63
+SIZE (buganini-bsdconv-opencc-1.0-0-gbe3e559.tar.gz) = 2777
diff --git a/chinese/bsdconv-opencc/pkg-descr b/chinese/bsdconv-opencc/pkg-descr
new file mode 100644
index 000000000000..bbbaad84ca2a
--- /dev/null
+++ b/chinese/bsdconv-opencc/pkg-descr
@@ -0,0 +1,10 @@
+Open Chinese Convert (OpenCC) is an open source Simplified-Traditional
+Chinese conversion project, providing high quality thesaurus and libopencc,
+as well as a conversion utility and a dictionary generator.
+
+bsdconv is a BSD licensed charset/encoding converter library with more function
+than libiconv. (Currently, only a few codecs are supported)
+
+This port is a opencc conversion module for bsdconv.
+
+WWW: https://github.com/buganini/bsdconv-opencc
diff --git a/chinese/bsdconv-opencc/pkg-plist b/chinese/bsdconv-opencc/pkg-plist
new file mode 100644
index 000000000000..b56b4ec790d1
--- /dev/null
+++ b/chinese/bsdconv-opencc/pkg-plist
@@ -0,0 +1,32 @@
+share/bsdconv/inter/OPENCC
+share/bsdconv/inter/OPENCC.so
+share/bsdconv/inter/OPENCC-MIX2ZHS
+share/bsdconv/inter/OPENCC-MIX2ZHS.so
+share/bsdconv/inter/OPENCC-MIX2ZHT
+share/bsdconv/inter/OPENCC-MIX2ZHT.so
+share/bsdconv/inter/OPENCC-ZHS2ZHT
+share/bsdconv/inter/OPENCC-ZHS2ZHT.so
+share/bsdconv/inter/OPENCC-ZHS2ZHTW_P
+share/bsdconv/inter/OPENCC-ZHS2ZHTW_P.so
+share/bsdconv/inter/OPENCC-ZHS2ZHTW_V
+share/bsdconv/inter/OPENCC-ZHS2ZHTW_VP
+share/bsdconv/inter/OPENCC-ZHS2ZHTW_VP.so
+share/bsdconv/inter/OPENCC-ZHS2ZHTW_V.so
+share/bsdconv/inter/OPENCC-ZHT2ZHS
+share/bsdconv/inter/OPENCC-ZHT2ZHS.so
+share/bsdconv/inter/OPENCC-ZHT2ZHTW_P
+share/bsdconv/inter/OPENCC-ZHT2ZHTW_P.so
+share/bsdconv/inter/OPENCC-ZHT2ZHTW_V
+share/bsdconv/inter/OPENCC-ZHT2ZHTW_VP
+share/bsdconv/inter/OPENCC-ZHT2ZHTW_VP.so
+share/bsdconv/inter/OPENCC-ZHT2ZHTW_V.so
+share/bsdconv/inter/OPENCC-ZHTW2ZHCN_S
+share/bsdconv/inter/OPENCC-ZHTW2ZHCN_S.so
+share/bsdconv/inter/OPENCC-ZHTW2ZHCN_T
+share/bsdconv/inter/OPENCC-ZHTW2ZHCN_T.so
+share/bsdconv/inter/OPENCC-ZHTW2ZHS
+share/bsdconv/inter/OPENCC-ZHTW2ZHS.so
+share/bsdconv/inter/OPENCC-ZHTW2ZHT
+share/bsdconv/inter/OPENCC-ZHTW2ZHT.so
+@dirrmtry share/bsdconv/inter
+@dirrmtry share/bsdconv