aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2015-09-07 23:25:25 +0800
committerdanfe <danfe@FreeBSD.org>2015-09-07 23:25:25 +0800
commit46cc663e56cf13ea96d666520d3eb9ef098636ac (patch)
tree97ac9e9e3420558a9f2d38bcb31560d037932e40
parentdd1280b46c56146c258abe2eb42b72c81a885b6b (diff)
downloadfreebsd-ports-gnome-46cc663e56cf13ea96d666520d3eb9ef098636ac.tar.gz
freebsd-ports-gnome-46cc663e56cf13ea96d666520d3eb9ef098636ac.tar.zst
freebsd-ports-gnome-46cc663e56cf13ea96d666520d3eb9ef098636ac.zip
- Unbreak the build on big-endian architectures (particularly, on PowerPC)
- Add `--disable-silent-rules' option to CONFIGURE_ARGS to help debugging - Simplify `tests' target and rename to our more standard `regression-test'
-rw-r--r--textproc/google-ctemplate/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/textproc/google-ctemplate/Makefile b/textproc/google-ctemplate/Makefile
index 40ddeff953be..1625a6fe71cf 100644
--- a/textproc/google-ctemplate/Makefile
+++ b/textproc/google-ctemplate/Makefile
@@ -14,24 +14,27 @@ COMMENT= Simple but powerful template language for C++
OPTIONS_DEFINE= DOCS
-GNU_CONFIGURE= yes
USES= libtool pathfix pkgconfig shebangfix
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-silent-rules
SHEBANG_FILES= src/template-converter
USE_LDCONFIG= yes
-BROKEN_powerpc= Does not compile on powerpc
-
post-patch:
@${REINPLACE_CMD} -e \
's|$$(prefix)/share/doc/$$(PACKAGE)-$$(VERSION)|${DOCSDIR}|' \
${WRKSRC}/Makefile.in
+# XXX: undefining BSWAP32 breaks builds on big-endian systems for some reason
+ @${REINPLACE_CMD} -e 's|# undef BSWAP32|//&|' \
+ ${WRKSRC}/src/base/macros.h
post-patch-DOCS-off:
@${REINPLACE_CMD} -e \
'/install-data-am/ s|install-dist_docDATA||' \
${WRKSRC}/Makefile.in
-tests: build
- @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+regression-test: build
+ @${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} \
+ ${MAKE_ARGS} check -C ${WRKSRC}
.include <bsd.port.mk>