aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-02-22 22:30:22 +0800
committerMathieu Arnold <mat@FreeBSD.org>2018-02-22 22:30:22 +0800
commit47343cbbd83d0054c0b728f2faadd959cf868a76 (patch)
treef22982836519e0a036871045c5b33ac9d45415a5
parent80288e8d2d6c87d166aff8cb1801d637f8546380 (diff)
downloadfreebsd-ports-gnome-47343cbbd83d0054c0b728f2faadd959cf868a76.tar.gz
freebsd-ports-gnome-47343cbbd83d0054c0b728f2faadd959cf868a76.tar.zst
freebsd-ports-gnome-47343cbbd83d0054c0b728f2faadd959cf868a76.zip
Add py-certbot-dns-cloudxns, CloudXNS DNS Authenticator plugin for py-certbot.
Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14262
-rw-r--r--security/Makefile1
-rw-r--r--security/py-certbot-dns-cloudxns/Makefile31
-rw-r--r--security/py-certbot-dns-cloudxns/distinfo3
-rw-r--r--security/py-certbot-dns-cloudxns/pkg-descr3
4 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 8a58c8344bd3..5ea3ed71f7a2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -892,6 +892,7 @@
SUBDIR += py-certbot
SUBDIR += py-certbot-apache
SUBDIR += py-certbot-dns-cloudflare
+ SUBDIR += py-certbot-dns-cloudxns
SUBDIR += py-certbot-nginx
SUBDIR += py-certifi
SUBDIR += py-cpe
diff --git a/security/py-certbot-dns-cloudxns/Makefile b/security/py-certbot-dns-cloudxns/Makefile
new file mode 100644
index 000000000000..ae0db5dad553
--- /dev/null
+++ b/security/py-certbot-dns-cloudxns/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= certbot-dns-cloudxns
+PORTVERSION= ${ACME_VERSION}
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= CloudXNS DNS Authenticator plugin for Certbot
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION}:security/py-acme@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION}:security/py-certbot@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dns-lexicon>0:dns/py-dns-lexicon@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${FLAVOR}
+
+.include "${.CURDIR}/../py-acme/version.mk"
+.include <bsd.port.mk>
diff --git a/security/py-certbot-dns-cloudxns/distinfo b/security/py-certbot-dns-cloudxns/distinfo
new file mode 100644
index 000000000000..fc6326b9fe74
--- /dev/null
+++ b/security/py-certbot-dns-cloudxns/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518081734
+SHA256 (certbot-dns-cloudxns-0.21.1.tar.gz) = 4dca77bf1eae36578513da1ca75e350bccc8cb5536f157bca7615bc49f1bb7b0
+SIZE (certbot-dns-cloudxns-0.21.1.tar.gz) = 11373
diff --git a/security/py-certbot-dns-cloudxns/pkg-descr b/security/py-certbot-dns-cloudxns/pkg-descr
new file mode 100644
index 000000000000..d2263e176738
--- /dev/null
+++ b/security/py-certbot-dns-cloudxns/pkg-descr
@@ -0,0 +1,3 @@
+This is the CloudXNS DNS Authenticator plugin for Certbot (security/py-certbot).
+
+WWW: https://github.com/certbot/certbot