aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-08-25 11:45:28 +0800
committertobik <tobik@FreeBSD.org>2018-08-25 11:45:28 +0800
commit4782e43f3a4145e4d2c66f8ca81551a79f5f94b5 (patch)
tree2fdfa62517bc76fcf999664bfd355ca8d453643c
parent852648fbd9be3318c4e202423f6a53c563a91a5e (diff)
downloadfreebsd-ports-gnome-4782e43f3a4145e4d2c66f8ca81551a79f5f94b5.tar.gz
freebsd-ports-gnome-4782e43f3a4145e4d2c66f8ca81551a79f5f94b5.tar.zst
freebsd-ports-gnome-4782e43f3a4145e4d2c66f8ca81551a79f5f94b5.zip
biology/protomol: Fix build with Clang 6
Report.cpp:208:12: error: invalid operands to binary expression ('std::ostream' (aka 'basic_ostream<char>') and 'const std::__1::ostream' (aka 'const basic_ostream<char>')) *myStream << a; ~~~~~~~~~ ^ ~ /usr/include/c++/v1/ostream:218:20: note: candidate function not viable: no known conversion from 'const std::__1::ostream' (aka 'const basic_ostream<char>') to 'const void *' for 1st argument; take the address of the argument with & basic_ostream& operator<<(const void* __p); ^ ... and so on ... http://beefy11.nyi.freebsd.org/data/head-i386-default/p477696_s338122/logs/errors/protomol-2.0.3_13.log
-rw-r--r--biology/protomol/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/biology/protomol/Makefile b/biology/protomol/Makefile
index 2be07195d4f7..bfd69198dc0e 100644
--- a/biology/protomol/Makefile
+++ b/biology/protomol/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff
USES= shebangfix
+USE_CXXSTD= c++98
SHEBANG_FILES= examples/butane_4/procDihedralFile.awk \
examples/butane_4/cleanOutput.bash \
examples/butane_4/runButaneResults.sh \