aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-02-01 22:36:03 +0800
committersobomax <sobomax@FreeBSD.org>2001-02-01 22:36:03 +0800
commit480aec3d5184be24bf4891396a1ade74957722b4 (patch)
tree916b674585483de5345417ba61f0d1ab92bc8f30
parente235c6fabf2e9eb7f1b76a22c69b54a248361bf4 (diff)
downloadfreebsd-ports-gnome-480aec3d5184be24bf4891396a1ade74957722b4.tar.gz
freebsd-ports-gnome-480aec3d5184be24bf4891396a1ade74957722b4.tar.zst
freebsd-ports-gnome-480aec3d5184be24bf4891396a1ade74957722b4.zip
Update to 1.5.
Submitted by: tg
-rw-r--r--math/py-gnuplot/Makefile19
-rw-r--r--math/py-gnuplot/distinfo2
-rw-r--r--math/py-gnuplot/pkg-plist76
3 files changed, 91 insertions, 6 deletions
diff --git a/math/py-gnuplot/Makefile b/math/py-gnuplot/Makefile
index 7855025277b5..becc1c69a1ef 100644
--- a/math/py-gnuplot/Makefile
+++ b/math/py-gnuplot/Makefile
@@ -6,23 +6,32 @@
#
PORTNAME= py-gnuplot
-PORTVERSION= 1.4
+PORTVERSION= 1.5
CATEGORIES= math python
-MASTER_SITES= http://monsoon.harvard.edu/~mhagger/Gnuplot/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gnuplot-py
DISTNAME= Gnuplot-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/Numeric/_numpy.so:${PORTSDIR}/math/numpy
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
${PYTHON_SITELIBDIR}/Numeric/_numpy.so:${PORTSDIR}/math/numpy
USE_PYTHON= yes
+SETUP_CMD= cd ${WRKSRC}; ${PYTHON_CMD} setup.py
do-build:
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @${SETUP_CMD} build
do-install:
- ${MKDIR} ${PYTHON_SITELIBDIR}/Gnuplot
- ${INSTALL_DATA} ${WRKSRC}/*.py? ${PYTHON_SITELIBDIR}/Gnuplot
+ @${SETUP_CMD} install
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/py-gnuplot
+ cd ${WRKSRC}/doc && ${TAR} -chf - * | \
+ ${TAR} --unlink -xf - -C ${PREFIX}/share/doc/py-gnuplot
+.endif
.include <bsd.port.mk>
diff --git a/math/py-gnuplot/distinfo b/math/py-gnuplot/distinfo
index 07d2470286d8..0815b58aae88 100644
--- a/math/py-gnuplot/distinfo
+++ b/math/py-gnuplot/distinfo
@@ -1 +1 @@
-MD5 (Gnuplot-1.4.tar.gz) = 414d80e1e9acb6acd8fd21dba80d7092
+MD5 (Gnuplot-1.5.tar.gz) = 94da6c11af51d5872c498e59fd31c9a0
diff --git a/math/py-gnuplot/pkg-plist b/math/py-gnuplot/pkg-plist
index df14b0cd98db..e38153bb87d1 100644
--- a/math/py-gnuplot/pkg-plist
+++ b/math/py-gnuplot/pkg-plist
@@ -1,9 +1,85 @@
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/PlotItems.py
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/PlotItems.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/_Gnuplot.py
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/_Gnuplot.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/__init__.py
lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/__init__.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/demo.py
lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/demo.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/funcutils.py
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/funcutils.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/gnuplot_Suites.py
lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/gnuplot_Suites.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/gp.py
lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/gp.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/gp_mac.py
lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/gp_mac.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/gp_unix.py
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/gp_unix.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/gp_win32.py
lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/gp_win32.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/oldplot.py
lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/oldplot.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/test.py
lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/test.pyc
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/utils.py
+lib/%%PYTHON_VERSION%%/site-packages/Gnuplot/utils.pyc
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/PlotItems.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/PlotItems.py_AnyFile.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/PlotItems.py_ArrayFile.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/PlotItems.py_Data.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/PlotItems.py_DataException.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/PlotItems.py_File.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/PlotItems.py_Func.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/PlotItems.py_GridData.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/PlotItems.py_OptionException.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/PlotItems.py_PlotItem.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/PlotItems.py_TempArrayFile.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/PlotItems.py_TempFile.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/PlotItems.py__unset.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/_Gnuplot.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/_Gnuplot.py_Gnuplot.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/_Gnuplot.py__GnuplotFile.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/demo.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/funcutils.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gnuplot_Suites.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gnuplot_Suites.py_Miscellaneous_Events.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gnuplot_Suites.py_Standard_Suite.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gnuplot_Suites.py_gnuplot_Suite.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gnuplot_Suites.py_odds_and_ends.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gp.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gp_mac.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gp_mac.py_GnuplotOpts.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gp_mac.py_GnuplotProcess.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gp_mac.py__GNUPLOT.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gp_unix.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gp_unix.py_GnuplotOpts.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gp_unix.py_GnuplotProcess.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gp_win32.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gp_win32.py_GnuplotOpts.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/gp_win32.py_GnuplotProcess.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/oldplot.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/setup.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/test.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/Gnuplot/utils.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/PlotItems.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/PlotItems.py_AnyFile.html
+%%PORTDOCS%%share/doc/py-gnuplot/PlotItems.py_ArrayFile.html
+%%PORTDOCS%%share/doc/py-gnuplot/PlotItems.py_Data.html
+%%PORTDOCS%%share/doc/py-gnuplot/PlotItems.py_DataException.html
+%%PORTDOCS%%share/doc/py-gnuplot/PlotItems.py_File.html
+%%PORTDOCS%%share/doc/py-gnuplot/PlotItems.py_Func.html
+%%PORTDOCS%%share/doc/py-gnuplot/PlotItems.py_GridData.html
+%%PORTDOCS%%share/doc/py-gnuplot/PlotItems.py_OptionException.html
+%%PORTDOCS%%share/doc/py-gnuplot/PlotItems.py_PlotItem.html
+%%PORTDOCS%%share/doc/py-gnuplot/PlotItems.py_TempArrayFile.html
+%%PORTDOCS%%share/doc/py-gnuplot/PlotItems.py_TempFile.html
+%%PORTDOCS%%share/doc/py-gnuplot/PlotItems.py__unset.html
+%%PORTDOCS%%share/doc/py-gnuplot/_Gnuplot.py.html
+%%PORTDOCS%%share/doc/py-gnuplot/_Gnuplot.py_Gnuplot.html
+%%PORTDOCS%%share/doc/py-gnuplot/_Gnuplot.py__GnuplotFile.html
+%%PORTDOCS%%share/doc/py-gnuplot/index.html
@dirrm lib/%%PYTHON_VERSION%%/site-packages/Gnuplot
+%%PORTDOCS%%@dirrm share/doc/py-gnuplot/Gnuplot
+%%PORTDOCS%%@dirrm share/doc/py-gnuplot