aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-06-06 06:09:07 +0800
committermiwi <miwi@FreeBSD.org>2009-06-06 06:09:07 +0800
commit483911344935dd35087bba5452a96405be1df8e7 (patch)
tree70e9d61cc154bd44430a855aac64c22a94fe3450
parentbf6b91f688075b49f0d617c1272a4781f1eba741 (diff)
downloadfreebsd-ports-gnome-483911344935dd35087bba5452a96405be1df8e7.tar.gz
freebsd-ports-gnome-483911344935dd35087bba5452a96405be1df8e7.tar.zst
freebsd-ports-gnome-483911344935dd35087bba5452a96405be1df8e7.zip
Global Menu is the globally-shared menu bar of all applications
launched in your desktop session. WWW: http://code.google.com/p/gnome2-globalmenu/ PR: ports/135049 Submitted by: Gustavo Perez
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/global-menu/Makefile44
-rw-r--r--deskutils/global-menu/distinfo3
-rw-r--r--deskutils/global-menu/files/patch-makefile.am11
-rw-r--r--deskutils/global-menu/files/patch-makefile.in11
-rw-r--r--deskutils/global-menu/files/patch-menuitem.c11
-rw-r--r--deskutils/global-menu/pkg-descr4
-rw-r--r--deskutils/global-menu/pkg-message7
-rw-r--r--deskutils/global-menu/pkg-plist60
9 files changed, 152 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index 1c50013bf10a..3f00af734d05 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -78,6 +78,7 @@
SUBDIR += gkrellm-timers
SUBDIR += glabels
SUBDIR += glipper
+ SUBDIR += global-menu
SUBDIR += gmcal
SUBDIR += gnochm
SUBDIR += gnome-blog
diff --git a/deskutils/global-menu/Makefile b/deskutils/global-menu/Makefile
new file mode 100644
index 000000000000..3d088b288d65
--- /dev/null
+++ b/deskutils/global-menu/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: gnome-globalmenu
+# Date created: 27 February 2009
+# Whom: Gustavo Perez
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnome-globalmenu
+PORTVERSION= 0.7.5
+CATEGORIES= deskutils
+MASTER_SITES= http://gnome2-globalmenu.googlecode.com/files/
+
+MAINTAINER= gustau.perez@gmail.com
+COMMENT= Global menu for gnome
+
+USE_GNOME= gnomepanel gnomedesktop
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15 automake:19:env autoheader:262:env
+INSTALLS_ICONS= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+MAN1= gnome-globalmenu.1
+
+GCONF_SCHEMAS= gnome-globalmenu.schemas
+
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/applet/GlobalMenu_PanelApplet.server \
+ ${LOCALBASE}/libdata/bonobo/servers
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/deskutils/global-menu/distinfo b/deskutils/global-menu/distinfo
new file mode 100644
index 000000000000..671d0a870e39
--- /dev/null
+++ b/deskutils/global-menu/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome-globalmenu-0.7.5.tar.bz2) = bafbad33ad43ba401d228dbaa10f26a0
+SHA256 (gnome-globalmenu-0.7.5.tar.bz2) = d628604c9623587cdb8b1459b6acee7a038faa2380d814ced27a22a72839d4db
+SIZE (gnome-globalmenu-0.7.5.tar.bz2) = 623230
diff --git a/deskutils/global-menu/files/patch-makefile.am b/deskutils/global-menu/files/patch-makefile.am
new file mode 100644
index 000000000000..f582c8b0eb21
--- /dev/null
+++ b/deskutils/global-menu/files/patch-makefile.am
@@ -0,0 +1,11 @@
+--- libgnomenu/Makefile.am.orig 2009-04-27 10:04:37.000000000 +0200
++++ libgnomenu/Makefile.am 2009-04-27 10:05:43.000000000 +0200
+@@ -32,7 +32,7 @@
+ libgnomenu_la_LIBADD = $(GTK_LIBS) $(WNCK_LIBS) $(X11_LIBS) ../libcompat/libcompat.la
+ libgnomenu_la_LDFLAGS = -version-info 2:0:0 -release $(VERSION) -no-undefined -Wl,--as-needed
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = libgnomenu.pc
+
+ libgnomenu_includedir = $(includedir)/libgnomenu
diff --git a/deskutils/global-menu/files/patch-makefile.in b/deskutils/global-menu/files/patch-makefile.in
new file mode 100644
index 000000000000..23c987986725
--- /dev/null
+++ b/deskutils/global-menu/files/patch-makefile.in
@@ -0,0 +1,11 @@
+--- libgnomenu/Makefile.in.orig 2009-04-27 10:06:46.000000000 +0200
++++ libgnomenu/Makefile.in 2009-04-27 10:07:20.000000000 +0200
+@@ -324,7 +324,7 @@
+ libgnomenu_la_CPPFLAGS = -I$(top_srcdir) $(GTK_CFLAGS) $(WNCK_CFLAGS) $(X11_CFLAGS) -include $(CONFIG_HEADER) -DWNCK_I_KNOW_THIS_IS_UNSTABLE
+ libgnomenu_la_LIBADD = $(GTK_LIBS) $(WNCK_LIBS) $(X11_LIBS) ../libcompat/libcompat.la
+ libgnomenu_la_LDFLAGS = -version-info 2:0:0 -release $(VERSION) -no-undefined -Wl,--as-needed
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = libgnomenu.pc
+ libgnomenu_includedir = $(includedir)/libgnomenu
+ libgnomenu_include_HEADERS = $(VALASOURCES:.vala=.h)
diff --git a/deskutils/global-menu/files/patch-menuitem.c b/deskutils/global-menu/files/patch-menuitem.c
new file mode 100644
index 000000000000..9e796739df87
--- /dev/null
+++ b/deskutils/global-menu/files/patch-menuitem.c
@@ -0,0 +1,11 @@
+--- libgnomenu/menuitem.c.old 2009-06-03 12:00:59.000000000 +0200
++++ libgnomenu/menuitem.c 2009-06-03 12:01:05.000000000 +0200
+@@ -128,7 +128,7 @@
+ }
+ if (_tmp0) {
+ g_debug ("menuitem.vala:81: maybe?");
+- if (gtk_menu_item_get_submenu ((GtkMenuItem*) self) != GTK_MENU (self->_submenu_cache)) {
++ if (gtk_menu_item_get_submenu ((GtkMenuItem*) self) != (GtkWidget*) GTK_MENU (self->_submenu_cache)) {
+ gtk_menu_item_set_submenu ((GtkMenuItem*) self, (GtkMenu*) self->_submenu_cache);
+ }
+ } else {
diff --git a/deskutils/global-menu/pkg-descr b/deskutils/global-menu/pkg-descr
new file mode 100644
index 000000000000..a09b58ea4af5
--- /dev/null
+++ b/deskutils/global-menu/pkg-descr
@@ -0,0 +1,4 @@
+Global Menu is the globally-shared menu bar of all applications
+launched in your desktop session.
+
+WWW: http://code.google.com/p/gnome2-globalmenu/
diff --git a/deskutils/global-menu/pkg-message b/deskutils/global-menu/pkg-message
new file mode 100644
index 000000000000..5c189a182ddd
--- /dev/null
+++ b/deskutils/global-menu/pkg-message
@@ -0,0 +1,7 @@
+Before adding the applet to your top/bottom panel, please
+ensure libglobalmenu-gnome is loaded as a Gtk module
+by setting the following gconf key :
+
+ apps/gnome-settings-daemon/gtk-modules/globalmenu-gnome
+
+Before that, you can simply add the applet to your panel.
diff --git a/deskutils/global-menu/pkg-plist b/deskutils/global-menu/pkg-plist
new file mode 100644
index 000000000000..f03c576170d7
--- /dev/null
+++ b/deskutils/global-menu/pkg-plist
@@ -0,0 +1,60 @@
+include/libgnomenu/application.h
+include/libgnomenu/globalmenu.h
+include/libgnomenu/gnomenu.h
+include/libgnomenu/helper.h
+include/libgnomenu/interface-item.h
+include/libgnomenu/interface-shell.h
+include/libgnomenu/keygrab.h
+include/libgnomenu/label.h
+include/libgnomenu/menu.h
+include/libgnomenu/menubar.h
+include/libgnomenu/menubarbox.h
+include/libgnomenu/menuitem.h
+include/libgnomenu/menushellutils.h
+include/libgnomenu/monitor.h
+include/libgnomenu/parser.h
+include/libgnomenu/serializer.h
+include/libgnomenu/window.h
+lib/bonobo/servers/GlobalMenu_PanelApplet.server
+lib/gtk-2.0/modules/libglobalmenu-gnome-0.7.5.so
+lib/gtk-2.0/modules/libglobalmenu-gnome.la
+lib/gtk-2.0/modules/libglobalmenu-gnome.so
+lib/libgnomenu-0.7.5.so
+lib/libgnomenu-0.7.5.so.2
+lib/libgnomenu.la
+lib/libgnomenu.so
+libdata/pkgconfig/libgnomenu.pc
+libdata/bonobo/servers/GlobalMenu_PanelApplet.server
+libexec/GlobalMenu.PanelApplet
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/ChangeLog
+%%DOCSDIR%%/INSTALL
+%%DOCSDIR%%/README
+%%DOCSDIR%%/README.GNOME
+%%DOCSDIR%%/README.XFCE
+share/locale/de/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/en_GB/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/es/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/fi/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/fr/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/hu/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/id/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/it/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/ko/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/nl/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/pl/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/pt/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/ru/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/sv/LC_MESSAGES/gnome-globalmenu.mo
+share/locale/zh_CN/LC_MESSAGES/gnome-globalmenu.mo
+share/pixmaps/globalmenu.png
+@dirrmtry share/locale
+@dirrmtry share/pixmaps
+@dirrmtry include/libgnomenu
+@dirrmtry libdata/pkgconfig
+@dirrmtry libexec
+@dirrmtry lib/bonobo/servers
+@dirrmtry libdata/bonobo/servers
+@dirrm %%DOCSDIR%%