aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2012-12-21 14:39:49 +0800
committeroliver <oliver@FreeBSD.org>2012-12-21 14:39:49 +0800
commit487af90af20c6929b8b62cb40b9b906c1248e08d (patch)
tree73d8626a9a8f64c83918c7238d1e64c6d8edb928
parent73f6e2ac0d46c1fb631db55337ddb2f399b1ffab (diff)
downloadfreebsd-ports-gnome-487af90af20c6929b8b62cb40b9b906c1248e08d.tar.gz
freebsd-ports-gnome-487af90af20c6929b8b62cb40b9b906c1248e08d.tar.zst
freebsd-ports-gnome-487af90af20c6929b8b62cb40b9b906c1248e08d.zip
use USE_CSTD instead of manually setting CFLAGS
-rw-r--r--security/oidentd/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/security/oidentd/Makefile b/security/oidentd/Makefile
index 920987f00690..1cbdbb3ec81c 100644
--- a/security/oidentd/Makefile
+++ b/security/oidentd/Makefile
@@ -21,7 +21,7 @@ MAN5= oidentd.conf.5 oidentd_masq.conf.5
MAN8= oidentd.8
PLIST_FILES= sbin/oidentd etc/oidentd.conf.sample \
etc/oidentd_masq.conf.sample
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} -std=gnu89"
+USE_CSTD= gnu89
OPTIONS= IPV6 "Enable IPv6 support" on \
MASQ "Enable NAT/IP masq support" on
@@ -31,7 +31,7 @@ OPTIONS= IPV6 "Enable IPv6 support" on \
.if defined(WITHOUT_IPV6)
CONFIGURE_ARGS+=--disable-ipv6
.else
-CATEGORIES+= ipv6
+CATEGORIES+= ipv6
.endif
.if defined(WITHOUT_MASQ) || ${OSVERSION} >= 800000