aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvg <vg@FreeBSD.org>2015-11-27 00:15:55 +0800
committervg <vg@FreeBSD.org>2015-11-27 00:15:55 +0800
commit48a20189a5f86fe77dddb9a2f954c4e107ab3a8c (patch)
tree5c4894e80b3254703a9c1703a493d8a587878e13
parent4d3f7f3a921b3f71adfe4438dd29a6d63eeba53d (diff)
downloadfreebsd-ports-gnome-48a20189a5f86fe77dddb9a2f954c4e107ab3a8c.tar.gz
freebsd-ports-gnome-48a20189a5f86fe77dddb9a2f954c4e107ab3a8c.tar.zst
freebsd-ports-gnome-48a20189a5f86fe77dddb9a2f954c4e107ab3a8c.zip
- Fix bug with SSL
-rw-r--r--net-mgmt/sx/Makefile1
-rw-r--r--net-mgmt/sx/files/patch-libsxclient_src_openssl.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/net-mgmt/sx/Makefile b/net-mgmt/sx/Makefile
index d99a64d1ec40..9df4de22ffd1 100644
--- a/net-mgmt/sx/Makefile
+++ b/net-mgmt/sx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sx
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://cdn.skylable.com/source/
diff --git a/net-mgmt/sx/files/patch-libsxclient_src_openssl.c b/net-mgmt/sx/files/patch-libsxclient_src_openssl.c
new file mode 100644
index 000000000000..f272bd88350e
--- /dev/null
+++ b/net-mgmt/sx/files/patch-libsxclient_src_openssl.c
@@ -0,0 +1,11 @@
+--- libsxclient/src/openssl.c.orig 2015-07-24 14:26:43 UTC
++++ libsxclient/src/openssl.c
+@@ -98,6 +98,8 @@ int sxi_sslctxfun(sxc_client_t *sx, curl
+ return -1;
+ }
+ SSL_CTX *ctx = (SSL_CTX*)info->internals;
++ if (!ctx)
++ return -EAGAIN;
+ SSL_CTX_set_cert_verify_callback(ctx, ssl_verify_hostname, ev);
+ return 0;
+ }