aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2018-06-03 15:30:06 +0800
committeracm <acm@FreeBSD.org>2018-06-03 15:30:06 +0800
commit4a3fc280467b94d89d91fe98277e5a9678fe7b17 (patch)
treea42b0f4c195553bc03b65db703054792b65d807e
parente1c67291481b7f197bc33ab2d40e89391de1d769 (diff)
downloadfreebsd-ports-gnome-4a3fc280467b94d89d91fe98277e5a9678fe7b17.tar.gz
freebsd-ports-gnome-4a3fc280467b94d89d91fe98277e5a9678fe7b17.tar.zst
freebsd-ports-gnome-4a3fc280467b94d89d91fe98277e5a9678fe7b17.zip
- Update to 0.8.12
-rw-r--r--editors/dlangide/Makefile12
-rw-r--r--editors/dlangide/distinfo6
-rw-r--r--editors/dlangide/files/patch-dub.json17
-rw-r--r--editors/dlangide/pkg-descr2
4 files changed, 23 insertions, 14 deletions
diff --git a/editors/dlangide/Makefile b/editors/dlangide/Makefile
index 9deb262f0f70..7afb0d170d81 100644
--- a/editors/dlangide/Makefile
+++ b/editors/dlangide/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dlangide
-PORTVERSION= 0.7.30
+PORTVERSION= 0.8.12
DISTVERSIONPREFIX= v
CATEGORIES= editors
@@ -23,6 +23,7 @@ BUILD_DEPENDS= ldmd2:lang/ldc \
${LOCALBASE}/lib/d/libDerelictGL3.a:graphics/derelict-gl3 \
${LOCALBASE}/lib/d/libDerelictSDL2.a:devel/derelict-sdl2 \
${LOCALBASE}/lib/d/libDerelictFT.a:print/derelict-ft \
+ ${LOCALBASE}/lib/d/libstdx-allocator.a:devel/stdx-allocator \
dcd-server:devel/dcd-server
USE_GITHUB= yes
@@ -31,8 +32,15 @@ GH_ACCOUNT= buggins
PLIST_FILES= bin/${PORTNAME}
DUB_CMD= ${LOCALBASE}/bin/dub build --build=release
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/dub.json
+ ${REINPLACE_CMD} -e 's|server.|dcd.server.|g' \
+ -e 's|common.messages|dcd.common.messages|g' \
+ ${WRKSRC}/src/dlangide/tools/d/dcdinterface.d
+
do-build:
- @cd ${WRKSRC} && ${DUB_CMD}
+ @cd ${WRKSRC} && ${DUB_CMD} --config=default
+ @cd ${WRKSRC} && ${DUB_CMD} --config=console
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
diff --git a/editors/dlangide/distinfo b/editors/dlangide/distinfo
index e2175924f2a5..5f5cbb897e34 100644
--- a/editors/dlangide/distinfo
+++ b/editors/dlangide/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1501067350
-SHA256 (buggins-dlangide-v0.7.30_GH0.tar.gz) = 5255ac4dfd70bf0d2f2a9306fbb1338f1c03f8ae5015dfe10d5fb8a942ab8225
-SIZE (buggins-dlangide-v0.7.30_GH0.tar.gz) = 2291395
+TIMESTAMP = 1525934043
+SHA256 (buggins-dlangide-v0.8.12_GH0.tar.gz) = 026d9189e2fdb035928a7312e9f80b9a4f11dcb8281aaebcd09be85b8dfd0bb8
+SIZE (buggins-dlangide-v0.8.12_GH0.tar.gz) = 2323290
diff --git a/editors/dlangide/files/patch-dub.json b/editors/dlangide/files/patch-dub.json
index 82b6cedf2d12..714ccf094d4d 100644
--- a/editors/dlangide/files/patch-dub.json
+++ b/editors/dlangide/files/patch-dub.json
@@ -1,17 +1,18 @@
---- dub.json.orig 2017-04-11 13:32:24 UTC
-+++ dub.json
-@@ -8,14 +8,10 @@
+--- dub.json.orig 2018-05-08 03:44:57.000000000 -0500
++++ dub.json 2018-05-10 01:35:07.457388000 -0500
+@@ -8,15 +8,10 @@
"targetName": "dlangide",
"targetPath": "bin",
"targetType": "executable",
-
-+ "libs": ["dlangui","dsymbol","dparse","dlib","dcd","emsi_containers","msgpack-d", "DerelictFT","DerelictUtil","DerelictGL3","DerelictSDL2"],
-+ "lflags":["-L/usr/local/lib/d","-L/usr/local/lib"],
- "stringImportPaths": ["views", "views/res", "views/res/i18n", "views/res/mdpi", "views/res/hdpi"],
++ "libs": ["dlangui","dsymbol","dparse","dlib","dcd","emsi_containers","msgpack-d", "DerelictFT","DerelictUtil","DerelictGL3","DerelictSDL2","stdx-allocator"],
++ "lflags":["-L%%LOCALBASE%%/lib/d","-L%%LOCALBASE%%/lib"],
+ "stringImportPaths": ["views"],
- "dependencies": {
-- "dlangui": "==0.9.50",
-- "dcd": "~>0.9.0-alpha4"
+- "dlangui": "==0.9.178",
+- "dsymbol": "~>0.2.9",
+- "dcd": "~>0.9.1"
- },
-
"copyFiles-windows": [
diff --git a/editors/dlangide/pkg-descr b/editors/dlangide/pkg-descr
index e61e93638219..23ee0a712120 100644
--- a/editors/dlangide/pkg-descr
+++ b/editors/dlangide/pkg-descr
@@ -21,4 +21,4 @@ Cross platform D language IDE written using DlangUI library.
- D source code Smart Indents
- Select word by mouse double click
-WWW: https://github.com/buggins/dlangui
+WWW: https://github.com/buggins/dlangide