aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-11-08 05:43:55 +0800
committerdinoex <dinoex@FreeBSD.org>2004-11-08 05:43:55 +0800
commit4c1f07834dfd2ce700f740c24441b3f9c82fa5f6 (patch)
tree21ebcef1322dd50e14c8371e876036f222ecb9eb
parentac70ed51a5eb08632fde62364f7578dc1b0704c0 (diff)
downloadfreebsd-ports-gnome-4c1f07834dfd2ce700f740c24441b3f9c82fa5f6.tar.gz
freebsd-ports-gnome-4c1f07834dfd2ce700f740c24441b3f9c82fa5f6.tar.zst
freebsd-ports-gnome-4c1f07834dfd2ce700f740c24441b3f9c82fa5f6.zip
- update to 1.10.0 (stable)
-rw-r--r--devel/gnustep-make/Makefile9
-rw-r--r--devel/gnustep-make/distinfo4
-rw-r--r--devel/gnustep-make/pkg-plist8
-rw-r--r--devel/gnustep/Makefile2
-rw-r--r--lang/gnustep-base/Makefile21
-rw-r--r--lang/gnustep-base/distinfo4
-rw-r--r--lang/gnustep-base/files/NSFileManager.m.patch20
-rw-r--r--lang/gnustep-base/pkg-plist37
8 files changed, 57 insertions, 48 deletions
diff --git a/devel/gnustep-make/Makefile b/devel/gnustep-make/Makefile
index 043c2657b6e5..8fe7964ab0b9 100644
--- a/devel/gnustep-make/Makefile
+++ b/devel/gnustep-make/Makefile
@@ -9,8 +9,7 @@ PORTNAME= gnustep-make
.if defined(WITH_GNUSTEP_DEVEL)
PORTVERSION= 1.9.2
.else
-PORTVERSION= 1.8.0
-PORTREVISION= 2
+PORTVERSION= 1.10.0
.endif
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNUSTEP}
@@ -30,14 +29,10 @@ USE_GNUSTEP= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ARGS+= --with-thread-lib="${PTHREAD_LIBS}"
.if defined(GNUSTEP_WITH_BASE_GCC)
GNUSTEP_WITHOUT_LIBOBJC= yes
.endif
-post-configure:
- ${MV} ${WRKSRC}/config.make ${WRKSRC}/config.make.sed
- ${SED} -e "s|\(objc_threaded:=\).*|\1${PTHREAD_LIBS}|" \
- < ${WRKSRC}/config.make.sed > ${WRKSRC}/config.make
-
.include <bsd.port.mk>
diff --git a/devel/gnustep-make/distinfo b/devel/gnustep-make/distinfo
index bda7365fe496..d6b8c47f6ac6 100644
--- a/devel/gnustep-make/distinfo
+++ b/devel/gnustep-make/distinfo
@@ -1,4 +1,4 @@
MD5 (gnustep-make-1.9.2.tar.gz) = 80acfa3ccaaae94f467f913d7cfedd8d
SIZE (gnustep-make-1.9.2.tar.gz) = 366822
-MD5 (gnustep-make-1.8.0.tar.gz) = 3d8de1ed93c45b2cbfa32fe9fd0396dd
-SIZE (gnustep-make-1.8.0.tar.gz) = 359394
+MD5 (gnustep-make-1.10.0.tar.gz) = bfd0f6530b938e7ee1d5a300219a0ab3
+SIZE (gnustep-make-1.10.0.tar.gz) = 372852
diff --git a/devel/gnustep-make/pkg-plist b/devel/gnustep-make/pkg-plist
index 9438b14d81c4..b723974d8040 100644
--- a/devel/gnustep-make/pkg-plist
+++ b/devel/gnustep-make/pkg-plist
@@ -1,5 +1,6 @@
@exec mkdir -p %D/System/Library/Makefiles
@exec ln -s Library/Makefiles %D/System
+%%GNUSTEP_STABLE%%System/.GNUsteprc
System/Library/Makefiles/GNUstep-reset.sh
System/Library/Makefiles/GNUstep.csh
System/Library/Makefiles/GNUstep.sh
@@ -90,7 +91,7 @@ System/Library/Makefiles/library.make
System/Library/Makefiles/messages.make
System/Library/Makefiles/mkinstalldirs
System/Library/Makefiles/names.make
-%%GNUSTEP_DEVEL%%System/Library/Makefiles/native-library.make
+System/Library/Makefiles/native-library.make
System/Library/Makefiles/objc.make
System/Library/Makefiles/os.sh
System/Library/Makefiles/palette.make
@@ -101,7 +102,8 @@ System/Library/Makefiles/service.make
System/Library/Makefiles/spec-debug-alone-rules.template
System/Library/Makefiles/spec-debug-rules.template
System/Library/Makefiles/spec-rules.template
-%%GNUSTEP_DEVEL%%System/Library/Makefiles/strip_makefiles.sh
+System/Library/Makefiles/strip_makefiles.sh
+%%GNUSTEP_STABLE%%System/Library/Makefiles/tar-exclude-list
System/Library/Makefiles/subproject.make
System/Library/Makefiles/target.make
System/Library/Makefiles/test-application.make
@@ -153,11 +155,9 @@ System/share/config.site
@dirrm System/Library
@dirrm System/Applications
@dirrm System
-%%GNUSTEP_STABLE%%@dirrm Network
@dirrm Local
@unexec rmdir %D
@exec mkdir -p %D/Local
-%%GNUSTEP_STABLE%%@exec mkdir -p %D/Network
@exec mkdir -p %D/System/Applications
@exec mkdir -p %D/System/Library/ApplicationSupport
@exec mkdir -p %D/System/Library/Bundles
diff --git a/devel/gnustep/Makefile b/devel/gnustep/Makefile
index 7733908b6a40..91f6aacf9739 100644
--- a/devel/gnustep/Makefile
+++ b/devel/gnustep/Makefile
@@ -9,7 +9,7 @@ PORTNAME= gnustep
.if defined(WITH_GNUSTEP_DEVEL)
PORTVERSION= 1.9.2
.else
-PORTVERSION= 1.8.0
+PORTVERSION= 1.10.0
.endif
CATEGORIES= devel lang
MASTER_SITES= # empty
diff --git a/lang/gnustep-base/Makefile b/lang/gnustep-base/Makefile
index 81b7b0528754..3ecca52f4ad3 100644
--- a/lang/gnustep-base/Makefile
+++ b/lang/gnustep-base/Makefile
@@ -9,8 +9,7 @@ PORTNAME= gnustep-base
.if defined(WITH_GNUSTEP_DEVEL)
PORTVERSION= 1.9.2
.else
-PORTVERSION= 1.8.0
-PORTREVISION= 2
+PORTVERSION= 1.10.0
.endif
CATEGORIES= lang devel
MASTER_SITES= ${MASTER_SITE_GNUSTEP}
@@ -20,11 +19,13 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep Foundation library
LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS+= xslt.2:${PORTSDIR}/textproc/libxslt
+LIB_DEPENDS+= gmp.6:${PORTSDIR}/math/libgmp4
PREFIX= ${LOCALBASE}/GNUstep
NO_MTREE= yes
ETCDIR= ${LOCALBASE}/etc
-USE_AUTOCONF_VER= 213
+USE_AUTOCONF_VER= 259
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-procfs
CONFIGURE_TARGET=
@@ -37,7 +38,7 @@ MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
CFLAGS+= -I${LOCALBASE}/include/libxml2/libxml
BREAKS_IF_PEDANTIC= yes
-PLIST_SUB+= MAJORVERSION=${PORTVERSION:C/([0-9]).*/\1/1}
+NO_FILTER_SHLIBS= yes
PLIST_SUB+= LOCALBASE=${LOCALBASE}
.if defined(WITHOUT_OPENSSL)
@@ -55,7 +56,10 @@ LIBS+= -lkvm
CONFIGURE_ENV+= LIBS="${LIBS}"
.endif
-.if !defined(WITH_GNUSTEP_DEVEL)
+.if defined(WITH_GNUSTEP_DEVEL)
+PLIST_SUB+= BASEVERSION=${PORTVERSION:C/([0-9]).*/\1/1}
+.else
+PLIST_SUB+= BASEVERSION=${PORTVERSION:C/[.][0-9]*$//1}
EXTRA_PATCHES+= ${FILESDIR}/NSFileManager.m.patch
.endif
@@ -64,13 +68,11 @@ EXTRA_PATCHES+= ${FILESDIR}/NSFileManager.m.patch
PATH:= ${PREFIX}/System/Tools:${PATH}
TARGLIB!= (cd ${PORTSDIR}/${GNUSTEP_OBJC_PORT} && make -V TARGLIB)
-.if defined(WITH_GNUSTEP_DEVEL)
post-build:
.for i in ${MAKE_APPS}
(cd ${WRKSRC}/${i}; . ${SYSMAKEDIR}/GNUstep.sh; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
.endfor
-.endif
post-extract:
@${SED} -e "s=%%PREFIX%%=${LOCALBASE}=" \
@@ -81,11 +83,14 @@ post-install:
-@${MKDIR} ${ETCDIR}/rc.d
${INSTALL_SCRIPT} ${WRKSRC}/GNUstep.sh ${ETCDIR}/rc.d/GNUstep.sh
${INSTALL_DATA} ${FILESDIR}/gdomap_if ${ETCDIR}
-.if defined(WITH_GNUSTEP_DEVEL)
.for i in ${INSTALL_APPS}
(cd ${WRKSRC}/${i}; . ${SYSMAKEDIR}/GNUstep.sh; \
${SETENV} ${MAKE_ENV} ${GMAKE} -d ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
.endfor
+.if !defined(WITH_GNUSTEP_DEVEL)
+ ${RM} ${PREFIX}/System/Library/Libraries/libgnustep-base.so
+ ${LN} -s libgnustep-base.so.${PORTVERSION} \
+ ${PREFIX}/System/Library/Libraries/libgnustep-base.so
.endif
test:
diff --git a/lang/gnustep-base/distinfo b/lang/gnustep-base/distinfo
index e393cc790355..93de19680f59 100644
--- a/lang/gnustep-base/distinfo
+++ b/lang/gnustep-base/distinfo
@@ -1,4 +1,4 @@
MD5 (gnustep-base-1.9.2.tar.gz) = b1fe102145f32aa05ebff41ffd7b9fd0
SIZE (gnustep-base-1.9.2.tar.gz) = 1735363
-MD5 (gnustep-base-1.8.0.tar.gz) = 3ce14c1f8384d3e3837f28e6a5155bc9
-SIZE (gnustep-base-1.8.0.tar.gz) = 1629498
+MD5 (gnustep-base-1.10.0.tar.gz) = a948608044062a8ce6fae230144f5519
+SIZE (gnustep-base-1.10.0.tar.gz) = 1879307
diff --git a/lang/gnustep-base/files/NSFileManager.m.patch b/lang/gnustep-base/files/NSFileManager.m.patch
index 1325f4466629..d787ef095dae 100644
--- a/lang/gnustep-base/files/NSFileManager.m.patch
+++ b/lang/gnustep-base/files/NSFileManager.m.patch
@@ -1,19 +1,27 @@
---- Source/NSFileManager.m.orig Thu Oct 9 11:31:35 2003
-+++ Source/NSFileManager.m Sat Apr 24 07:39:43 2004
-@@ -589,6 +589,12 @@
- int len, cur;
+--- Source/NSFileManager.m.orig Sat Jul 10 05:19:56 2004
++++ Source/NSFileManager.m Tue Sep 14 16:56:38 2004
+@@ -567,6 +567,12 @@
NSDictionary *needChown = nil;
-
+ #endif
+
+ if (path == nil) // don't try to do anything when path is nil
+ {
+ ASSIGN(_lastError, @"Could not create directory - name is nil");
+ return NO;
+ }
+
+ /* This is consitent with MacOSX - just return NO for an invalid path. */
+ if ([path length] == 0)
+ return NO;
+@@ -599,7 +605,6 @@
+ }
+
+ #else
+-
/*
* If there is no file owner specified, and we are running setuid to
* root, then we assume we need to change ownership to correct user.
-@@ -682,6 +688,12 @@
+@@ -693,6 +698,12 @@
while (cur < len);
#endif /* !MINGW */
diff --git a/lang/gnustep-base/pkg-plist b/lang/gnustep-base/pkg-plist
index b7b57496faaa..e301d3762cc0 100644
--- a/lang/gnustep-base/pkg-plist
+++ b/lang/gnustep-base/pkg-plist
@@ -5,17 +5,15 @@ System/Library/DTDs/gsdoc-0_6_5.dtd
System/Library/DTDs/gsdoc-0_6_6.dtd
System/Library/DTDs/gsdoc-0_6_7.dtd
System/Library/DTDs/gsdoc-1_0_0.dtd
-%%GNUSTEP_DEVEL%%System/Library/DTDs/gsdoc-1_0_1.dtd
+System/Library/DTDs/gsdoc-1_0_1.dtd
System/Library/DTDs/plist-0_9.dtd
-%%GNUSTEP_STABLE%%System/Library/DocTemplates/AutoDocTemplate.gsdoc
-%%GNUSTEP_STABLE%%System/Library/DocTemplates/indextemplate.gsdoc
-%%GNUSTEP_DEVEL%%System/Library/Documentation/man/man1/autogsdoc.1.gz
-%%GNUSTEP_DEVEL%%System/Library/Documentation/man/man1/cvtenc.1.gz
-%%GNUSTEP_DEVEL%%System/Library/Documentation/man/man1/defaults.1.gz
+System/Library/Documentation/man/man1/autogsdoc.1.gz
+System/Library/Documentation/man/man1/cvtenc.1.gz
+System/Library/Documentation/man/man1/defaults.1.gz
System/Library/Documentation/man/man1/gdnc.1.gz
-%%GNUSTEP_DEVEL%%System/Library/Documentation/man/man1/pldes.1.gz
-%%GNUSTEP_DEVEL%%System/Library/Documentation/man/man1/sfparse.1.gz
-%%GNUSTEP_DEVEL%%System/Library/Documentation/man/man1/xmlparse.1.gz
+System/Library/Documentation/man/man1/pldes.1.gz
+System/Library/Documentation/man/man1/sfparse.1.gz
+System/Library/Documentation/man/man1/xmlparse.1.gz
System/Library/Documentation/man/man8/gdomap.8.gz
System/Library/Headers/Foundation/Foundation.h
System/Library/Headers/Foundation/GSMime.h
@@ -31,7 +29,6 @@ System/Library/Headers/Foundation/NSCalendarDate.h
System/Library/Headers/Foundation/NSCharacterSet.h
System/Library/Headers/Foundation/NSClassDescription.h
System/Library/Headers/Foundation/NSCoder.h
-%%GNUSTEP_STABLE%%System/Library/Headers/Foundation/NSConcreteNumber.h
System/Library/Headers/Foundation/NSConnection.h
System/Library/Headers/Foundation/NSData.h
System/Library/Headers/Foundation/NSDate.h
@@ -44,7 +41,7 @@ System/Library/Headers/Foundation/NSDistantObject.h
System/Library/Headers/Foundation/NSDistributedLock.h
System/Library/Headers/Foundation/NSDistributedNotificationCenter.h
System/Library/Headers/Foundation/NSEnumerator.h
-%%GNUSTEP_DEVEL%%System/Library/Headers/Foundation/NSError.h
+System/Library/Headers/Foundation/NSError.h
System/Library/Headers/Foundation/NSException.h
System/Library/Headers/Foundation/NSFileHandle.h
System/Library/Headers/Foundation/NSFileManager.h
@@ -52,10 +49,10 @@ System/Library/Headers/Foundation/NSFormatter.h
System/Library/Headers/Foundation/NSGeometry.h
System/Library/Headers/Foundation/NSHashTable.h
System/Library/Headers/Foundation/NSHost.h
-%%GNUSTEP_DEVEL%%System/Library/Headers/Foundation/NSIndexSet.h
+System/Library/Headers/Foundation/NSIndexSet.h
System/Library/Headers/Foundation/NSInvocation.h
System/Library/Headers/Foundation/NSKeyValueCoding.h
-%%GNUSTEP_DEVEL%%System/Library/Headers/Foundation/NSKeyedArchiver.h
+System/Library/Headers/Foundation/NSKeyedArchiver.h
System/Library/Headers/Foundation/NSLock.h
System/Library/Headers/Foundation/NSMapTable.h
System/Library/Headers/Foundation/NSMethodSignature.h
@@ -71,7 +68,7 @@ System/Library/Headers/Foundation/NSPortCoder.h
System/Library/Headers/Foundation/NSPortMessage.h
System/Library/Headers/Foundation/NSPortNameServer.h
System/Library/Headers/Foundation/NSProcessInfo.h
-%%GNUSTEP_DEVEL%%System/Library/Headers/Foundation/NSPropertyList.h
+System/Library/Headers/Foundation/NSPropertyList.h
System/Library/Headers/Foundation/NSProtocolChecker.h
System/Library/Headers/Foundation/NSProxy.h
System/Library/Headers/Foundation/NSRange.h
@@ -107,7 +104,7 @@ System/Library/Headers/GNUstepBase/GCObject.h
System/Library/Headers/GNUstepBase/GSMime.h
System/Library/Headers/GNUstepBase/GSXML.h
System/Library/Headers/GNUstepBase/GSLocale.h
-%%GNUSTEP_DEVEL%%System/Library/Headers/GNUstepBase/GSLock.h
+System/Library/Headers/GNUstepBase/GSLock.h
System/Library/Headers/GNUstepBase/Unicode.h
System/Library/Headers/GNUstepBase/GNUstep.h
System/Library/Headers/GNUstepBase/behavior.h
@@ -120,7 +117,7 @@ System/Library/Headers/gnustep/base/GSFileHandle.h
System/Library/Headers/gnustep/base/GSIArray.h
System/Library/Headers/gnustep/base/GSIMap.h
System/Library/Headers/gnustep/base/GSLocale.h
-%%GNUSTEP_DEVEL%%System/Library/Headers/gnustep/base/GSLock.h
+System/Library/Headers/gnustep/base/GSLock.h
System/Library/Headers/gnustep/base/GSMime.h
System/Library/Headers/gnustep/base/GSObjCRuntime.h
System/Library/Headers/gnustep/base/GSUnion.h
@@ -144,7 +141,7 @@ System/Library/Libraries/Resources/gnustep-base/Languages/Dutch
System/Library/Libraries/Resources/gnustep-base/Languages/English
System/Library/Libraries/Resources/gnustep-base/Languages/French
System/Library/Libraries/Resources/gnustep-base/Languages/German
-%%GNUSTEP_DEVEL%%System/Library/Libraries/Resources/gnustep-base/Languages/Hungarian
+System/Library/Libraries/Resources/gnustep-base/Languages/Hungarian
System/Library/Libraries/Resources/gnustep-base/Languages/Italian
System/Library/Libraries/Resources/gnustep-base/Languages/Locale.aliases
System/Library/Libraries/Resources/gnustep-base/Languages/Locale.encodings
@@ -233,6 +230,7 @@ System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Aragua
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Aruba
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Asuncion
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Atka
+%%GNUSTEP_STABLE%%System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Bahia
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Barbados
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Belem
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Belize
@@ -242,6 +240,7 @@ System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Boise
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Buenos_Aires
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Cambridge_Bay
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Cancun
+%%GNUSTEP_STABLE%%System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Campo_Grande
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Caracas
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Catamarca
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Cayenne
@@ -343,6 +342,7 @@ System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Teguci
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Thule
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Thunder_Bay
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Tijuana
+%%GNUSTEP_STABLE%%System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Toronto
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Tortola
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Vancouver
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/America/Virgin
@@ -356,6 +356,7 @@ System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/Antarctica/Dum
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/Antarctica/Mawson
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/Antarctica/McMurdo
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/Antarctica/Palmer
+%%GNUSTEP_STABLE%%System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/Antarctica/Rothera
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/Antarctica/South_Pole
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/Antarctica/Syowa
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/Antarctica/Vostok
@@ -738,7 +739,7 @@ System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/WET
System/Library/Libraries/Resources/gnustep-base/NSTimeZones/zones/Zulu
System/Library/Libraries/Resources/gnustep-base/TraditionalChinese.lproj/Localizable.strings
System/Library/Libraries/libgnustep-base.so
-System/Library/Libraries/libgnustep-base.so.%%MAJORVERSION%%
+System/Library/Libraries/libgnustep-base.so.%%BASEVERSION%%
System/Library/Libraries/libgnustep-base.so.%%VERSION%%
System/Makefiles/Additional/base.make
System/Tools/autogsdoc