aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjwb <jwb@FreeBSD.org>2019-09-22 23:54:33 +0800
committerjwb <jwb@FreeBSD.org>2019-09-22 23:54:33 +0800
commit4cffcb6f6385eed5747d9eac32d7dcaf2578d772 (patch)
tree516f47b9c3bd7162eab19c5b10075ba4b7ca966e
parent79f0b18072b0b20a7723e86b89aae3f1369c1202 (diff)
downloadfreebsd-ports-gnome-4cffcb6f6385eed5747d9eac32d7dcaf2578d772.tar.gz
freebsd-ports-gnome-4cffcb6f6385eed5747d9eac32d7dcaf2578d772.tar.zst
freebsd-ports-gnome-4cffcb6f6385eed5747d9eac32d7dcaf2578d772.zip
graphics/py-spectra: Color scales and color conversion made easy for Python
Spectra is a Python library that makes color math, color scales, and color-space conversion easy. Support for: Color scales Color ranges Color blending Brightening/darkening colors Saturating/desaturating colors Conversion to/from multiple color spaces Spectra is built on colormath and grapefruit. Spectra is enormously inspired by chroma.js and d3's scales.
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-spectra/Makefile25
-rw-r--r--graphics/py-spectra/distinfo3
-rw-r--r--graphics/py-spectra/pkg-descr16
4 files changed, 45 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 012a0489fa78..c502443f93ff 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -897,6 +897,7 @@
SUBDIR += py-seqdiag
SUBDIR += py-sorl-thumbnail
SUBDIR += py-soya3d
+ SUBDIR += py-spectra
SUBDIR += py-stltools
SUBDIR += py-svgwrite
SUBDIR += py-termtosvg
diff --git a/graphics/py-spectra/Makefile b/graphics/py-spectra/Makefile
new file mode 100644
index 000000000000..f95d3ffee9e8
--- /dev/null
+++ b/graphics/py-spectra/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= spectra
+DISTVERSION= 0.0.11
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Color scales and color conversion made easy for Python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m nose -v test
+
+.include <bsd.port.mk>
diff --git a/graphics/py-spectra/distinfo b/graphics/py-spectra/distinfo
new file mode 100644
index 000000000000..834bf1e38874
--- /dev/null
+++ b/graphics/py-spectra/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1569116785
+SHA256 (spectra-0.0.11.tar.gz) = 8eb362a5187cb63cee13cd01186799c0c791a3ad3bec57b279132e12521762b8
+SIZE (spectra-0.0.11.tar.gz) = 18819
diff --git a/graphics/py-spectra/pkg-descr b/graphics/py-spectra/pkg-descr
new file mode 100644
index 000000000000..1a5a86d753e6
--- /dev/null
+++ b/graphics/py-spectra/pkg-descr
@@ -0,0 +1,16 @@
+Spectra is a Python library that makes color math, color scales, and
+color-space conversion easy.
+
+Support for:
+
+ Color scales
+ Color ranges
+ Color blending
+ Brightening/darkening colors
+ Saturating/desaturating colors
+ Conversion to/from multiple color spaces
+
+Spectra is built on colormath and grapefruit. Spectra is enormously inspired by
+chroma.js and d3's scales.
+
+WWW: https://pypi.python.org/pypi/spectra