aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-17 06:31:01 +0800
committerpav <pav@FreeBSD.org>2005-09-17 06:31:01 +0800
commit4d38583c41dd96b8d2527a8ec7a2e1f8489e594a (patch)
tree2a8aa64cace51299dd978060c81e513308807393
parent8d3a37de5f58771ed141adef995d9ff998e428f2 (diff)
downloadfreebsd-ports-gnome-4d38583c41dd96b8d2527a8ec7a2e1f8489e594a.tar.gz
freebsd-ports-gnome-4d38583c41dd96b8d2527a8ec7a2e1f8489e594a.tar.zst
freebsd-ports-gnome-4d38583c41dd96b8d2527a8ec7a2e1f8489e594a.zip
PHP - Replace, rename, and remove user defined functions and classes.
Define customized superglobal variables for general purpose use. Execute code in restricted environment (sandboxing). PR: ports/84545 Submitted by: Elias Mandouvalos <ocean@mail.gr>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pecl-runkit/Makefile26
-rw-r--r--devel/pecl-runkit/distinfo2
-rw-r--r--devel/pecl-runkit/files/patch-config.m418
-rw-r--r--devel/pecl-runkit/pkg-descr5
5 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c54fb1616af0..d23cddfde2ff 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1249,6 +1249,7 @@
SUBDIR += pear-XML_Util
SUBDIR += pear-XML_XPath
SUBDIR += pear-apd
+ SUBDIR += pecl-runkit
SUBDIR += pecl-statgrab
SUBDIR += pedisassem
SUBDIR += perforce
diff --git a/devel/pecl-runkit/Makefile b/devel/pecl-runkit/Makefile
new file mode 100644
index 000000000000..05105483f36d
--- /dev/null
+++ b/devel/pecl-runkit/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pecl-runkit
+# Date created: 4 Aug 2005
+# Whom: Elias Mandouvalos <ocean@mail.gr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= runkit
+PORTVERSION= 0.4
+CATEGORIES= devel pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+DISTNAME= runkit-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= pav@FreeBSD.org
+COMMENT= PECL extension to modify constants, user-defined functions and classes
+
+USE_PHP= yes
+USE_PHPEXT= yes
+PHP_MODNAME= runkit
+
+CONFIGURE_ARGS= --enable-runkit=classkit
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-runkit/distinfo b/devel/pecl-runkit/distinfo
new file mode 100644
index 000000000000..cc29ffa605a6
--- /dev/null
+++ b/devel/pecl-runkit/distinfo
@@ -0,0 +1,2 @@
+MD5 (PECL/runkit-0.4.tgz) = 05a690f04b7d2c42193f3e0c1bb99a19
+SIZE (PECL/runkit-0.4.tgz) = 30802
diff --git a/devel/pecl-runkit/files/patch-config.m4 b/devel/pecl-runkit/files/patch-config.m4
new file mode 100644
index 000000000000..11c2bedfa271
--- /dev/null
+++ b/devel/pecl-runkit/files/patch-config.m4
@@ -0,0 +1,18 @@
+--- config.m4:1.1 Fri Apr 29 19:54:33 2005
++++ config.m4 Sat Jul 16 12:46:31 2005
+@@ -1,4 +1,4 @@
+-dnl $Id: config.m4,v 1.1 2005/04/29 23:54:33 pollita Exp $
++dnl $Id: config.m4,v 1.2 2005/07/16 16:46:31 pollita Exp $
+ dnl config.m4 for extension runkit
+
+ PHP_ARG_ENABLE(runkit, whether to enable runkit support,
+@@ -8,8 +8,5 @@
+ if test "$PHP_RUNKIT" = "classkit"; then
+ AC_DEFINE(PHP_RUNKIT_CLASSKIT_COMPAT, 1, [Whether to export classkit compatable function aliases])
+ fi
+- PHP_ADD_LIBRARY(dl,,RUNKIT_SHARED_LIBADD)
+- PHP_SUBST(RUNKIT_SHARED_LIBADD)
+-
+ PHP_NEW_EXTENSION(runkit, runkit.c runkit_functions.c runkit_methods.c runkit_constants.c runkit_import.c runkit_classes.c runkit_sandbox.c, $ext_shared)
+ fi
+
diff --git a/devel/pecl-runkit/pkg-descr b/devel/pecl-runkit/pkg-descr
new file mode 100644
index 000000000000..4989d66e620d
--- /dev/null
+++ b/devel/pecl-runkit/pkg-descr
@@ -0,0 +1,5 @@
+The runkit extension provides means to modify constants, user-defined
+functions, and user-defined classes. It also provides for custom superglobal
+variables and embeddable sub-interpreters via sandboxing.
+
+WWW: http://pecl.php.net/package/runkit