aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-07-28 07:15:02 +0800
committerale <ale@FreeBSD.org>2004-07-28 07:15:02 +0800
commit4da3811a7ea92092ce6b537d6816c97ec9d651fe (patch)
tree760d30a943a241ff8793fda4cb61c09adc003a74
parent8e7826e34ec3a92d9dbecdc6af31a52dfef507fe (diff)
downloadfreebsd-ports-gnome-4da3811a7ea92092ce6b537d6816c97ec9d651fe.tar.gz
freebsd-ports-gnome-4da3811a7ea92092ce6b537d6816c97ec9d651fe.tar.zst
freebsd-ports-gnome-4da3811a7ea92092ce6b537d6816c97ec9d651fe.zip
MFphp4: Fix compilation of wddx extension.
-rw-r--r--lang/php5/Makefile.ext5
-rw-r--r--lang/php53/Makefile.ext5
-rw-r--r--textproc/php4-wddx/files/patch-config.m44
-rw-r--r--textproc/php5-wddx/files/patch-config.m422
-rw-r--r--textproc/php5-wddx/files/patch-wddx.c13
5 files changed, 45 insertions, 4 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index fe3dde6eb774..5419bf56ef40 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -351,7 +351,10 @@ CONFIGURE_ARGS+=--enable-tokenizer
.endif
.if ${PHP_MODNAME} == "wddx"
-CONFIGURE_ARGS+=--enable-wddx
+CONFIGURE_ARGS+=--enable-wddx \
+ --with-libxml-dir=${LOCALBASE}
+
+USE_GNOME= libxml2
USE_PHP= xml session
USE_PHP_BUILD= yes
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index fe3dde6eb774..5419bf56ef40 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -351,7 +351,10 @@ CONFIGURE_ARGS+=--enable-tokenizer
.endif
.if ${PHP_MODNAME} == "wddx"
-CONFIGURE_ARGS+=--enable-wddx
+CONFIGURE_ARGS+=--enable-wddx \
+ --with-libxml-dir=${LOCALBASE}
+
+USE_GNOME= libxml2
USE_PHP= xml session
USE_PHP_BUILD= yes
diff --git a/textproc/php4-wddx/files/patch-config.m4 b/textproc/php4-wddx/files/patch-config.m4
index f8db4af29bfc..9ac5a80e27b4 100644
--- a/textproc/php4-wddx/files/patch-config.m4
+++ b/textproc/php4-wddx/files/patch-config.m4
@@ -26,6 +26,6 @@
+ fi
+
+ PHP_ADD_INCLUDE($EXPAT_DIR/include)
-+ PHP_ADD_LIBRARY_WITH_PATH(expat, $EXPAT_DIR/lib, XML_SHARED_LIBADD)
-+ PHP_SUBST(XML_SHARED_LIBADD)
++ PHP_ADD_LIBRARY_WITH_PATH(expat, $EXPAT_DIR/lib, WDDX_SHARED_LIBADD)
++ PHP_SUBST(WDDX_SHARED_LIBADD)
fi
diff --git a/textproc/php5-wddx/files/patch-config.m4 b/textproc/php5-wddx/files/patch-config.m4
new file mode 100644
index 000000000000..08787003b8f9
--- /dev/null
+++ b/textproc/php5-wddx/files/patch-config.m4
@@ -0,0 +1,22 @@
+--- config.m4.orig Mon Jul 26 09:05:10 2004
++++ config.m4 Mon Jul 26 09:07:46 2004
+@@ -5,6 +5,9 @@
+ PHP_ARG_ENABLE(wddx,whether to enable WDDX support,
+ [ --enable-wddx Enable WDDX support.])
+
++PHP_ARG_WITH(libxml-dir, libxml2 install dir,
++[ --with-libxml-dir=<DIR> WDDX: libxml2 install prefix], no, no)
++
+ if test "$PHP_WDDX" != "no"; then
+ if test "$ext_shared" != "yes" && test "$enable_xml" = "no"; then
+ AC_MSG_WARN(Activating XML)
+@@ -12,4 +15,9 @@
+ fi
+ AC_DEFINE(HAVE_WDDX, 1, [ ])
+ PHP_NEW_EXTENSION(wddx, wddx.c, $ext_shared)
++
++ PHP_SETUP_LIBXML(WDDX_SHARED_LIBADD, [
++ ], [
++ AC_MSG_ERROR([xml2-config not found. Please check your libxml2 installation.])
++ ])
+ fi
diff --git a/textproc/php5-wddx/files/patch-wddx.c b/textproc/php5-wddx/files/patch-wddx.c
new file mode 100644
index 000000000000..0a26af4abf7c
--- /dev/null
+++ b/textproc/php5-wddx/files/patch-wddx.c
@@ -0,0 +1,13 @@
+--- wddx.c.orig Mon Jul 26 08:56:21 2004
++++ wddx.c Mon Jul 26 08:56:40 2004
+@@ -18,6 +18,10 @@
+
+ /* $Id: wddx.c,v 1.96.2.5.2.1 2004/07/13 13:15:30 iliaa Exp $ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include "php.h"
+ #include "php_wddx.h"
+