aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-01 01:11:32 +0800
committerantoine <antoine@FreeBSD.org>2014-02-01 01:11:32 +0800
commit4dcfe4ae4c386dbe24f668e734e51fffcfda99ae (patch)
tree0a134fc370d69e60eaaee41a0fa686422afe0950
parent19d1589bf7245b42ca253677b87e1d786d0b843b (diff)
downloadfreebsd-ports-gnome-4dcfe4ae4c386dbe24f668e734e51fffcfda99ae.tar.gz
freebsd-ports-gnome-4dcfe4ae4c386dbe24f668e734e51fffcfda99ae.tar.zst
freebsd-ports-gnome-4dcfe4ae4c386dbe24f668e734e51fffcfda99ae.zip
Stage support
-rw-r--r--net/tcptrace/Makefile23
1 files changed, 8 insertions, 15 deletions
diff --git a/net/tcptrace/Makefile b/net/tcptrace/Makefile
index 036fd38edd83..77ae24570a83 100644
--- a/net/tcptrace/Makefile
+++ b/net/tcptrace/Makefile
@@ -15,27 +15,20 @@ GNU_CONFIGURE= yes
ALL_TARGET= tcptrace
PLIST_FILES= bin/${PORTNAME} \
- bin/xpl2gpl
-
-MAN1= tcptrace.1
+ bin/xpl2gpl \
+ man/man1/tcptrace.1.gz
PORTDOCS= ARGS CHANGES FAQ README README.mailing_list \
README.modules README.tline_graphs README.tput_graphs \
README.version README.xpl2gpl THANKS dot_tcptracerc
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/tcptrace ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/xpl2gpl ${PREFIX}/bin
-
-post-install:
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man ${MAN1PREFIX}/man/man1/${PORTNAME}.1
-
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcptrace ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/xpl2gpl ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man ${STAGEDIR}${MAN1PREFIX}/man/man1/${PORTNAME}.1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>