aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-04-26 01:00:05 +0800
committermakc <makc@FreeBSD.org>2009-04-26 01:00:05 +0800
commit4e26edbe7c8efc55078eaf7e43e715bcdf98413a (patch)
treeee8b2c75686a43da4c7c89482ea4039616328945
parent1af96c8c2c6b78b8f40edf1d06e5f4b250e412b8 (diff)
downloadfreebsd-ports-gnome-4e26edbe7c8efc55078eaf7e43e715bcdf98413a.tar.gz
freebsd-ports-gnome-4e26edbe7c8efc55078eaf7e43e715bcdf98413a.tar.zst
freebsd-ports-gnome-4e26edbe7c8efc55078eaf7e43e715bcdf98413a.zip
Minor cleanups,
Mark MAKE_JOBS_SAFE.
-rw-r--r--editors/calligra/Makefile23
-rw-r--r--editors/koffice-kde3/Makefile23
-rw-r--r--editors/koffice-kde4/Makefile23
3 files changed, 33 insertions, 36 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index e9a8740625c4..a3657715ecda 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -18,24 +18,21 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Office Suite for KDE3
BUILD_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
-LIB_DEPENDS= GraphicsMagick++:${PORTSDIR}/graphics/GraphicsMagick \
+LIB_DEPENDS= GraphicsMagick++.1:${PORTSDIR}/graphics/GraphicsMagick \
art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl \
- aspell:${PORTSDIR}/textproc/aspell \
+ aspell.16:${PORTSDIR}/textproc/aspell \
exif.12:${PORTSDIR}/graphics/libexif \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- freetype:${PORTSDIR}/print/freetype2 \
- lcms:${PORTSDIR}/graphics/lcms \
- paper:${PORTSDIR}/print/libpaper \
- poppler-qt:${PORTSDIR}/graphics/poppler-qt \
- wpd-0.8:${PORTSDIR}/textproc/libwpd \
- wv2:${PORTSDIR}/textproc/wv2 \
- xml2:${PORTSDIR}/textproc/libxml2 \
- xslt:${PORTSDIR}/textproc/libxslt
+ fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ lcms.1:${PORTSDIR}/graphics/lcms \
+ paper.2:${PORTSDIR}/print/libpaper \
+ poppler-qt.2:${PORTSDIR}/graphics/poppler-qt \
+ wpd-0.8.8:${PORTSDIR}/textproc/libwpd \
+ wv2.1:${PORTSDIR}/textproc/wv2
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
-PREFIX= ${KDE_PREFIX}
USE_BZIP2= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
@@ -43,6 +40,8 @@ USE_MYSQL= yes
USE_PYTHON= yes
USE_RUBY= yes
USE_PGSQL= yes
+USE_GNOME= libxml2 libxslt
+MAKE_JOBS_SAFE= yes
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
diff --git a/editors/koffice-kde3/Makefile b/editors/koffice-kde3/Makefile
index e9a8740625c4..a3657715ecda 100644
--- a/editors/koffice-kde3/Makefile
+++ b/editors/koffice-kde3/Makefile
@@ -18,24 +18,21 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Office Suite for KDE3
BUILD_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
-LIB_DEPENDS= GraphicsMagick++:${PORTSDIR}/graphics/GraphicsMagick \
+LIB_DEPENDS= GraphicsMagick++.1:${PORTSDIR}/graphics/GraphicsMagick \
art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl \
- aspell:${PORTSDIR}/textproc/aspell \
+ aspell.16:${PORTSDIR}/textproc/aspell \
exif.12:${PORTSDIR}/graphics/libexif \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- freetype:${PORTSDIR}/print/freetype2 \
- lcms:${PORTSDIR}/graphics/lcms \
- paper:${PORTSDIR}/print/libpaper \
- poppler-qt:${PORTSDIR}/graphics/poppler-qt \
- wpd-0.8:${PORTSDIR}/textproc/libwpd \
- wv2:${PORTSDIR}/textproc/wv2 \
- xml2:${PORTSDIR}/textproc/libxml2 \
- xslt:${PORTSDIR}/textproc/libxslt
+ fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ lcms.1:${PORTSDIR}/graphics/lcms \
+ paper.2:${PORTSDIR}/print/libpaper \
+ poppler-qt.2:${PORTSDIR}/graphics/poppler-qt \
+ wpd-0.8.8:${PORTSDIR}/textproc/libwpd \
+ wv2.1:${PORTSDIR}/textproc/wv2
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
-PREFIX= ${KDE_PREFIX}
USE_BZIP2= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
@@ -43,6 +40,8 @@ USE_MYSQL= yes
USE_PYTHON= yes
USE_RUBY= yes
USE_PGSQL= yes
+USE_GNOME= libxml2 libxslt
+MAKE_JOBS_SAFE= yes
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
diff --git a/editors/koffice-kde4/Makefile b/editors/koffice-kde4/Makefile
index e9a8740625c4..a3657715ecda 100644
--- a/editors/koffice-kde4/Makefile
+++ b/editors/koffice-kde4/Makefile
@@ -18,24 +18,21 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Office Suite for KDE3
BUILD_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
-LIB_DEPENDS= GraphicsMagick++:${PORTSDIR}/graphics/GraphicsMagick \
+LIB_DEPENDS= GraphicsMagick++.1:${PORTSDIR}/graphics/GraphicsMagick \
art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl \
- aspell:${PORTSDIR}/textproc/aspell \
+ aspell.16:${PORTSDIR}/textproc/aspell \
exif.12:${PORTSDIR}/graphics/libexif \
- fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
- freetype:${PORTSDIR}/print/freetype2 \
- lcms:${PORTSDIR}/graphics/lcms \
- paper:${PORTSDIR}/print/libpaper \
- poppler-qt:${PORTSDIR}/graphics/poppler-qt \
- wpd-0.8:${PORTSDIR}/textproc/libwpd \
- wv2:${PORTSDIR}/textproc/wv2 \
- xml2:${PORTSDIR}/textproc/libxml2 \
- xslt:${PORTSDIR}/textproc/libxslt
+ fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ lcms.1:${PORTSDIR}/graphics/lcms \
+ paper.2:${PORTSDIR}/print/libpaper \
+ poppler-qt.2:${PORTSDIR}/graphics/poppler-qt \
+ wpd-0.8.8:${PORTSDIR}/textproc/libwpd \
+ wv2.1:${PORTSDIR}/textproc/wv2
RUN_DEPENDS= ${LOCALBASE}/lib/libpqxx.a:${PORTSDIR}/databases/postgresql-libpqxx
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
-PREFIX= ${KDE_PREFIX}
USE_BZIP2= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
@@ -43,6 +40,8 @@ USE_MYSQL= yes
USE_PYTHON= yes
USE_RUBY= yes
USE_PGSQL= yes
+USE_GNOME= libxml2 libxslt
+MAKE_JOBS_SAFE= yes
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"