aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-07-28 06:58:47 +0800
committermarcus <marcus@FreeBSD.org>2002-07-28 06:58:47 +0800
commit4ef0ee5c0742eddefe891581a58a37d2093b25fe (patch)
tree28cff2b1d792edad830bb22e9bd547944f597175
parent54d689c11eb53fb4345d740e2af0f88a10217537 (diff)
downloadfreebsd-ports-gnome-4ef0ee5c0742eddefe891581a58a37d2093b25fe.tar.gz
freebsd-ports-gnome-4ef0ee5c0742eddefe891581a58a37d2093b25fe.tar.zst
freebsd-ports-gnome-4ef0ee5c0742eddefe891581a58a37d2093b25fe.zip
Use USE_GNOMENG.
-rw-r--r--archivers/file-roller/Makefile10
-rw-r--r--archivers/fileroller/Makefile10
-rw-r--r--audio/gdcd/Makefile3
-rw-r--r--audio/gdrdao/Makefile3
-rw-r--r--deskutils/genius/Makefile8
-rw-r--r--devel/anjuta-devel/Makefile10
-rw-r--r--devel/anjuta/Makefile10
7 files changed, 17 insertions, 37 deletions
diff --git a/archivers/file-roller/Makefile b/archivers/file-roller/Makefile
index 835ed39c1357..e9757dfb6e1c 100644
--- a/archivers/file-roller/Makefile
+++ b/archivers/file-roller/Makefile
@@ -20,19 +20,13 @@ RUN_DEPENDS= bzip:${PORTSDIR}/archivers/bzip \
rar:${PORTSDIR}/archivers/rar \
lzop:${PORTSDIR}/archivers/lzop
-USE_REINPLACE= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack libglade gnomevfs bonobo
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|\$$\(datadir\)/gnome/apps|\$$\(datadir\)/apps|g ; \
- s|\$$\(datadir\)/gnome/help|\$$\(datadir\)/help|g ; \
- s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/archivers/fileroller/Makefile b/archivers/fileroller/Makefile
index 835ed39c1357..e9757dfb6e1c 100644
--- a/archivers/fileroller/Makefile
+++ b/archivers/fileroller/Makefile
@@ -20,19 +20,13 @@ RUN_DEPENDS= bzip:${PORTSDIR}/archivers/bzip \
rar:${PORTSDIR}/archivers/rar \
lzop:${PORTSDIR}/archivers/lzop
-USE_REINPLACE= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack libglade gnomevfs bonobo
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|\$$\(datadir\)/gnome/apps|\$$\(datadir\)/apps|g ; \
- s|\$$\(datadir\)/gnome/help|\$$\(datadir\)/help|g ; \
- s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/audio/gdcd/Makefile b/audio/gdcd/Makefile
index b42ad51b77af..564998280ea9 100644
--- a/audio/gdcd/Makefile
+++ b/audio/gdcd/Makefile
@@ -16,7 +16,8 @@ LIB_DEPENDS= cdaudio.1:${PORTSDIR}/audio/libcdaudio
USE_REINPLACE= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomelibs gdkpixbuf
USE_AUTOMAKE_VER= 15
AUTOMAKE_ARGS= -a -i
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/audio/gdrdao/Makefile b/audio/gdrdao/Makefile
index f459f305c60f..6848d9486580 100644
--- a/audio/gdrdao/Makefile
+++ b/audio/gdrdao/Makefile
@@ -14,7 +14,8 @@ MAINTAINER= ports@FreeBSD.org
RUN_DEPENDS= cdrdao:${PORTSDIR}/audio/cdrdao
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomelibs
GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/deskutils/genius/Makefile b/deskutils/genius/Makefile
index 14ca8c55ea76..b69a4ae04ebb 100644
--- a/deskutils/genius/Makefile
+++ b/deskutils/genius/Makefile
@@ -15,16 +15,14 @@ MAINTAINER= ports@FreeBSD.org
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
- 's|\$$(datadir)/gnome/|\$$(datadir)/|g ; \
- s|\$$(datadir)/locale|\$$(prefix)/share/locale|g'
.include <bsd.port.mk>
diff --git a/devel/anjuta-devel/Makefile b/devel/anjuta-devel/Makefile
index 9339b0e72fc8..3b1421ed1f1f 100644
--- a/devel/anjuta-devel/Makefile
+++ b/devel/anjuta-devel/Makefile
@@ -13,23 +13,19 @@ MASTER_SITE_SUBDIR= anjuta
MAINTAINER= gnome@FreeBSD.org
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= scintilla.1:${PORTSDIR}/x11-toolkits/scintilla
-RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs gnomevfs
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's#-lpthread#${PTHREAD_LIBS}#g ; \
s#DATADIRNAME=lib#DATADIRNAME=share#g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index 9339b0e72fc8..3b1421ed1f1f 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -13,23 +13,19 @@ MASTER_SITE_SUBDIR= anjuta
MAINTAINER= gnome@FreeBSD.org
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
LIB_DEPENDS= scintilla.1:${PORTSDIR}/x11-toolkits/scintilla
-RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs gnomevfs
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's#-lpthread#${PTHREAD_LIBS}#g ; \
s#DATADIRNAME=lib#DATADIRNAME=share#g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g'
.include <bsd.port.mk>