aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-11-27 00:21:44 +0800
committerpav <pav@FreeBSD.org>2006-11-27 00:21:44 +0800
commit4ef135a694f2c6cc682bdcdb518eb636440ba3d3 (patch)
treee2e5b1a08ec3ffc847446b762fee3c5cce07a928
parentcf10f81d6f1fb74678df51a0fd0204f41d4d9be8 (diff)
downloadfreebsd-ports-gnome-4ef135a694f2c6cc682bdcdb518eb636440ba3d3.tar.gz
freebsd-ports-gnome-4ef135a694f2c6cc682bdcdb518eb636440ba3d3.tar.zst
freebsd-ports-gnome-4ef135a694f2c6cc682bdcdb518eb636440ba3d3.zip
- Improve handling of C*FLAGS
Submitted by: mi (adapted from)
-rw-r--r--net/boinc-client/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index d0b62ac2de20..bbea8841ed2e 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -32,7 +32,10 @@ SUB_LIST= BOINC_HOME="${BOINC_HOME}" BOINC_USER="${BOINC_USER}" BOINC_GROUP="${B
USE_RC_SUBR= boinc.sh
CONFIGURE_ARGS= --disable-server
-CONFIGURE_ENV= CPPFLAGS=-I${X11BASE}/include CXXFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include -O3" CFLAGS="${CFLAGS} -O3"
+CPPFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS:= ${CXXFLAGS:N-O*:N-f*} -O3
+CFLAGS:= ${CFLAGS:N-O*:N-f*} -O3
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" CXXFLAGSS="${CXXFLAGS}" CFLAGS="${CFLAGS}"
OPTIONS= X11 "Build Boinc Manager GUI" on
@@ -40,6 +43,7 @@ OPTIONS= X11 "Build Boinc Manager GUI" on
.if !defined(WITHOUT_X11)
CONFIGURE_ARGS+= --with-wx-config=wxgtk2-2.6-config
+CPPFLAGS+= -I${X11BASE}/include
.else
CONFIGURE_ARGS+= --with-wx-config=false
.endif