aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2019-08-29 21:29:51 +0800
committerbapt <bapt@FreeBSD.org>2019-08-29 21:29:51 +0800
commit4f2effd19258893a24682ba007c929a73e4bd409 (patch)
treeae923b9038baa99120bd31e6bd3c9035ef24d51b
parent4ed48b579de9fa422a5d3f70fc3c243d4b1a6068 (diff)
downloadfreebsd-ports-gnome-4f2effd19258893a24682ba007c929a73e4bd409.tar.gz
freebsd-ports-gnome-4f2effd19258893a24682ba007c929a73e4bd409.tar.zst
freebsd-ports-gnome-4f2effd19258893a24682ba007c929a73e4bd409.zip
Update to 2.13
-rw-r--r--x11/i3status/Makefile22
-rw-r--r--x11/i3status/distinfo6
-rw-r--r--x11/i3status/files/no-pulseaudio.diff25
-rw-r--r--x11/i3status/files/patch-src_print__volume.c11
-rw-r--r--x11/i3status/files/patch-src_pulse.c12
5 files changed, 36 insertions, 40 deletions
diff --git a/x11/i3status/Makefile b/x11/i3status/Makefile
index 68aeae4b8989..4ab12df5bc44 100644
--- a/x11/i3status/Makefile
+++ b/x11/i3status/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= i3status
-PORTVERSION= 2.12
+PORTVERSION= 2.13
CATEGORIES= x11
MASTER_SITES= http://i3wm.org/i3status/
@@ -10,25 +10,23 @@ COMMENT= Small program for generating a status bar
LICENSE= BSD3CLAUSE
-OPTIONS_DEFINE= PULSEAUDIO
-
LIB_DEPENDS= libconfuse.so:devel/libconfuse \
libyajl.so:devel/yajl
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-USES= gmake tar:bzip2
-
-PULSEAUDIO_EXTRA_PATCHES_OFF= ${FILESDIR}/no-pulseaudio.diff
-PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= ac_cv_path_PATH_ASCIIDOC=${TRUE} \
+ ac_cv_path_PATH_XMLTO=${TRUE} \
+ --disable-dependency-tracking
+USES= gmake pkgconfig tar:bzip2
+BUILD_WRKSRC= ${WRKSRC}/${CONFIGURE_TARGET}
+INSTALL_WRKSRC= ${WRKSRC}/${CONFIGURE_TARGET}
post-patch:
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' ${WRKSRC}/i3status.c
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/i3status ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man/i3status.1 ${STAGEDIR}${MANPREFIX}/man/man1
+post-install:
${INSTALL_DATA} ${WRKSRC}/i3status.conf \
${STAGEDIR}${PREFIX}/etc/i3status.conf.sample
+
.include <bsd.port.mk>
diff --git a/x11/i3status/distinfo b/x11/i3status/distinfo
index e3fad5a319c0..d2151d833382 100644
--- a/x11/i3status/distinfo
+++ b/x11/i3status/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1526289145
-SHA256 (i3status-2.12.tar.bz2) = 6fc6881536043391ab4bed369d956f99d1088965d8bcebed18d1932de3ba791a
-SIZE (i3status-2.12.tar.bz2) = 57162
+TIMESTAMP = 1564643344
+SHA256 (i3status-2.13.tar.bz2) = ce89c9ff8565f62e88299f1a611229afdfc356b4e97368a5f8c4f06ad2fa1466
+SIZE (i3status-2.13.tar.bz2) = 201409
diff --git a/x11/i3status/files/no-pulseaudio.diff b/x11/i3status/files/no-pulseaudio.diff
deleted file mode 100644
index 232ea05ba8df..000000000000
--- a/x11/i3status/files/no-pulseaudio.diff
+++ /dev/null
@@ -1,25 +0,0 @@
---- Makefile.orig 2016-01-12 12:26:06 UTC
-+++ Makefile
-@@ -75,6 +75,11 @@ OBJS:=$(filter-out src/pulse.o, $(OBJS))
- LIBS:=$(filter-out -lpulse, $(LIBS)) -lpthread
- endif
-
-+ifeq ($(OS),FreeBSD)
-+OBJS:=$(filter-out src/pulse.o, $(OBJS))
-+LIBS:=$(filter-out -lpulse, $(LIBS)) -lpthread
-+endif
-+
- src/%.o: src/%.c include/i3status.h
- $(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@ $<
- @echo " CC $<"
---- src/print_volume.c.orig 2016-01-12 12:27:47 UTC
-+++ src/print_volume.c
-@@ -60,7 +60,7 @@ void print_volume(yajl_gen json_gen, cha
- free(instance);
- }
-
--#ifndef __OpenBSD__
-+#if !defined(__OPENBSD__) && !defined(__FreeBSD__)
- /* Try PulseAudio first */
-
- /* If the device name has the format "pulse[:N]" where N is the
diff --git a/x11/i3status/files/patch-src_print__volume.c b/x11/i3status/files/patch-src_print__volume.c
new file mode 100644
index 000000000000..a15fc4ed6fd0
--- /dev/null
+++ b/x11/i3status/files/patch-src_print__volume.c
@@ -0,0 +1,11 @@
+--- src/print_volume.c.orig 2019-01-23 08:03:56 UTC
++++ src/print_volume.c
+@@ -86,7 +86,7 @@ void print_volume(yajl_gen json_gen, char *buffer, con
+ free(instance);
+ }
+
+-#if !defined(__DragonFly__) && !defined(__OpenBSD__)
++#if !defined(__DragonFly__) && !defined(__OpenBSD__) && !defined(__FreeBSD__)
+ /* Try PulseAudio first */
+
+ /* If the device name has the format "pulse[:N]" where N is the
diff --git a/x11/i3status/files/patch-src_pulse.c b/x11/i3status/files/patch-src_pulse.c
new file mode 100644
index 000000000000..c7bdcb952a75
--- /dev/null
+++ b/x11/i3status/files/patch-src_pulse.c
@@ -0,0 +1,12 @@
+--- src/pulse.c.orig 2019-01-23 08:03:56 UTC
++++ src/pulse.c
+@@ -1,3 +1,4 @@
++#ifndef __FreeBSD__
+ // vim:ts=4:sw=4:expandtab
+ #include <config.h>
+ #include <string.h>
+@@ -337,3 +338,4 @@ bool pulse_initialize(void) {
+ }
+ return true;
+ }
++#endif