aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordhn <dhn@FreeBSD.org>2011-09-02 01:21:46 +0800
committerdhn <dhn@FreeBSD.org>2011-09-02 01:21:46 +0800
commit4f308daba17852b86b83aa8becdfc67d26337223 (patch)
treee7feed5f9afb2cd0c2c9b4f37c2de90546c7a736
parenta9f2ca1d80071860244c33971fd8f1201fde669c (diff)
downloadfreebsd-ports-gnome-4f308daba17852b86b83aa8becdfc67d26337223.tar.gz
freebsd-ports-gnome-4f308daba17852b86b83aa8becdfc67d26337223.tar.zst
freebsd-ports-gnome-4f308daba17852b86b83aa8becdfc67d26337223.zip
- Update to 1.8.3
PR: ports/160082 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
-rw-r--r--benchmarks/mdtest/Makefile36
-rw-r--r--benchmarks/mdtest/distinfo4
-rw-r--r--benchmarks/mdtest/files/patch-Makefile10
-rw-r--r--benchmarks/mdtest/pkg-descr2
4 files changed, 23 insertions, 29 deletions
diff --git a/benchmarks/mdtest/Makefile b/benchmarks/mdtest/Makefile
index c1ca40fab9d3..e557fead1426 100644
--- a/benchmarks/mdtest/Makefile
+++ b/benchmarks/mdtest/Makefile
@@ -6,41 +6,45 @@
#
PORTNAME= mdtest
-PORTVERSION= 1.7.1
-PORTREVISION= 4
+PORTVERSION= 1.8.3
CATEGORIES= benchmarks
-MASTER_SITES= http://www.llnl.gov/icc/lc/siop/downloads/
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20latest/${PORTNAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A filesystem metadata benchmark utility
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2011-09-01
-
-PLIST_FILES= bin/mdtest
+LICENSE= GPLv2
OPTIONS= OPENMPI "Use openmpi instead of mpich2" off
+MAN1= ${PORTNAME}.1
+PORTEXAMPLES= *
+PLIST_FILES= bin/${PORTNAME}
+
+CFLAGS+= -DDarwin
+
.include <bsd.port.pre.mk>
.if defined(WITH_OPENMPI)
BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
-RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:${PORTSDIR}/net/openmpi
+RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
MPICC= ${LOCALBASE}/mpi/openmpi/bin/mpicc
.else
BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/lib/libmpich.so:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
MPICC= ${LOCALBASE}/bin/mpicc
.endif
-USE_GMAKE= yes
-ALL_TARGET= mdtest
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%MPICC%%|${MPICC}|' ${WRKSRC}/${MAKEFILE}
+do-build:
+ cd ${WRKSRC} && ${MPICC} ${CFLAGS} -o ${PORTNAME} ${PORTNAME}.c
do-install:
- ${STRIP_CMD} ${WRKSRC}/mdtest
- ${INSTALL_PROGRAM} ${WRKSRC}/mdtest ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/scripts && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
+.endif
.include <bsd.port.post.mk>
diff --git a/benchmarks/mdtest/distinfo b/benchmarks/mdtest/distinfo
index 5ecdb2390a8f..bfe12bf1b10d 100644
--- a/benchmarks/mdtest/distinfo
+++ b/benchmarks/mdtest/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mdtest-1.7.1.tar.gz) = 1ebe974d1c275c2abb9ab06a09506ab908718f2e6a73780956d0a89db40c3024
-SIZE (mdtest-1.7.1.tar.gz) = 11344
+SHA256 (mdtest-1.8.3.tgz) = 1367d9518b1320242e31f76d2865fde6ba145c94c73143dfb4108d7f469ab4bd
+SIZE (mdtest-1.8.3.tgz) = 28721
diff --git a/benchmarks/mdtest/files/patch-Makefile b/benchmarks/mdtest/files/patch-Makefile
deleted file mode 100644
index 0609ddecb018..000000000000
--- a/benchmarks/mdtest/files/patch-Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.orig Sun Apr 29 16:35:18 2007
-+++ Makefile Sun Apr 29 16:42:07 2007
-@@ -21,6 +21,7 @@
-
- CC.AIX = mpcc_r -bmaxdata:0x80000000
- CC.Linux = mpicc -Wall
-+CC.FreeBSD = %%MPICC%% -Wall
-
- # Requires GNU Make
- OS=$(shell uname)
diff --git a/benchmarks/mdtest/pkg-descr b/benchmarks/mdtest/pkg-descr
index 3ba0939f5e1a..e9db2f3306f0 100644
--- a/benchmarks/mdtest/pkg-descr
+++ b/benchmarks/mdtest/pkg-descr
@@ -1,4 +1,4 @@
The mdtest software is used for testing the metadata
performance of a file system.
-WWW: http://www.llnl.gov/icc/lc/siop/
+WWW: http://sourceforge.net/projects/mdtest/