aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-07-19 22:05:36 +0800
committerrafan <rafan@FreeBSD.org>2008-07-19 22:05:36 +0800
commit5041a1f626dcbf738724ae682e345e7a71c70a1a (patch)
treec0e4b6c7f61b770226ca2757285b125b2f5e01de
parent5f0eddcbe187ddecb99b490d890cc6bfcf1842de (diff)
downloadfreebsd-ports-gnome-5041a1f626dcbf738724ae682e345e7a71c70a1a.tar.gz
freebsd-ports-gnome-5041a1f626dcbf738724ae682e345e7a71c70a1a.tar.zst
freebsd-ports-gnome-5041a1f626dcbf738724ae682e345e7a71c70a1a.zip
- Fix build on 6.3
PR: ports/125744 Submitted by: Cheng-Tao Lin <b89605222 at ntu.edu.tw> (maintainer)
-rw-r--r--x11/lxpanel/Makefile4
-rw-r--r--x11/lxpanel/files/patch-src-configurator.c19
-rw-r--r--x11/lxpanel/files/patch-src-panel.h10
-rw-r--r--x11/lxpanel/files/patch-src-systray-fixedtip.h11
-rw-r--r--x11/lxpanel/pkg-plist1
5 files changed, 40 insertions, 5 deletions
diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
index 4fe3b8c8dd41..90fd00292eb1 100644
--- a/x11/lxpanel/Makefile
+++ b/x11/lxpanel/Makefile
@@ -46,10 +46,6 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if ${OSVERSION} < 700000
-BROKEN= does not compile
-.endif
-
pre-patch:
@${REINPLACE_CMD} -e 's,linux,sys,' \
${WRKSRC}/src/plugins/volume/volume-impl.c
diff --git a/x11/lxpanel/files/patch-src-configurator.c b/x11/lxpanel/files/patch-src-configurator.c
new file mode 100644
index 000000000000..109c00d2c327
--- /dev/null
+++ b/x11/lxpanel/files/patch-src-configurator.c
@@ -0,0 +1,19 @@
+--- src/configurator.c.orig 2008-07-17 14:36:27.000000000 +0800
++++ src/configurator.c 2008-07-17 14:38:36.000000000 +0800
+@@ -46,6 +46,7 @@
+ void restart(void);
+ void gtk_run(void);
+ void panel_config_save(Panel* panel);
++void save_global_config(void);
+ static void logout(void);
+
+ Command commands[] = {
+@@ -532,7 +533,7 @@
+ gtk_box_pack_start( (GtkBox*)GTK_DIALOG(dlg)->vbox, scroll,
+ TRUE, TRUE, 4 );
+ view = (GtkTreeView*)gtk_tree_view_new();
+- gtk_container_add( (GtkContainer*)scroll, view );
++ gtk_container_add( (GtkContainer*)scroll, (GtkWidget*)view );
+ tree_sel = gtk_tree_view_get_selection( view );
+ gtk_tree_selection_set_mode( tree_sel, GTK_SELECTION_BROWSE );
+
diff --git a/x11/lxpanel/files/patch-src-panel.h b/x11/lxpanel/files/patch-src-panel.h
new file mode 100644
index 000000000000..6b992d768730
--- /dev/null
+++ b/x11/lxpanel/files/patch-src-panel.h
@@ -0,0 +1,10 @@
+--- src/panel.h.orig 2008-07-17 14:40:37.000000000 +0800
++++ src/panel.h 2008-07-17 14:41:21.000000000 +0800
+@@ -190,6 +190,7 @@
+ void panel_set_dock_type(Panel *p);
+ void panel_set_orientation(Panel *p);
+ void panel_update_background( Panel* p );
++void panel_destroy( Panel* p );
+
+ extern const char* lxpanel_get_file_manager();
+ extern const char* lxpanel_get_terminal();
diff --git a/x11/lxpanel/files/patch-src-systray-fixedtip.h b/x11/lxpanel/files/patch-src-systray-fixedtip.h
new file mode 100644
index 000000000000..f2a65f645934
--- /dev/null
+++ b/x11/lxpanel/files/patch-src-systray-fixedtip.h
@@ -0,0 +1,11 @@
+--- src/systray/fixedtip.h.orig 2008-07-17 14:48:22.000000000 +0800
++++ src/systray/fixedtip.h 2008-07-17 14:49:43.000000000 +0800
+@@ -52,6 +52,8 @@
+ void (* clicked) (NaFixedTip *fixedtip);
+ };
+
++ void fixed_tip_hide(void);
++
+ GType na_fixed_tip_get_type (void);
+
+ GtkWidget *na_fixed_tip_new (GtkWidget *parent,
diff --git a/x11/lxpanel/pkg-plist b/x11/lxpanel/pkg-plist
index d8c3adba0fe7..a987e18c23a8 100644
--- a/x11/lxpanel/pkg-plist
+++ b/x11/lxpanel/pkg-plist
@@ -65,7 +65,6 @@ lib/lxpanel/plugins/volume.so
@dirrmtry lib/lxpanel
@dirrm %%DATADIR%%/ui
@dirrm %%DATADIR%%/profile/default/panels
-@dirrm %%DATADIR%%/profile/default/config
@dirrm %%DATADIR%%/profile/default
@dirrm %%DATADIR%%/profile
@dirrm %%DATADIR%%/images