aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2014-10-05 08:06:03 +0800
committerjhale <jhale@FreeBSD.org>2014-10-05 08:06:03 +0800
commit505f5851f35c2bdacabadf9bdbd26eecc895d7a3 (patch)
tree2d4ff47e6b6879f9090c5d15dbd71b9679b51852
parentee001081559589c3fce6b5bb0d511f4fb7147fba (diff)
downloadfreebsd-ports-gnome-505f5851f35c2bdacabadf9bdbd26eecc895d7a3.tar.gz
freebsd-ports-gnome-505f5851f35c2bdacabadf9bdbd26eecc895d7a3.tar.zst
freebsd-ports-gnome-505f5851f35c2bdacabadf9bdbd26eecc895d7a3.zip
- Convert to USES=python, limit to 2.x
- Fix typo in RUN_DEPENDS - Simplify post-install - Remove PYAO option as the port builds a library for handling libao by default and py-ao would only be needed if that library wasn't built - Bump PORTREVISION
-rw-r--r--audio/pytone/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/audio/pytone/Makefile b/audio/pytone/Makefile
index 312aad9d8ae9..2740ccdee029 100644
--- a/audio/pytone/Makefile
+++ b/audio/pytone/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pytone
PORTVERSION= 3.0.3
+PORTREVISION= 1
CATEGORIES= audio python
MASTER_SITES= http://www.luga.de/pytone/download/ \
http://redundancy.redundancy.org/mirror/
@@ -15,29 +16,25 @@ LICENSE= GPLv2
LIB_DEPENDS= libao.so:${PORTSDIR}/audio/libao
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}mutagen>0y:${PORTSDIR}/audio/py-mutagen
+ ${PYTHON_PKGNAMEPREFIX}mutagen>0:${PORTSDIR}/audio/py-mutagen
-USES= ncurses
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+USES= ncurses python:2
+USE_PYTHON= autoplist distutils
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
SUB_FILES= pkg-message
PLIST_FILES= etc/pytonerc.sample
-OPTIONS_DEFINE= MAD MPG123 MPG321 PYAO VORBIS
+OPTIONS_DEFINE= MAD MPG123 MPG321 VORBIS
OPTIONS_DEFAULT= MAD VORBIS
MAD_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mad>0:${PORTSDIR}/audio/py-mad
MPG123_RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
MPG321_DESC= MP3 decoding support via mpg321
MPG321_RUN_DEPENDS= mpg321:${PORTSDIR}/audio/mpg321
-PYAO_DESC= ${AO_DESC}
-PYAO_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ao>0:${PORTSDIR}/audio/py-ao
VORBIS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}vorbis>0:${PORTSDIR}/audio/py-vorbis
post-patch:
@@ -48,8 +45,7 @@ post-patch:
.endfor
post-install:
- (cd ${WRKSRC}/conf && ${INSTALL_DATA} pytonerc \
- ${STAGEDIR}${PREFIX}/etc/pytonerc.sample)
+ ${INSTALL_DATA} ${WRKSRC}/conf/pytonerc ${STAGEDIR}${PREFIX}/etc/pytonerc.sample
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pytone/*.so
.include <bsd.port.mk>