aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2009-06-12 06:53:00 +0800
committerlwhsu <lwhsu@FreeBSD.org>2009-06-12 06:53:00 +0800
commit5090a86480162bb61f994e869f0f2f49b2133701 (patch)
tree66aadf6e9cbc775a8a597a8e097d8ae1a35d32a8
parent818df2de50ef64182daef300053d1c5a2f0dbb06 (diff)
downloadfreebsd-ports-gnome-5090a86480162bb61f994e869f0f2f49b2133701.tar.gz
freebsd-ports-gnome-5090a86480162bb61f994e869f0f2f49b2133701.tar.zst
freebsd-ports-gnome-5090a86480162bb61f994e869f0f2f49b2133701.zip
- Fix build for customized PREFIX and LOCALBASE
Submitted by: QAT
-rw-r--r--databases/py-pytc/Makefile7
-rw-r--r--databases/py-pytc/files/patch-setyp.py14
2 files changed, 14 insertions, 7 deletions
diff --git a/databases/py-pytc/Makefile b/databases/py-pytc/Makefile
index 9ecda66dd98f..5328f50579db 100644
--- a/databases/py-pytc/Makefile
+++ b/databases/py-pytc/Makefile
@@ -22,4 +22,9 @@ USE_PYDISTUTILS= yes
PLIST_FILES= %%PYTHON_SITELIBDIR%%/pytc.so
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${WRKSRC}/setup.py
+
+.include <bsd.port.post.mk>
diff --git a/databases/py-pytc/files/patch-setyp.py b/databases/py-pytc/files/patch-setyp.py
index fa7df2591cec..fb743d866567 100644
--- a/databases/py-pytc/files/patch-setyp.py
+++ b/databases/py-pytc/files/patch-setyp.py
@@ -1,11 +1,13 @@
---- setup.py.orig 2009-02-18 08:58:48.199458174 +0800
-+++ setup.py 2009-02-18 08:58:56.569760265 +0800
-@@ -5,7 +5,7 @@
+--- setup.py.orig 2009-06-12 02:49:50.405623403 +0800
++++ setup.py 2009-06-12 02:50:50.873879838 +0800
+@@ -8,8 +8,8 @@
if sys.version_info < (2, 3):
raise Error, "Python 2.3 or later is required"
-include_dirs = []
-+include_dirs = ['/usr/local/include']
- library_dirs = ['/usr/local/lib']
+-library_dirs = ['/usr/local/lib']
++include_dirs = ['%%LOCALBASE%%/include']
++library_dirs = ['%%LOCALBASE%%/lib']
- if sys.platform == 'darwin':
+ if sys.platform == 'linux2':
+ os.environ['PATH'] += ":/usr/local/bin:$home/bin:.:..:../.."