aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2018-01-27 03:32:07 +0800
committerpawel <pawel@FreeBSD.org>2018-01-27 03:32:07 +0800
commit50b085cb567c93c6cbfdc7a045da06585168ac29 (patch)
tree2a2717016ceac4cff18d55f88ec618f48a094169
parent6ebbfef5e03333c0b317f1f340ca52178b4d7a4e (diff)
downloadfreebsd-ports-gnome-50b085cb567c93c6cbfdc7a045da06585168ac29.tar.gz
freebsd-ports-gnome-50b085cb567c93c6cbfdc7a045da06585168ac29.tar.zst
freebsd-ports-gnome-50b085cb567c93c6cbfdc7a045da06585168ac29.zip
Take the role of an evil wizard and seek the ultimate knowledge of destruction.
Explore the world, murder innocent villagers and burn their homes. Build your dungeon, lay traps and prepare for an assault of angry heroes. When you control your minions the game becomes a classic roguelike, with turn-based and very tactical combat. You can also play as an adventurer and assault dungeons made by you or other players. WWW: http://keeperrl.com/
-rw-r--r--games/Makefile1
-rw-r--r--games/keeperrl/Makefile52
-rw-r--r--games/keeperrl/distinfo3
-rw-r--r--games/keeperrl/pkg-descr9
-rw-r--r--games/keeperrl/pkg-plist68
5 files changed, 133 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index d233f632a8ba..7495b5736486 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -477,6 +477,7 @@
SUBDIR += kcheckers
SUBDIR += kdegames4
SUBDIR += kdiamond
+ SUBDIR += keeperrl
SUBDIR += kevedit
SUBDIR += kfourinline
SUBDIR += kgoldrunner
diff --git a/games/keeperrl/Makefile b/games/keeperrl/Makefile
new file mode 100644
index 000000000000..8835e8d49aff
--- /dev/null
+++ b/games/keeperrl/Makefile
@@ -0,0 +1,52 @@
+# $FreeBSD$
+
+PORTNAME= keeperrl
+PORTVERSION= 0.0.${ALPHA_VERSION}
+CATEGORIES= games
+
+MAINTAINER= pawel@FreeBSD.org
+COMMENT= Ambitious dungeon builder with roguelike elements
+
+LICENSE= GPLv2 OFL11
+LICENSE_COMB= multi
+LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING.txt
+LICENSE_FILE_OFL11= ${WRKSRC}/data_contrib/SIL_Open_Font_License.txt
+
+BROKEN_FreeBSD_10= needs c++14, does not build even with clang5
+
+LIB_DEPENDS= libvorbis.so:audio/libvorbis \
+ libcurl.so:ftp/curl
+
+USES= gmake localbase openal
+
+USE_GITHUB= yes
+GH_ACCOUNT= miki151
+GH_TAGNAME= alpha${ALPHA_VERSION}
+USE_GL= gl
+USE_SDL= sdl2 image2
+
+ALPHA_VERSION= 23
+NO_CONFIGURE= yes
+LIBS+= -lexecinfo
+MAKE_ARGS= DATA_DIR="${DATADIR}" GCC="${CXX}" \
+ LDFLAGS="${LDFLAGS}" RELEASE=true
+
+DESKTOP_ENTRIES="KeeperRL" "" "" "keeper" \
+ "Game;Simulation;" false
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CFLAGS =/ s|=|= ${CFLAGS}|' \
+ -e '/^LIBS =/ s|$$| ${LIBS}|' \
+ -e 's|bash|sh|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} 's|bash|sh|' ${WRKSRC}/check_serial.sh
+ @${REINPLACE_CMD} '/_GLIBCXX_END_NAMESPACE_VERSION/d' \
+ ${WRKSRC}/extern/iomanip.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/keeper ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "data_contrib data_free" \
+ ${STAGEDIR}${DATADIR} "! -name *License.txt"
+
+.include <bsd.port.mk>
diff --git a/games/keeperrl/distinfo b/games/keeperrl/distinfo
new file mode 100644
index 000000000000..0a5c5a0e88f3
--- /dev/null
+++ b/games/keeperrl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1516986107
+SHA256 (miki151-keeperrl-0.0.23-alpha23_GH0.tar.gz) = 046cba3c8834f52f9e796d2deece8770b833d351eb222c216fdf65b0c1869979
+SIZE (miki151-keeperrl-0.0.23-alpha23_GH0.tar.gz) = 3252139
diff --git a/games/keeperrl/pkg-descr b/games/keeperrl/pkg-descr
new file mode 100644
index 000000000000..147b5ea846a4
--- /dev/null
+++ b/games/keeperrl/pkg-descr
@@ -0,0 +1,9 @@
+Take the role of an evil wizard and seek the ultimate knowledge of destruction.
+Explore the world, murder innocent villagers and burn their homes. Build your
+dungeon, lay traps and prepare for an assault of angry heroes.
+
+When you control your minions the game becomes a classic roguelike, with
+turn-based and very tactical combat. You can also play as an adventurer and
+assault dungeons made by you or other players.
+
+WWW: http://keeperrl.com/
diff --git a/games/keeperrl/pkg-plist b/games/keeperrl/pkg-plist
new file mode 100644
index 000000000000..e9a6c549b730
--- /dev/null
+++ b/games/keeperrl/pkg-plist
@@ -0,0 +1,68 @@
+bin/keeper
+%%DATADIR%%/data_contrib/Lato-Bol.ttf
+%%DATADIR%%/data_contrib/Symbola.ttf
+%%DATADIR%%/data_free/credits.txt
+%%DATADIR%%/data_free/images/frame.png
+%%DATADIR%%/data_free/images/icons.png
+%%DATADIR%%/data_free/images/morale_icons.png
+%%DATADIR%%/data_free/images/mouse_cursor.png
+%%DATADIR%%/data_free/images/mouse_cursor2.png
+%%DATADIR%%/data_free/images/spells.png
+%%DATADIR%%/data_free/images/splash2.png
+%%DATADIR%%/data_free/images/splash2a.png
+%%DATADIR%%/data_free/images/splash2b.png
+%%DATADIR%%/data_free/images/splash2c.png
+%%DATADIR%%/data_free/images/splash2d.png
+%%DATADIR%%/data_free/images/splash2e.png
+%%DATADIR%%/data_free/images/splash2f.png
+%%DATADIR%%/data_free/images/stat_icons.png
+%%DATADIR%%/data_free/images/team_icons.png
+%%DATADIR%%/data_free/images/ui/barthin.png
+%%DATADIR%%/data_free/images/ui/corner1.png
+%%DATADIR%%/data_free/images/ui/corner2X.png
+%%DATADIR%%/data_free/images/ui/corner2X_highlight.png
+%%DATADIR%%/data_free/images/ui/cornerBOTTOMR.png
+%%DATADIR%%/data_free/images/ui/cornerTOPL.png
+%%DATADIR%%/data_free/images/ui/cornerTOPR.png
+%%DATADIR%%/data_free/images/ui/cornermini.png
+%%DATADIR%%/data_free/images/ui/cornermini2.png
+%%DATADIR%%/data_free/images/ui/down.png
+%%DATADIR%%/data_free/images/ui/horibar.png
+%%DATADIR%%/data_free/images/ui/horibarmini.png
+%%DATADIR%%/data_free/images/ui/horibarmini2.png
+%%DATADIR%%/data_free/images/ui/horicorner1.png
+%%DATADIR%%/data_free/images/ui/horicorner2.png
+%%DATADIR%%/data_free/images/ui/horiline.png
+%%DATADIR%%/data_free/images/ui/horiline2.png
+%%DATADIR%%/data_free/images/ui/horimiddle.png
+%%DATADIR%%/data_free/images/ui/immigrant2bg.png
+%%DATADIR%%/data_free/images/ui/immigrantbg.png
+%%DATADIR%%/data_free/images/ui/menu_highlight.png
+%%DATADIR%%/data_free/images/ui/scrollbar.png
+%%DATADIR%%/data_free/images/ui/scrollmark.png
+%%DATADIR%%/data_free/images/ui/ui_highlight.png
+%%DATADIR%%/data_free/images/ui/up.png
+%%DATADIR%%/data_free/images/ui/vertbar.png
+%%DATADIR%%/data_free/images/ui/vertbar2.png
+%%DATADIR%%/data_free/images/ui/vertbarmini.png
+%%DATADIR%%/data_free/images/ui/vertbarmini2.png
+%%DATADIR%%/data_free/images/ui/vertibarmsg1.png
+%%DATADIR%%/data_free/images/ui/vertibarmsg2.png
+%%DATADIR%%/data_free/images/window_bg.png
+%%DATADIR%%/data_free/names/artifacts.txt
+%%DATADIR%%/data_free/names/aztec_names.txt
+%%DATADIR%%/data_free/names/creatures.txt
+%%DATADIR%%/data_free/names/cyclops.txt
+%%DATADIR%%/data_free/names/demons.txt
+%%DATADIR%%/data_free/names/dogs.txt
+%%DATADIR%%/data_free/names/dragons.txt
+%%DATADIR%%/data_free/names/dwarfs.txt
+%%DATADIR%%/data_free/names/first_female.txt
+%%DATADIR%%/data_free/names/first_male.txt
+%%DATADIR%%/data_free/names/gods.txt
+%%DATADIR%%/data_free/names/orc.txt
+%%DATADIR%%/data_free/names/town_names.txt
+%%DATADIR%%/data_free/names/vampires.txt
+%%DATADIR%%/data_free/names/world.txt
+%%DATADIR%%/data_free/sokoban_input.txt
+%%DATADIR%%/data_free/splash.txt