aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-12-24 05:36:47 +0800
committerantoine <antoine@FreeBSD.org>2013-12-24 05:36:47 +0800
commit50b33c4f9f1ae5ebcc3a8e3761c4626984c00b91 (patch)
treee431983d8320b9a89011fffcc879c007ce1d690c
parent1ddbe10709de5b8eb3573c6b41169e04971d762f (diff)
downloadfreebsd-ports-gnome-50b33c4f9f1ae5ebcc3a8e3761c4626984c00b91.tar.gz
freebsd-ports-gnome-50b33c4f9f1ae5ebcc3a8e3761c4626984c00b91.tar.zst
freebsd-ports-gnome-50b33c4f9f1ae5ebcc3a8e3761c4626984c00b91.zip
Fix PYTHON option after getting rid of implicit lang/python dependency
-rw-r--r--net/freeradius2/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index df49872d0ceb..1e0f202b5c43 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -178,6 +178,7 @@ USE_PYTHON= yes
CONFIGURE_ARGS+=--with-rlm_python \
--with-rlm-python-lib-dir=${PYTHON_LIBDIR} \
--with-rlm-python-include-dir=${PYTHON_INCLUDEDIR}
+CONFIGURE_ENV+= PYTHONBIN=${PYTHON_CMD}
PLIST_SUB+= RLMPYTHON=""
.else
CONFIGURE_ARGS+=--without-rlm_python
@@ -229,7 +230,7 @@ EXPM= yes
# Oracle support is experimental under FreeBSD
.if ${PORT_OPTIONS:MOCI8}
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-exec.c
-CONFIGURE_ENV= ORACLE_HOME="${ORACLE_HOME}"
+CONFIGURE_ENV+= ORACLE_HOME="${ORACLE_HOME}"
ORACLE_HOME?= ${LOCALBASE}/oracle8-client
BUILD_DEPENDS+= ${ORACLE_HOME}/lib/libclntst8.a:${PORTSDIR}/databases/oracle8-client
CONFIGURE_ARGS+=--with-oracle-home-dir=${ORACLE_HOME}/rdbms/demo